Jump to content

dia-do-acbr-online.png

Ganhe acesso a todas Palestras
Assinando o Suporte ACBr Comercial

Saiba Mais


dia-do-acbr-online.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

Perda comunicação ECF Epson TM-T900F


  • Este tópico foi criado há 953 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Bom dia Pessoal,

   Já li alguns tópicos comentando sobre, mais gostaria de reforçar essa questão para ver se mais alguém passa por esse problema. Tenho várias ECFs do modelo Epson TM-T900F que com o Windows 10 perdem comunicação.

   Estou utilizando a porta de comunicação por USB, com o controle porta ativado e o SerialParams BAUD=115200 DATA=8 PARITY=N STOP=1 HANDSHAKE=DTR/DSR MAXBANDWIDTH=0 SENDBYTESCOUNT=0 SENDBYTESINTERVAL=0.

   O driver da USB instalei a ultima versão disponível no site da Epson 7.0.0.0. Desabilitei a opção de suspensão seletiva das USBs e nos USB roots no gerenciamento de dispositivos desabilitei para não desligar a usb para economizar energia. Mesmo assim ocorre frequentemente da ECF perder comunicação e para resolver só desligando a ECF ou a maquina.

  Em anexo deixo o ACBrlog.txt e as imagens das opções que estou desabilitando no Windows. Também habilitei o log da InterfaceEpson e deixo em anexo, no fim é possível ver que ela retorna 'Restore USB port Fail'

acbrlog.txt

eplog_07.txt

energia.jpg

Link to post
Share on other sites
  • 1 month later...

Entrei e

Em 07/02/2018 at 11:16, douglas_k disse:

Bom dia Pessoal,

   Já li alguns tópicos comentando sobre, mais gostaria de reforçar essa questão para ver se mais alguém passa por esse problema. Tenho várias ECFs do modelo Epson TM-T900F que com o Windows 10 perdem comunicação.

   Estou utilizando a porta de comunicação por USB, com o controle porta ativado e o SerialParams BAUD=115200 DATA=8 PARITY=N STOP=1 HANDSHAKE=DTR/DSR MAXBANDWIDTH=0 SENDBYTESCOUNT=0 SENDBYTESINTERVAL=0.

   O driver da USB instalei a ultima versão disponível no site da Epson 7.0.0.0. Desabilitei a opção de suspensão seletiva das USBs e nos USB roots no gerenciamento de dispositivos desabilitei para não desligar a usb para economizar energia. Mesmo assim ocorre frequentemente da ECF perder comunicação e para resolver só desligando a ECF ou a maquina.

  Em anexo deixo o ACBrlog.txt e as imagens das opções que estou desabilitando no Windows. Também habilitei o log da InterfaceEpson e deixo em anexo, no fim é possível ver que ela retorna 'Restore USB port Fail'

acbrlog.txt

eplog_07.txt

energia.jpg

Entrei em contato com o pessoal da EPSON e o pessoal passou que o usuário do windows e o nosso aplicativo deve rodar como administrador. Alterei em algumas maquinas para testar e até então parece que normalizou. Vou continuar os testes e se isso realmente resolver volto a postar um modo de contornar essa situação.

  • Like 1
Link to post
Share on other sites
  • 1 month later...

Estamos com o mesmo problema em alguns clientes e a solução acima não resolveu.
Do nada perde comunicação e as vezes ao desconectar o cabo USB e reconectar a comunicação é retomada.
Ainda não conseguimos identificar um padrão, mas, se alguém tem passado por isso e puder dar uma ideia,
agradecemos muito.

Obrigado.

Link to post
Share on other sites
17 horas atrás, Jefferson Damian disse:

Existe uma forma de gerar um log da DLL interfaceepson.dll?
Porque um pessoal com esse mesmo problema entrou em contato com a Epson e eles pediram para anexar o log da ECF.
Mas o gerado pela DLL.

Desde já agradeço a atenção

Bom dia Jefferson,

   Para gerar o log da ECF edite o arquivo InterfaceEpson.xml que deve estar junto com a InterfaceEpson.dll e coloque o valor da chave <Log>1</Log> para 1. O caminho que ele irá salvar o log é definido pela chave <Path>C:\Epson\InterfaceEpson\DataFiles\</Path>. Em um teste que fiz ele salvou o arquivo com nome eplog_18.txt

  To anexando junto o arquivo InterfaceEpson.xml. O email do suporte da Epson que me atendeu foi de [email protected]

  Pessoal aqui na empresa tinha as maquinas bloqueadas pelo AD, limitando varias funcionalidades. Depois que colocamos os usuários do Windows como administradores os problemas aparentemente foram resolvidos, não ocorrendo mais as perdas de comunicação.

 Também vou colocar no corpo a resposta do suporte da Epson:

'Douglas, boa tarde.

 

Analisei os logs, verifiquei o momento em que a comunicação é perdida.

A versão da DLL está OK, não é antiga/defasada.

Neste caso é preciso que você execute seu software como administrador, dê todas as permissões para seu aplicativo e que seja o administrador.

Feito isso, não terá mais problemas.

 

Obs.: se seu PDV executar outro aplicativo, este também deve ser executado como administrador e conter todas permissões.'

InterfaceEpson.xml

Link to post
Share on other sites
  • Este tópico foi criado há 953 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...