Jump to content

Compre o Delphi
Com até 30% de desconto
e parcelado em até 12x sem juros

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Wesley Oliveira

Falha ao localizar o nó de Assinatura

Recommended Posts

Olá!

Estou começando a implementação do Reinf no meu sistema e ao tentar gerar os XML (Assinatura) está dando o erro

"Falha ao localizar o nó de Assinatura"

Tentei comparar com o que está sendo feito na aplicação exemplo do Reinf, mas aqui pra mim o exemplo apresenta o mesmo erro.

A configuração do ACBr feita no sistema é essa:

{ Configurações Gerais Reinf }
fACBrReinf.Configuracoes.Geral.FormaEmissao     := teNormal;
fACBrReinf.Configuracoes.Geral.ExibirErroSchema := True;
fACBrReinf.Configuracoes.Geral.SSLLib           := libCapicom;
fACBrReinf.Configuracoes.Geral.VersaoDF         := v1_04_00;

{ Configuração SSL }
fACBrReinf.SSL.DescarregarCertificado;

fACBrReinf.SSL.SSLDgst       := dgstSHA256;
fACBrReinf.SSL.SSLType       := LT_TLSv1_2;
fACBrReinf.SSL.SSLCryptLib   := cryWinCrypt;
fACBrReinf.SSL.SSLXmlSignLib := xsXmlSec;

Alguém tem idéia do que pode ser?

Obrigado.

Share this post


Link to post
Share on other sites
9 minutos atrás, Wesley Oliveira disse:

 

Bom dia, Wesley Oliveira.

Tente usar as seguintes configurações abaixo:

SSLLib := libWinCrypt;

SSLCryptLib := cryWinCrypt; 

SSLHttpLib := httpWinHttp;

SSLXmlSignLib := xsLibXml2;

SSLType := LT_TLSv1_2;


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
2 minutos atrás, Felipe E. Resende Mesquita disse:

Bom dia, Wesley Oliveira.

Tente usar as seguintes configurações abaixo:

SSLLib := libWinCrypt;

SSLCryptLib := cryWinCrypt; 

SSLHttpLib := httpWinHttp;

SSLXmlSignLib := xsLibXml2;

SSLType := LT_TLSv1_2;

Bom dia. Tentei aqui e continua com o mesmo erro..

Share this post


Link to post
Share on other sites
Agora, Wesley Oliveira disse:

Bom dia. Tentei aqui e continua com o mesmo erro..

Você está com as Dlls atualizadas?

  • Like 1

Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...