Jump to content

dev botao

Erro ao inicializar LibXML2


Go to solution Solved by Daniel Simoes,
  • Este tópico foi criado há 1540 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Prezados,

Estou com problema para geração do XML em um determinado cliente.

Já tentei algumas configurações do SSL e está dando erro de inicialização da Biblioteca da LibXML2.

Já copiei as Dll's para os dois systems;

Desmarquei em opções de internet TLS1.0

E mesmo assim continuo com o problema e o cliente parado.

Onde estou errando??? 

 

 

 

DLibX3.png

Link to comment
Share on other sites

  • Fundadores

Mantenha todas as dependências de DLL, apenas na mesma pasta do seu programa (mesma pasta do seu .exe)

http://svn.code.sf.net/p/acbr/code/trunk2/DLLs/LibXml2/x86/

Copie todas as DLLs da pasta do Link acima (e não apenas a principal)

  • Thanks 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Olá, Daniel, obrigado pela atenção.

Prezado eu fiz o seguinte para o cliente voltar a funcionar: Copie as DLL de um diretório mais antigo, porque, tenho um outro cliente com as mesmas características deste, ou seja,

W10, certificado A1 e tem estas DLL instaladas.. Resolveu este caso.

 

Daniel eu tenho clientes com diferentes SO. Desde W7, W10, Server 2008 e estou encontrando dificuldades em vários. Configurei meu sistema para que carregue as opções de SSL conforme cada empresa, mas, confesso a você está difícil. Tentei aplicar aquela configuração que você publicou como a ideal, mas, em vários clientes ocorreram problema. 

Tem uma opção ou manual que eu possa utilizar???

Mais uma vez, obrigado.

 

Link to comment
Share on other sites

  • Fundadores
  • Solution

Cada Sistema Operacional tem características diferentes...   Não há uma recomendação única para todos os sistemas Operacionais...

Mas para usar a Wincrypt com TLS12, é fundamental ter o Windows Atualizado completamente

Por favor detalhe melhor os problemas encontrados...

 

A única configuração que funcionará igual em todos os Sistemas Operacionais (mesmo no Linux), é usar libOpenSSL com certificados A1

 

  • Like 2
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Olá, Daniel.

 

Talvez este seja um dos problemas a atualização de windows que é feita por uns e outros não.

Como o cliente que ficou parado no sábado, funcionou com a ação que tomamos vou configurar cada cliente.

E se complicar de novo volto a solicitar ajuda... 

 

Obrigado

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.