Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

InternalErro 12002


Go to solution Solved by Joffas,

Recommended Posts

Boa tarde,

Alguém sabe dizer ao instalar o ACBR, o que exatamente acontece por baixo e oque esta faltando para funcionar...?

O problema é o seguinte, estava já a uns dois anos sem atualizar os componentes da ACBR, mas agora precisei do TSL 1.2 para consumir as NFe, então fui obrigado a atualizar.

Acontece que na máquina onde eu rodo o instalador "acbrinstall_trunk2.exe" a coisa funciona e na maquina onde não foi rodada não funca e apresenta o erro abaixo

 
 image.png.c47fca6ee7a2d158c9b76f0b8a4a461f.png

 

Já copiei todas as dlls para a pasta da aplicação, mais estou acho que tem algo que esta faltando no registro do windows ou variavel de ambiente...

Lista de Dlls copiadas para a pasta da aplicação e system32...

image.png.710dc69f8d80f92a2dd584e348bd0b0c.png

Link to post
Share on other sites

Boa tarde

2 anos é muito e tempo demais.

bom existem diversas coisas. por exemplo openssl tem que ser as versões superiores a 1.0 e tem no svn

deve também lembrar de instalar por exemplo o VisualC++ RunTime

https://github.com/abbodi1406/vcredist/releases

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to post
Share on other sites

Verdade, muito tempo mesmo rsss...

Mas a minha dúvida é a seguinte, existe alguma desta dlls que deve estar pré-configurada no windows para funcionar?

Não basta coloca-las na pasta da aplicação?

O que o instalador do ACBR registra por baixo dos panos para que a coisa funcione corretamente...rsss...

Link to post
Share on other sites
  • Solution

Obrigado pelas dicas @Juliomar Marchetti,

Descobri o problema é que antes o componente pegava o proxy da configuração do Windows.

Agora tenho que configurar no componente, e por coincidência a máquina que configurei o novo ACBR tinha um variável de Ambiente forçando o HTTP_PROXY.

 

vlw...

 

 

  • Like 1
Link to post
Share on other sites

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...