Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

logos

Texto.png

p200

D500 - Campo TP_ASSINANTE com valor incorreto


Go to solution Solved by Juliomar Marchetti,

Recommended Posts

Prezados, estamos tendo problemas com algumas notas de entrada de telecomunicações, não sei constatar se era uma problema com versões antigas do PVA que não validavam corretamente, ou se ninguém mesmo estava lançando notas de telecomunicações de entrada no componente da ACBR, falo isso porque olhando em guias antigos da EFD o campo TP_ASSINANTE é antigo, e a não obrigatoriedade para entrada também é.

Mas fato é que o arquivo texto está indo com zero quando informado o valor TP_ASSINANTE := TACBrTpAssinante.assNenhum; no registro D500, e como zero não está previsto nem mesmo quando obrigatório, acontece um problema de validação, pelo menos nessa versão do PVA atual.

Segue a correção em anexo, junto com algumas imagens para auxílio na verificação.

  • A relação de obrigatoriedade
    1814539268_ACBR3.thumb.png.4ee0526e01bafdd43098be5c6e85c448.png
  • Os valores válidos
    1762819961_ACBR2.thumb.png.a9dbba77f9b16234cb5f5636d4d246f0.png
  • A correção
    Arquivo: ACBrEFDBloco_D_Class.pas
    Linha: 1618
    1634738360_CorreoACBR1.thumb.png.8f4856dc0ab5c04d5de0a8b2227e3c4c.png

 

ACBrEFDBloco_D_Class.pas

 www.datalider.com.br - [email protected] - Macgayver Armini

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...