Jump to content

dev botao

Nao Consigo Instalar Componente Acbrnfedanfervcodebase


Go to solution Solved by Juliomar Marchetti,
  • Este tópico foi criado há 4207 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Moderadores

Acho que você não atualizou correto o SVN

O Isaque e Italo reformularam algumas units e criaram uma nova do dfeutil

caso você modifique seus fontes do componente pode ser que não tenha sido atualizado corretamente

Confere se todos os arquivos estão corretos com o SVN

  • Like 1
Consultor SAC ACBr Juliomar Marchetti
 

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
 

 

Link to comment
Share on other sites

O que me faz querer atualizar para a nova versão eh que qdo vou cancelar me informa erro de cabeçalho Atualizei os schemas mas nao funcionando continuou dando o erro. Acredito que estou com a nova versao pois puxei por svn, Eu preciso esta mesmo atualizando os componentes para esse erro? foi apos a atualização do dia 19 que o cancelamento parou. Atualmente meus clientes precisam consultar o numero da chave de acesso pelo site a baixar o xml, e cancelar pelo emissor gratuito.

Link to comment
Share on other sites

Instalando a nova versão

Documento := Trim(NotaUtil.LimpaNumero(Documento));

O delphi me aponta o seguinte erro

[Error] uNFe.pas(360): Undeclared identifier: 'LimpaNumero'

 

Como citei estou mudando a versao pois quando vou cancelar ou importa para o emissor gratuito da o seguinte erro.

Status descrição : Cabeçalho - Versão do arquivo xml não suportada. Isso começou a ocorrer após o dia 19

Link to comment
Share on other sites

  • Moderadores

Não existe no componente nenhuma Unit com o nome uNFe.pas

 

Nesta unit, que deve ser do seu sistema, vc deve adicionar no uses a unit ACBrDFeUtil e trocar a classe NotaUtil por DFeUtil

  • Like 1
djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Moderadores

Estude o demo.

 

ACBrNFe1.DANFE.ProtocoloNFe := ACBrNFe1.WebServices.ConsultaDPEC.nRegDPEC +' '+ DateTimeToStr(ACBrNFe1.WebServices.ConsultaDPEC.dhRegDPEC);

  • Like 1
djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

pessoal na primeira maquina que instalei funcionou permito tudo como cancelamento, passei agora para maquina do desenvolvimento quando compilo ele Acbrnfedanfervcodebase da a seguinte mensagem [Fatal Error] ACBrNFeDanfeRVCodeBase.dpk(76): Required package 'Rave65VCL' not found.

Preciso usar esse componente pois era o que ja usavamos.... 

Link to comment
Share on other sites

  • Moderadores
  • Solution

No caso ele quer usar o Rave na versão 65 e você deve ter outra versão 

então só remover a declaração desse pacote e compilar que o delphi vai automaticamente solicitar para você adicionar

a versão instalada em seu delphi

Consultor SAC ACBr Juliomar Marchetti
 

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
 

 

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.