Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

Maurício C. O. Medeiros

Membros
  • Content Count

    21
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Maurício C. O. Medeiros

  • Rank
    Novato

Profile Information

  • Sexo
    Masculino
  • Location
    Muriaé-MG - Brasil
  1. consegui resolver, mas não sei se é a melhor solução. eu adicionei um segundo componente ao formulário. ambos são preenchidos com os dados do boleto, mas um, o que grava o PDF, eu limpo a lista a cada registro, o outro uso para imprimir os boletos.
  2. o laço é grande, sim. resumindo, faço o seguinte: with cdsBoletos do begin Close; CommandText := 'consulta boletos'; end; ACBrBoleto.ListadeBoletos.Clear; while not(cdsBoletos.Eof)do begin with ACBrBoleto do begin //informo os dados do boleto //banco, cedente, vencimento, valor, observações end ACBrBoleto.ACBrBoletoFC.NomeArquivo:='diretorio do arquivo PDF'; ACBrBoleto.GerarPDF; cdsBoletos.Next; end; ACBrBoleto.Imprimir; //daqui para frente eu tenho um código para encontrar
  3. bom dia. tenho uma rotina de emissão de boleto onde: 1 - consulto a tabela de boleto 2 - dentro de um laço de repetição, mando as informações para o ACBrBoleto e salvo em PDF 4 - faço a impressão de todos os boletos 5 - por fim, faço o envio do PDF por e-mail os PDF são salvos separadamente, cada um com sua numeração, mas as informações (valor, cliente, etc) do primeiro boleto são repetidas para os demais. eu quero salvar um PDF para cada boleto. alguém já passou por isso? estou fazendo algo errado? tem alguma solução? desde já agradeço.
  4. e é justamento o fast que estou usando e está dando o problema. a cada documento eu escrevo em todos os campos e mando incluir na lista de boleto, usando o comando ACBrBoleto1.CriarTituloNaLista. após incluir todos, uso o comando imprimir.
  5. boa tarde. tenho uma rotina de impressão de boleto onde permito ao usuário selecionar e imprimir ao mesmo tempo documentos de bancos diferentes. para isso existe um cadastro de parâmetros de cobrança no meu sistema, onde são informados dados do banco, da cobrança, etc. ex.: documento 1 do banco do brasil, documento 2 do banco mercantil, documento 3 do sicoob os dados do documento são impressos corretamente, já o nome do cedente, que permito ao usuário informar qual será impresso, não atualiza, o mesmo é impresso em todos os boletos. revisando a rotina, vi que na lista
  6. sim, somente o logo sai em branco. o texto é impresso corretamente. não acho que seja problema na imagem, pois a mesma é usada em outros modelos de etiqueta. o problema só começou quando mudou a linguagem da impressora - antes usava uma com PPLA agora outra com PPLB. pelo ACBrEtq não funcionou, consegui imprimir enviando os comandos direto para impressora usando a linguagem da mesma. apesar de ter conseguido, vou fazer o que pediu. se conseguir resolver, prefiro utilizar o ACBrEtq a enviar os comandos direto.
  7. boa tarde. tenho vários clientes imprimindo etiqueta na impressora argox sem problemas. um cliente comprou uma impressora cuja linguagem é a PPLB ao invés da PPLA, a qual utilizo no sistema. fiz uma nova rotina de impressão para a linguagem, que tem suas diferenças, mas não consigo imprimir imagem. a imagem sai em branco. estou usando o ACBrETQ. alguém pode me ajudar? obrigado.
  8. boa tarde. estou usando o ACBrSPED PIS/COFINS e no bloco M115, de ajuste de crédito, estou deixando o campo COD_CTA em branco, mas o componente está preenchendo com zeros. na validação, usando o EFD, o arquivo está sendo rejeitado por isso e tenho que zerar o campo na mão para passar na validação e poder enviar o arquivo. mesmo se eu informar um valor, de acordo com a conta enviada no registro 0500, ele está preenchendo com zeros e também dá erro ao validar. ex.: envio COD_CTA = ''; o componente grava no arquivo texto da seguinte maneira: ...|00000000000000000000|...
  9. isso! tenho um ECF ligado ao computador por uma porta USB e uma gaveta ligada neste ECF. ambos são bematech. funcionava enquanto o ECF estava ligado por uma porta serial. ele foi trocado e agora é ligado pelo USB do computador.
  10. sim, mas usando a porta COM. usando USB é o primeiro cliente que me aparece. aí não consegui fazer comunicar.
  11. mas como fica a configuração da propriedade porta? coloco USB nela?
  12. boa tarde. estou desenvolvendo uma rotina de controle de gaveta de dinheiro e estou tendo problema na comunicação. a gaveta está ligada a um ECF e este ligado ao PC por uma porta USB. utilizo os componentes ACBrECF e ACBrGAV e não estou conseguindo fazer a comunicação. dá o seguinte erro: "communication error 2: o sistema não pode encontrar o arquivo especificado." o ACBrGAV comunica com a porta USB? como faço para configurar e usar? espero que me ajudem.
×
×
  • Create New...