Jump to content

Dercide Alvarez

Membros
  • Content Count

    607
  • Joined

  • Last visited

Everything posted by Dercide Alvarez

  1. Hoje tentei cancelar uma nota pela primeira vez, e também deu esse mesmo erro. Ai tivemos que cancelar no sistema da prefeitura, e pelo sistema consultei o RPS e atualizou os dados no banco de dados do nosso sistema. Vamos aguardar pra ver se o cancelamento funciona. Dercide Alvarez
  2. Hoje tentei cancelar uma nota pela primeira vez, e também deu esse mesmo erro. Dercide Alvarez
  3. @jairovianna O problema é que vc nao preencheu a tag xNome da entrega, por isso ta em branca. Dercide.
  4. @jairovianna Carreguei o XML que você enviou e os dados de ENTREGA sairam normalmente, conforme imagem em anexo. Talvez os teus fontes estejam desatualizados. Dercide.
  5. @jairovianna As informações de Entrega/Retirada estão saindo normalmente na Danfe do Fortes Report. Segue a imagem para confirmar. Dercide Alvarez.
  6. Bom dia @Destak Acho que as tuas configurações estão erradas, se esta passado o arquivo, deveria usar a OpenSSL. Eu atualizei os fontes hoje e esta tudo normal. NFEletronica.Configuracoes.Geral.SSLLib := libOpenSSL; NFEletronica.Configuracoes.Geral.SSLCryptLib := cryOpenSSL; NFEletronica.Configuracoes.Geral.SSLHttpLib := httpOpenSSL; NFEletronica.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2; NFEletronica.SSL.SSLType := LT_TLSv1_2; Dercide Alvarez
  7. @Italo Jurisato Junior Pelo o que reparamos é quando a NFSe enviada e em seguida imprime, ai sai bagunçado. Quando tentamos imprimir posteriormente, esta saindo normal. Eu ja tinha relatado essa questão em um tópico com você, e na época verificamos que o componente não assumia o caractere de quebra de pagina configurado.
  8. @Vinibarr Vinibarr Minha rotina de leitura funciona normalmente.... Talvez você não esteja usando as sintaxe correta, tente assim : for I := 0 to ACBrNFe1.NotasFiscais.Items[0].NFe.Det.Count-1 do begin with ACBrNFe1.NotasFiscais.Items[0].NFe.Det.Items do begin Descricao := Prod.xProd; Quantidade := Prod.qCom; Unitario := Prod.vUnCom; ValorTotal := Prod.vProd; Dercide.
  9. Bom dia, Não sei se já aconteceu com alguém esse problema, ou talvez, eu esteja fazendo alguma coisa errada e não percebi. Usando o FORTES REPORT. GINFES - Cidade de AMPARO - SP Hoje mesmo o cliente reclamou, "Imprimi saiu tudo bagunçado". Sai e entrei no sistema, imprimi "Saiu tudo certo". Esses tempos eu havia postado que o componente não respeitava a quebra de linha do INI, e usava sempre o pipe. O estranho é que as vezes imprime correto, e as vezes não. Ele tambem esta dizendo que a impressão sai cortada. (vai me mandar uma foto). Ja verificamos a configuração da impressora e esta tudo certo. Dercide.
  10. Boa tarde, Somente hoje consegui homologar a cidade de Amparo-SP pelo GINFES. Só inclui ela no cidades.ini e foi tranquilo. Dercide. Cidades.INI
  11. @Wladimir É a inscrição do TOMADOR e não a tua (PRESTADOR). É a do cliente que esta na nota, deve ter alguma inconsistencia nos dados que voce informou. Dercide.
  12. @Wladimir Já consultou na prefeitura pra verificar se existe alguma pendencia fiscal junto ao CADIN ? Não sei se é isso que esta provocando os erros. CNPJ_127097650001-84.pdf
  13. Boa tarde @Wladimir Segue a tabelas de códigos de serviços, dá uma conferida. https://www.prefeitura.sp.gov.br/cidade/secretarias/fazenda/servicos/iss/index.php?p=2497 instruo_normativa_sf-surem_ano_2011_n__08_anexo_1_atualizada_at_in_23-17_1545234368.xls
  14. @marcosfmr Você poderia compartilhar as alterações feita na demo ?
  15. @Ricardo de Lima Vc tem que baixar o componente, e quando compilar marcar as opções que deseja. Veja a tela a seguir :
  16. @patrick.knopf Através do Gerar eu tinha conseguido enviar notas essa semana, sem necessidade de consultar depois. Pensei que tinha usado o Enviar. Mas beleza, obrigado pelo retorno. Dercide Alvarez
  17. @patrick.knopf Você usou o Enviar para o envio ? Para a consulta foi ConsultaLoteRPS ? Dercide Alvarez
  18. Bom dia, Fiz a Homologação da cobrança CNB 240 do Santander, e houve uma critica em relação ao Código da Multas (G073). No caso não teria multa, apenas a mora diária, e o componente nesse caso, coloca ZERO ('0'), na posição 066-066 do registro R. Mas o banco aceita apenas 1- Valor fixo, 2- Percentual, independente se ter ou não ter multa, ou nesse caso não gerar o Registro R. Fiz o ajuste no ACBrBancoSantander.pas e foi homologada a cobrança. Antes: IfThen((PercentualMulta > 0), IfThen(MultaValorFixo,'1','2'), '0') + // 66 - 66 1-Cobrar Multa Valor Fixo / 2-Percentual / 0-Não cobrar multa Depois: IfThen((PercentualMulta > 0), IfThen(MultaValorFixo,'1','2'), '2') + // 66 - 66 1-Cobrar Multa Valor Fixo / 2-Percentual / 0-Não cobrar multa Segue o fonte para analise e possível atualização no componente. O que notei e diversos fontes, é que apesar do componente ter a propriedade CodigoMulta,, ela não é utilizada na maioria dos bancos. Dercide. ACBrBancoSantander.pas
  19. @Italo Jurisato Junior Atualizei os fontes e o INI. Tentei enviar a nota usando o ENVIAR, e setei para consultar após o envio, ele da erro que não foi implementado consultar Situação do Lote. Tentei enviar e depois consultar, não consigo consultar. No site da prefeitura consulto o Lote e o Protocolo, mas aparece que tem o erro E900. Desisti e tentei o Gerar que enviou normalmente. Dercide.
  20. @brunomeida As que eu emiti são em produção. Dercide Alvarez
  21. Vai entender...... Recompilei a aplicação (tinha compilado ontem a noite),,, tentei enviar, e consegui enviar 9 notas em produção. Espero que não de mais erro. Dercide Alvarez
  22. Bom dia, Ta complicado, ontem tentei enviar algumas notas, e de primeira enviei duas NFSe utilizando o Gerar. Depois fiz alguns ajustes e tentei enviar, e deu erro E900. Hoje o erro persistiu. Alguém esta conseguindo enviar notas ? Se sim, estão utilizando o Gerar ou Enviar ? Dercide Alvarez
  23. @BigWings Sim, sempre que posso acompanho as alterações e as atualizações, mas acredito que o que esta funcionando, não deva mudar, a não ser que esteja totalmente errado, e de qualquer forma foi implementado. Mas tranquilo, vou ver o que posso fazer para voltar a situação anterior e atender aos clientes que reclamaram. Dercide Alvarez
  24. @alphajoy Não foi a tua alteração que alterou a impressão, e sim a do link que foi relatado acima. Eu também acho que tem que ir para a pagina seguinte, mas tudo o que muda para os clientes, e nós não percebermos fica complicado, pois ficamos discutindo que nada foi alterado. Mas beleza, vou ver o que fazer para contornar a situação. Dercide Alvarez
×
×
  • Create New...