Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

Francis Silva

Membros
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

5 Neutral

1 Follower

About Francis Silva

  • Rank
    Novato
  • Birthday 07/04/1972

Contact Methods

  • Skype
    live:francis.lay.silva

Profile Information

  • Sexo
    Masculino
  • Location
    Manaus/AM

Recent Profile Visitors

965 profile views
  1. Até o momento sim, com exceção do módulo que usa o Indy que foi preciso desativar no arquivo .inc. Fora isso tudo tranquilo.
  2. Logo após ter postado o problema acima lembrei-me de um fato que ocorria sempre antigamente com os packages do Quickreport na época que eram utilizados no AcBr: sempre que lançavam uma versão nova NUNCA atualizavam os packages do Quickreport para a nova IDE. Então fui verificar os DPK para o FastReport e BINGO, lá estava o mesmo problema. Quem quiser resolver esse problema até que o Trunk seja atualizado basta acrescentar a linha abaixo no final de TODOS os DPK para o FastReport: {$IFDEF VER330} fs26, frx26, frxe26, frxDB26, dsnap, {$ENDIF} // Rio Problema resolvido. Se pudere
  3. Olá. Baixe a compilei a versão Rio do acBr2. A compilação e instalação dos packages é feita sem erros, mas quando abro o Delphi TODOS os packages de relatórios do fastreport dão os seguinte erros: Os outros dois packages restantes dão o mesmo erro 'Datasnap.Midas'. Alguém tem alguma ideia de qual seja o problema? Eu só utilizo o FR para relatórios. No Delphi 10.2 está normal. Grato.
  4. O problema é com o Windows 7, ele não encontra as libs mesmo elas estando no path. A solução que encontrei e que funcionou foi copiar todos os BPLs depois de compilados para a pasta $(BDSCOMMONDIR)\BPL, aí funcionou e instalou todos os componentes normalmente. O único problema é lembrar de excluir as BPLs dessa pasta antes de compilar uma nova versão do trunk, e depois copiar novamente para ela.
  5. 2 anos desde a última resposta para esse problema e ele ainda continua um mistério. Estou montando uma máquina com o Windows 7 64-bits e está dando exatamente o mesmo erro. Tanto pelo instalador quanto pela compilação manual todos os packages são compilados sem nenhum erro, mas quando são adicionados ao Delphi todos eles sem exceção dão esse mesmo erro "o dispositivo não está pronto". Não são arquivos velhos (o HD é novo; primeira instalação), é a ultima versão atualmente no repositório (revisão 15894) e no Windows 10 instala normalmente. Só no Windows 7 que não. Afi
  6. Olá, existe algum exemplo de como pegar o retorno da Carta de Correção utilizando os eventos ? Não estou muito familiarizado com o acBr ainda.
  7. Olá, atualizei o meu repositório para revisão 6840 e ao executar o ACBrInstall.exe percebi que o pacote "ACBr_SAT_Extrato_ESCPOS.dpk" não aparece na tela para ser selecionado e instalado. Abri os fontes do ACBrInstall e constatei que o pacote aparece normalmente no form. Compilei então o projeto e executei, e o pacote ficou disponível para instalação. Conclusão, falta apenas atualizar o executável do instalador para a próxima revisão. Obrigado.
  8. Finalmente consegui encontrar os fontes, o download é feito através de SVN. Para quem não conhece o endereço do repositório (como eu não conhecia) é https://svn.code.sf.net/p/fortesreport/svn/
  9. O problema é que não encontro os fontes do FortesReport, todos os arquivos que baixo do Source Forge ou do site do FortesReport vem já compilados, apenas as dcu's.
  10. O único extrato disponível para o SAT foi feito utilizando o FortesReport, entretanto este componente parou de ser atualizado na versão XE3 do Delphi, não consigo encontrar uma versão para o XE5 e por isso não consigo compilar o componente de extrato do SAT. Existe alguma versão deste extrato para o FastReport ou QuickReport? Se não houver tem algum projeto para lançar estes componentes? Obrigado.
  11. Eu fiz a alteração no ACBrInstall para instalar os pacotes da GNRE, mas não tenho acesso a atualizar o repositório. Será que algum moderador pode validar a minha atualização e atualizar o repositório? Os arquivos estão em anexo. Obrigado.NewACBRInstall.rar
  12. Saudações a todos. Fiz a atualização do meu repositório local dos fontes do ACBr para a revisão 6330 e percebi que novos fontes e packages foram adicionados na pasta chamada ACBrGNRE. Entretanto, apesar de existirem packages específicos para compilar estas novas rotinas, o instalador do ACBr não os compila e portanto não gera as suas BPL's. Estes novos pacotes são linkados automaticamente com outros pacotes já existentes ou eu devo compilá-los manualmente? Obrigado pela ajuda.
  13. Fiz uma nova correção nos DPK de relatórios do QuickReport. Os arquivos: ACBR\PACOTES\DELPHI\ACBr_BoletoFC_Quick.dpk ACBR\PACOTES\DELPHI\ACBrNFe2\ACBrCTeDacteQRpkg.dpk ACBR\PACOTES\DELPHI\ACBrNFe2\ACBrMDFeDAMDFEQRpkg.dpk ACBR\PACOTES\DELPHI\ACBrNFe2\ACBrNFeDanfeQRpkg.dpk ACBR\PACOTES\DELPHI\ACBrNFe2\ACBrNFeDanfeQRpkg_Delphi6.dpk não estavam fazendo referência a runtime library do QuickReport e por esse motivo, apesar de compilar normalmente, quando se abria o Delphi ocorriam vários erros de uma mesma unit estar sendo usado por mais de um package. O que fiz para corrigir o probl
×
×
  • Create New...