Jump to content

OldProgramer

Membros
  • Posts

    83
  • Joined

  • Last visited

Everything posted by OldProgramer

  1. Sim, seria até mais interessante do zero pois o emissor está muito "remendado". Como é industria, é cheio detalhes. Tem estado como o MT e CE que o cálculo é completamente diferente. E tem até cliente que por causa de liminar conseguem tratamento diferenciado. Pode variar ambas.
  2. Conecta, puxa o(s) registro(s), pra um componente de edição não db, desconecta e qdo a alteração for executada faz a conexão e o update.
  3. Algum colega tem algum fonte pra vender onde o próprio usuário pode criar suas templates pro modelamento de seu negócio? Ex: pra uma nota de remessa X o CST fica Y, desta ICMS mas não totaliza; é uma nota pra ZF cst Y, NCM Z, desconta ICMS do produto, etc; é nota com CFOP W, triangulada, recupera ST da entrada e desconta da saída, etc. Reforçando, modelamento pelo usuário final.
  4. Bom dia Juliomar. Realmente tinha na pasta de output. Apaguei todas pastas outputs. Eliminei todos os search paths do projeto e fiz uma limpa nas lib search's tbm. Re-instalei o ACBr novamente limpando arquivos antigos novamente e deixando apenas a libxx. Ao dar um build no meu projeto tive esse problema "[dcc32 Fatal Error] frxClass.pas(12063): F2051 Unit ACBrNFeDANFEFR was compiled with a different version of frxClass.TfrxReport". Não tenho nenhuma versão do FastReport a mais, só a 5.6.2. A título de teste, troquei pelo DanfeFortes e funcionou. Agora consegui recompilar meu projeto, porém sem os componentes ACBr Fastreport. Não tenho problemas em usar os do Fortes e aparentemente está funcionando tudo normal. De qualquer jeito agradeço a atenção e a ajuda.
  5. SSD zerado, instalação Win e ACBr nova. Até apaguei a ACBr_WinCrypt.dcu pra ver se ia acusar falta ou tava pegando de algum local que esqueci. Mas nada, acusou falta normalmente.
  6. Opa Juliomar, segue. Grato pela atenção. log_Delphi_XE8_Win32.txt
  7. Olá pessoal. Troquei meu SSD, instalei um Windows 10 e suas atualizações, instalei o meu XE8 e atualizei o ACBr. Executei a instalação pelo instalador, por via das duvidas apagando arquivos antigos e instalou normalmente. O que o corre é que ao dar um build na minha aplicação aparece: [dcc32 Fatal Error] ACBr_WinCrypt.pas(21489): F2051 Unit ACBrDFeWinCrypt was compiled with a different version of ACBr_WinCrypt.PCCERT_CONTEXT No meu note está normal e as minhas fontes vieram dele. Alguém pode me dar uma dica? Grato.
  8. Procuro desenvolvedor Deplphi para integração Pluug.to. Basicamente integrar o plugg.to (todas as suas funcionalidades) com uma base MySQL. Documentação da API: https://documenter.getpostman.com/view/249752/T1DpAwbJ?version=latest Interessados já enviem cotação e prazo em privado. Grato.
  9. Pra complementar: - incluindo a unit "frxGradient" no meu emissor não deu mais crash. Não sei porque pois nunca declarei manualmente antes essa unit e sempre usei normalmente tanto relatórios do fast como a própria DANFE. - retirei o raise do retorno no caso de rejeição e continuo o processamento pelo retorno e passe a usar assim aparentemente sem maiores problemas.
  10. Obrigado pela atenção Juliomar e Daniel. Separei o módulo de emissão de NFe do resto do meu sistema pra facilitar. Passou a assinar, enviar e receber normalmente, mas qdo há rejeição, ao ser gerado há exceção (raise EACBrDFeException.CreateDef(MsgErro)) ele apresenta "Invalid class type cast" e eu não consigo prosseguir para fazer o tratamento dessa rejeição. Tentei trocar a classe pela padrão do SysUtil mas nada.
  11. Outro coisa: como a demo funciona corretamente, a título de teste, incorporei a demo no meu sistema sem alterar absolutamente nada e caput! Erro no mesmo local.
  12. Debugando, foi no módulo 'assinatura', nesta chamada: Aí cai no 'finally' a seguir: E derruba a aplicação em:
  13. Obrigado BigWings e Elton. No meu desktop (exatamente a mesma versão e configuração do Delphi, exceto que está sob Win 8.1, ambas com o IDE FixPack) fiz agora a instalação e instalou normal. Eu estava fazendo no meu note. Realmente li sobre o erro interno e tal, mas realmente não acho nenhuma diferença nas duas instalações nem no procedimento que fiz pra atualizar ambos. Talvez algum corrompimento na instalação do Delphi já que o note é novo descartei problemas de hardware (q seria um estranhamento só dar problema nisso). Só de pensar em instalar tudo de novo no note já me dá arrepios...
  14. Fiz uma atualização dia 9/4 (apenas para atualização pois fazia uns 2 meses que não atualizava mas estava tudo funcionando 100%) e dei um build no meu sistema, a partir daí comecei a ter problemas com a NFe. Então desinstalei todos os componentes, apaguei a pasta toda de fontes do ACBr, baixei tudo novamente, apaguei os arquivos atigos como administrador e rodei o instalador (ver 1.5.0.3). Instala tudo normal menos os componentes do Fastreport e do Fortes. Compiling package C:\Fontes\ACBrwc\Pacotes\Delphi\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBr_NFeDanfeFR.dpk "C:\Program Files (x86)\Embarcadero\Studio\16.0\bin\dcc32.exe" "C:\Fontes\ACBrwc\Pacotes\Delphi\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBr_NFeDanfeFR.dpk" Embarcadero Delphi for Win32 compiler version 29.0 Copyright (c) 1983,2015 Embarcadero Technologies, Inc. C:\Fontes\ACBrwc\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFRDM.pas(42) Fatal: F2084 Internal Error: AV0050CF4B-W00400000-1 Compilation failure Erro ao compilar o pacote "ACBr_NFeDanfeFR.dpk". Abortando... Ocorreram erros na compilação dos pacotes. Compiling package C:\Fontes\ACBrwc\Pacotes\Delphi\ACBrDFe\ACBrNFSe\DANFSE\Fortes\ACBr_NFSeDanfseRL.dpk "C:\Program Files (x86)\Embarcadero\Studio\16.0\bin\dcc32.exe" "C:\Fontes\ACBrwc\Pacotes\Delphi\ACBrDFe\ACBrNFSe\DANFSE\Fortes\ACBr_NFSeDanfseRL.dpk" Embarcadero Delphi for Win32 compiler version 29.0 Copyright (c) 1983,2015 Embarcadero Technologies, Inc. C:\Fontes\ACBrwc\Fontes\ACBrDFe\ACBrNFSe\DANFSE\Fortes\ACBrNFSeDANFSeRL.pas(47) Fatal: F2084 Internal Error: AV00496D8E-W04B80000-1 Compilation failure Erro ao compilar o pacote "ACBr_NFSeDanfseRL.dpk". Abortando... Ocorreram erros na compilação dos pacotes. Alguém pode me dar uma dica? Uso Win10 e Delphi XE8, Fastreport 5 e Fortes atualizado. Manualmente tbm não instalam esses componentes. Grato a todos.
  15. Obrigado pela atenção Daniel. No momento do envio. Não mudei nada no processo, quer dizer, alimento o componente e depois uso o método "Enviar" com apenas o número do lote. Não uso o "Assinar". Se mando apenas gravar o XML sem assinar faz normalmente.
  16. Bom dia a todos. Estava emitindo NFe, manifestando, etc normalmente, mas depois de atualizar semana passada comecei a receber "Access violation" na hora de emitir a NFe ou manifestar. Atualizei os fontes, desinstalei os componentes do XE8, usei o instalador apagando o conteúdo anterior e dei um build geral mas o erro persiste. Uso WinCrypt, mas mesmo com OpenSSL (copiei as DLL's da versão 1.1.x e apaguei as enteriores) dá o mesmo erro. Alguém teve o mesmo problema ou pode me dar uma dica? Nem que for voltar a uma versão anterior dos fontes?
  17. Vi que o software gratuito mantém o controle local, ou seja, realmente não atualiza se foi manifestada por outro prg, no máximo aparece como "download feito". É que essa argumentação de que o controle do manifesto deve ser exclusivamente pela aplicação é bizarra. Numa empresa grande mais de uma pessoa pode fazer este tipo de trabalho, e até mesmo um computador/servidor pode falhar e a aplicação deve ser reiniciada em algum outro equipamento, logo, é patético não existir mais uma consulta direta sobre o estado (manifesto, etc) de uma NFe.
  18. Opa BigWings obrigado pela atenção. Aparece como não manifestada, aí que tá. Recebo que a operação foi aceita e tal, mas se consulto no software gratuito aparece como não manifestada. Não sei se no outro dia ou sei lá qual o tempo depois vai aparecer como manifestada, mas pro cliente isso parece estranho.
  19. Pessoal, qdo manifesto pelo meu sistema usando o ACBr (modo produção evidentemente), recebo normal o retorno 135, porém se abro o programa gratuito e puxo as notas, ela aparece como não manifestada. Os servidores são diferentes? É um atraso normal? Chefe ficou reclamando disso...
  20. Sim, me enganei, mas a questão continua sendo não haver preenchimento das tags: pFCP e vFCP dentro do ICMS.
  21. Olá colega. No seu XML não estão preenchidos as tags do FCP, aí não vai aparecer nada no PDF mesmo. Emito NFe's pro RJ tanto indústria como revenda e faz normalmente. As tags são pFCPST e vFCPST dentro do ICMS.
  22. Pode ser, mas como eu disse ("ontem ou ante ontem não lembro direito atualizei toda a pasta do acbr e mandei instalar do zero inclusive apagando arquivos antigos"). Como não apareceu nenhum problema do log do SVN não imaginei que tenha ficado algo desatualizado, mas enfim, problema resolvido. Eu apenas coloquei aqui para o caso de ter algo a ser verificado nos fontes.
  23. A declaração da classe pai está: function CalcularTamMaximoNossoNumero(const Carteira : String; const NossoNumero : String = ''; const Convenio: String = ''): Integer; virtual; e da filha function CalcularTamMaximoNossoNumero(const Carteira : String; NossoNumero : String = ''; Convenio: String = ''): Integer; override; Corrigindo a declaração no ACBrBancoBrasil compilou normal.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.