Jump to content

Marcio Vinicio da Silva

Membros
  • Content Count

    12
  • Joined

  • Last visited

Community Reputation

4 Neutral

About Marcio Vinicio da Silva

  • Rank
    Novato

Profile Information

  • Sexo
    Masculino
  • Localização
    Tupandi

Recent Profile Visitors

282 profile views
  1. Eu li o tópico. Estou usando todas as DLLs da pasta "\ACBr\DLLs\XMLSec\MinGW\32" Também compilei o ACBrMonitor com a opção "{$DEFINE USE_MINGW}" ativada. (removido o comentário no ACBr.inc). Todos os comandos referentes a NFe funcionam perfeitamente. Status, assinatura, envio, consulta, manifesto, etc. Realmente não sei o que pode estar causando o problema, visto que, apenas este comando do GNRE não funciona.
  2. Felipe, Fiz a alteração na configuração do certificado, conforme você sugeriu, mas agora tenho outra mensagem de erro: Projeto ACBrMonitor elevou classe exceção 'EACBrDFeException' com a mensagem: Erro Interno: 10091 Erro HTTP: 500 URL: https://www.testegnre.pe.gov.br/gnreWS/services/GnreLoteRecepcao Network subsystem is unusable No arquivo 'C:\Projeto\ACBrwc\Fontes\ACBrDFe\ACBrDFeHttpOpenSSL.pas' na linha 141: + sLineBreak + FHTTP.Sock.LastErrorDesc);
  3. Boa tarde Felipe, Acredito que sejam estas as informações que você precisa: -> Configuração SSL <- SSL Lib. = libOpenSSL SSL Type = LT_TLSv1_2 Crypt. Lib. = cryOpenSSL HTTP Lib. = httpOpenSSL XML Sign. Lib. = xsXmlSec Obrigado.
  4. Está ocorrendo o erro: "GnreLoteRecepcao error: ssl routines ssl3_read_bytes sslv3 alert bad certificate" Acontece ao executar o comando: GNRE.GerarGuia("c:\guia.ini") Os fontes do projeto ACBr foram sincronizados em 16/07. Todos os comandos referentes a NFe funcionam perfeitamente. Compilei uma versão em modo Debug com o Lazarus (2.0.2) e obtive o erro mais detalhado: Projeto ACBrMonitor elevou classe exceção 'EACBrDFeException' com a mensagem: Erro Interno: 10091 Erro HTTP: 500 URL: https://www.testegnre.pe.gov.br/gnreWS/services/GnreLoteRecepcao error:14094412:SSL routines:ssl3_read_bytes:sslv3 alert bad certificate No arquivo 'C:\Projeto\ACBrwc\Fontes\ACBrDFe\ACBrDFeHttpOpenSSL.pas' na linha 141: + sLineBreak + FHTTP.Sock.LastErrorDesc); O arquivo XML é criado. O erro ocorre na função "TDFeHttpOpenSSL.Enviar". Estou usando OpenSSL e as DLL's da pasta: \ACBr\DLLs\XMLSec\MinGW\32 Alguém teria alguma dica? ACBrMonitor.ini guia.ini HttpSendDocument.xml HttpSendHeader.xml
  5. Boa dia pessoal. Está ocorrendo o erro: "external: SIGSEGV", quando o ACBrMonitor vai assinar o XML. Eu sincronizei os fontes do projeto ACBr no dia 16/07/2019 e compilei com o Lazarus (versão 2.0.2) no Windows 7. Tudo parecia funcionar. Status do serviço, criar XML, consultar NFe, etc. Mas quando tento enviar a NFe ocorre o problema. Compilei uma versão em modo de "debug" e percebi que o erro acontece na linha 277 da "ACBrNFeNotasFiscais": FXMLAssinado := SSL.Assinar(String(XMLUTF8), 'NFe', 'infNFe'); -> Configuração SSL <- SSL Lib. = libOpenSSL SSL Type = LT_TLSv1_2 Crypt. Lib. = cryOpenSSL HTTP Lib. = httpOpenSSL XML Sign. Lib. = xsXmlSec Pensei que o problema pudesse estar relacionado a configuração ou as DLLs utilizadas, mas tudo funciona perfeitamente quando uso uma versão antiga do ACBrMonitor (1.2.0.11) compilada em Julho/2018 (colocada na mesma pasta da versão nova). Alguém já teve um problema semelhante? ACBr.inc ACBrMonitor.ini
  6. Juliomar. Fiz o teste sem o [exportInd], como você demonstrou e também não funcionou. Continuamos com o pensamento de que esquecemos de alguma informação extra ou algum outro detalhe como Finalidade, indFinal, idDest, etc ... não esteja com valor correto.
  7. Sim Juliomar. No arquivo .INI nós adicionamos a seguinte estrutura: [Produto001] CFOP=7501 ... [detExport] [exportInd] nRE=161936495008 chNFe=43161174178807000155550000000627401000000184 qExport=3.0000 Pensávamos que isso era suficiente para criar o grupo <detExport> no arquivo XML, mas não funcionou. Imagino que tenha alguma informação extra que esquecemos, ou algum outro detalhe como Finalidade, indFinal, idDest, etc ... que não está com valor correto e por isso o ACBrMonitor não cria o grupo.
  8. Em uma exportação usando CFOP 7501, o grupo <detExport> não é gerado quando a nota é criada através do arquivo .INI. Coloquei os arquivos em anexo. Estou usando a versão: 0.3.08.1 do ACBrMonitorPlus. Se alguém puder me ajudar, desde já agradeço. 850812_2_8.ini 43161200912882000161550020008508121000000180-nfe.xml
×
×
  • Create New...