Jump to content

renemelo

Membros Pro
  • Posts

    151
  • Joined

  • Last visited

1 Follower

About renemelo

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

renemelo's Achievements

Community Regular

Community Regular (8/14)

  • Reacting Well Rare
  • Dedicated Rare
  • First Post
  • Collaborator Rare
  • Conversation Starter

Recent Badges

8

Reputation

1

Community Answers

  1. certo, entendi. muito obrigado pelo esclarecimento.
  2. Bom dia, na verdade, mesmo no componente novo, se eu tento alterar o fonte para fazer um teste - sem desinstalar o componente e instalar de novo com o codigo alterado - parece que o delphi ignora o novo trecho de codigo. Vou dar um exemplo melhor : na unit ACBrNFSeXNotasFiscais - funcao LoadFromLoteNfse tem o seguinte trecho : TagF: Array[1..14] of String; Se eu alterar o tamanho do array para 15 ou 16 posicoes, o compilador "ignora" a alteracao no codigo e mantem em 14 posicoes. tenho a impressao que isso nao era assim antes, por que ja fiz alteracoes no codigo do acbr para testes. foi alterado alguma coisa nesse sentido ou estou viajando? obrigado.
  3. Boa tarde senhores, duas dúvidas. 1) Ao imprimir, quando carrega o XML, existe uma conversão para inteiro em "pcnLeitor" (Conforme imagem), que está trazendo este valor abaixo. 2) Alguns códigos, como este por exemplo, podemos alterar o fonte somente para teste ou tem que ser compilado novamente o ACBr? Se não me engano, antigamente dava. Grato.
  4. Obrigado, funcionou para a emissão da nota. Este fonte vai para ser baixado?
  5. Boa tarde senhores. Na prefeitura de Belford Rio me retorna o seguinte erro: <ErroMensagem>E165 - Alíquota do serviço inválida</ErroMensagem> Em anexo, estou colocando 2 arquivos, um válido, emitido pelo site e outro TESTE emitido pelo sistema, notem que na tag valores existe diferença, seria os schemas? Grato! RPS_VALIDADO_RIO.xml TESTE.XML
  6. entendi, muito obrigado pela resposta. nesse caso, o meu problema esta que como o ACBr nao acha a tag <nfse>, o componente volta como sucesso - ou seja - a nota foi emitida, mas sem os dados dela NotasFiscais.Count = 0. Com isso, não consigo mudar o status dentro do meu sistema, marcando a nota como emitida, já que não tenho as informações dela. Como vocês fazem no sistema de voces?
  7. muito obrigado pela resposta, mas eu baixei todos os manuais que constam para cidade de Araquari-SC e nao consegui achar essa informação. cliquei em todos os menus que aparecem no site e nao achei nada nem parecido com isso. sera que as opcoes para cada prefeitura sao diferentes?
  8. Bom dia estou com o mesmo problema e nao achei no site como alterar o modelo do retorno do XML. poderia dar um print da opcao pra que eu possa fazer aqui pra mim? obrigado
  9. Nao chega a matar ninguem obviamente, mas eu salvo o numero de serie do certificado em um ini para validar o certificado em uma outra operacao dentro do sistema. A minha pergunta foi so realmente pra saber se alguem passou pela mesma situação. Mas nao precisa ter nenhum tipo de ajuste por parte de vocês, eu vou ajustar aqui internamente pra contornar. obrigado pelo retorno.
  10. Nao vi se alguem passou por isso, mas quando carrega o certificado como OpenSSL, o componente retira os zeros da frente do numero de serie, mas no WinCrypt nao. Alguem ja passou por isso?
  11. Boa tarde Ema Canoas, ele nao chega a salvar o retorno por que na Unit ACBrNFSeXWebserviceBase, na procedure ChecarRetorno, o retorno do webservice cai no Raise, fazendo com que o SalvarRetorno(FPRetorno, Result) nao seja executado (ja que ele acontece apenas se nao deu um erro nas prcedures anteriores). Em anexo, uma consulta e remessa com o componente antigo que esta funcionando. Precisa que eu anexe novamente os arquivos com o componente novo? Canoas_Funcionando.zip
  12. Em Campinas/SP, tive problemas ao gerar o XML do RPS. na unit ISSDSF.GravarXml, tive que alterar essa linha de tcInt para tcStr NFSeNode.AppendChild(AddNode(tcStr, '#1', 'CodigoServico', 4, 5, 0, OnlyNumber(NFSe.Servico.ItemListaServico), '')); apesar disso, o numero do protocolo vem em branco - acho que no XML que volta da prefeitura, eles chamam de lote ao inves de protocolo e nao vem os dados da NFe no XML, vem alguns dados do RPS Obs : usando o lote como "protocolo", a consulta nao falha, mas tambem nao vem o XML da NFSe. Um outro detalhe que vale a pena destacar é que o retorno do XML na consulta do lote volta o numero da nota e data da emissao, mas nao retorna os outros dados da nota. Com isso, a rotina que preenche o componente dá erro de conversao para Inteiro onde o componente vai ser carregado com os dados do municipio do tomador e do prestador por que o XML que retorna da prefeitura tambem nao esses dados. segue o XML para AnaliseCampinas.zip
  13. Apos atualizar o componente para a nova versao, na cidade de Canoas/RS do provedor Abaco, da o seguinte erro ao usar a propriedade ACBrNFSeX.Emitir e tambem ao ConsultarLoteRPS : SOAP-ENV:Client - Error reading e:ConsultarLoteRps.Execute No meu exemplo eu fiz duas notas : as duas deram o erro ao tentar emitir. uma delas eu emiti com o componente ACBrNFSe para testar e emitiu normalmente. segue os arquivos XML para a analise. Canoas.zip
  14. bom dia, certo, vou proceder conforme voce falou.
  15. Conclui meus testes na migração do ACBrNFSe para ACBrNFSeX. vou colocar o resultado de todos aqui, mas se essa nao for a maneira correta, me avisem que eu abro de novo, do jeito certo. ---------------------------- Guarulhos/SP : OK Contagem/MG : OK Curitiba/PR : OK --------------------------------- Cabo de Santo Agostinho/PE: transmitiu o RPS mas nao carregou o XML do retorno -> timeout prefeitura - vou continuar tentando consultar o lote, talvez seja problema na prefeitura mesmo. Simoes Filho/BA : nao carregou o schema da pasta para emitir. A propriedade ACBrNFSeX.Configuracoes.Arquivos.PathSchemas aponta para a pasta raiz, os provedores estao em uma subpasta do diretorio. para essa cidade, o componente nao acha a subpasta com os schemas. para as demais prefeituras, ele acha sozinho. Canoas/RS : erro ao consultar o lote -> SOAP-ENV:Client - Error reading e:ConsultarLoteRps.Execute obs : Deu o mesmo erro no ACBrNFSeX.Emitir CMP : na unit ISSDSF.GravarXml, tive que alterar essa linha de tcInt para tcStr NFSeNode.AppendChild(AddNode(tcStr, '#1', 'CodigoServico', 4, 5, 0, OnlyNumber(NFSe.Servico.ItemListaServico), '')); apesar disso, o numero do protocolo vem em branco - acho que no XML que volta da prefeitura, eles chamam de lote ao inves de protocolo e nao vem os dados da NFe no XML, vem alguns dados do RPS Obs : usando o lote como "protocolo", a consulta nao falha, mas tambem nao vem o XML da NFSe. Viana/ES : erro 500 na ACBrNFSeX.Emitir e tambem ao consultar o lote. Obs : em anexo os XML, caso queiram verificar alguma coisa. Campinas.zipViana.zipCanoas.zipCabo de Santo Agostinho.zipSimoes Filho.zip
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.