Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

germanojedi

Membros
  • Content Count

    10
  • Joined

  • Last visited

  • Days Won

    1

germanojedi last won the day on May 1 2014

germanojedi had the most liked content!

Community Reputation

2 Neutral

About germanojedi

  • Rank
    Novato
  • Birthday 11/03/1976

Profile Information

  • Sexo
    Masculino
  • Location
    Fortaleza

Recent Profile Visitors

326 profile views
  1. Também estou com o mesmo problema com o Acbr_GNRE, porém não aparece aonde possa desmarcar tal opção.
  2. Ok. Vou fazer dessa forma e refazer os testes. Obrigado
  3. Envio em anexo o log de um cupom com acréscimo. acbrlog.txt
  4. Bom, acho que encontrei uma forma de resolver o problema. Sempre que existe acréscimo no cupom coloquei esse comando: ACBrAAC1.AtualizarValorGT(.ACBrECF1.NumSerie,.ACBrECF1.GrandeTotal); Com isso eu forço o AAC a atualizar o GT.
  5. Olá, realmente fiz conforme fui instruído. O arquivo sem o comando de recriar atualizou sozinho, apenas pela ligação dos componentes, porém percebi que ao fazer cupom com acréscimo no final o grande total do arquivo não foi atualizado, ficando o GT diferente da ECF. A partir desse ponto não se consegue fazer um novo cupom até por uma questão de segurança. A questão é: existe alguma configuração a mais para que o arquivo criptografado se atualize quando houver acréscimo ou teria que atualizar as dlls?
  6. Bom saber, vou retirar esse comando. Existe aonde obter essas configurações?
  7. Homologuei o programa usando os exemplos de cada componente. Não tive problemas, exceto no AcbrAAC. Sempre que se mexe no Grande Total estou usando o comando recriarArquivoAuxiliar para atualizar o arquivo auxiliar criptografado. Quando o finalizo o cupom caso haja acréscimo atualizo mais uma vez com o comando de recriar. Porém em algumas vezes dá uma mensagem de Ecf não respondendo como se o programa se desconectasse da impressora e não consegue mais acesso. O programa só volta a funcionar quando recrio o arquivo auxiliar via um outro programa nosso de suporte. Alguém já passou por algo parec
  8. Como já havia dito no post anterior já compilei todos os pacotes e executei o Acbr Install novamente mas sem êxito. Já até pensei que pudesse ser o caminho do repositório errado mas usei o caminho novo que está no forum que é esse svn://svn.code.sf.net/p/acbr/code.
  9. Olá. Estou com um problema parecido com os relatados aqui. Após atualizar o Acbr fui abrir o exemplo ACBR_PAF_Demo e está aparecendo erro no Image1.ExplicitWidth como se a propriedade não existisse. Quando vou compliar o projeto mostra erro nessa linha with ACBrPAF.PAF_R.RegistroR01.New (Undeclared identier) Já complilei novamente os pacotes atualizados e até usei o Acbr Install novamente mas não resolveu o problema. Gostaria de saber o que poderia estar causando o erro.
  10. Depois de muito procurar aqui não encontrei nenhuma resposta. Gostaria de saber porque sempre que linko o Componente AcbrECF no AcbrAAC ao abrir a aplicação diz que a ECF não está conectada. Basta tirar a ligação entre os componentes que conecta normal. Existe algo que possa causar esse erro. Observei que no Demo no AcbrAAC não existe ligação entre ele e o AcbrECF, embora aqui no forum já tenham dito que seja necessário. Grato pela atenção.
×
×
  • Create New...