Jump to content

botao.pngbotao.png

botao.pngbotao.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

Edevair Viesa Junior

Usuários SAC
  • Content Count

    298
  • Joined

  • Last visited

Community Reputation

54 Excellent

1 Follower

About Edevair Viesa Junior

  • Rank
    Membro Ativo
  • Birthday 08/16/1977

Profile Information

  • Sexo
    Masculino
  • Location
    : São Caetano do Sul - SP

Recent Profile Visitors

1,304 profile views
  1. @BigWings deu certo sim, realmente não atualizava há algum tempo mesmo.... Agradeço a ajuda. Pode fechar o tópico por favor... Muito Obrigado !
  2. Estão ocrrendo também os seguintes erros : [dcc32 Error] FUVAREJO.pas(5052): E2003 Undeclared identifier: 'TACBrHandShake' [dcc32 Error] FUVAREJO.pas(5053): E2003 Undeclared identifier: 'TACBrSerialParity' [dcc32 Error] FUVAREJO.pas(5054): E2003 Undeclared identifier: 'TACBrSerialStop' [dcc32 Error] FUVAREJO.pas(5175): E2003 Undeclared identifier: 'TACBrPessoa' [dcc32 Error] FUVAREJO.pas(5265): E2003 Undeclared identifier: 'atSim' [dcc32 Error] FUVAREJO.pas(5269): E2003 Undeclared identifier: 'atNao'
  3. Bom dia. Minha aplicação roda 100% no Delphi Berlin, eu estou migrando para o Delphi Rio e estou tendo um erro ao compilar. O erro é na linha do aceite no boleto. v_titulo := ACBrBoleto.CriarTituloNaLista; with v_titulo do begin Vencimento := Now; DataDocumento := Now; NumeroDocumento := '1'; EspecieDoc := 'DM'; EspecieMod := 'R$'; Aceite := atNao; //Aqui Gera o Erro DataProcessamento := Now; Carteira := '1'; NossoNumero := '1'; ValorDocumento := 0; with Sacado do begin NomeSacado := g_nume
  4. @Daniel Simoes problema resolvido, era exatamente isso. Muito Obrigado pelas informações. Moderador, pode fechar o post. Muito Obrigado !
  5. @Daniel Simoes muito obrigado. Vou orientar o cliente e retorno com o resultado.
  6. Pessoal, estou com um problema em um cliente, não sei nem se isso existe, mas a contabilidade de um cliente solicitou que seja feita uma carta de correção de alguns CFes emitidos que estão com o CFOP errado. O cliente cadastrou o produto no sistema conforme a NFe do fornecedor e nestas NFes os produtos vieram com o CFOP 5401 ou 6401, o cliente cadastrou com 5401 no sistema e emitiu um monte de CFes, a contabilidade efetuou a escrituração e enviou uma nota a ele solicitando qeu seja feita uma carta de correção destes CFes que foram emitidos com o CFOP 5401 para 5405 já que o cliente é simples n
  7. @Daniel Simoes eu tentei usar o comando sim, inclusive usando o spooler do windows com o RAW mas mesmo assim não abriu a gaveta... @BigWings o teste é feito apenas na abertura da gaveta sem impressão, nem esc pos e nem spooler.... Agradeço aos dois pelas dicas, mas acabei achando a solução... Aliás uma das dicas ajudou bastante, de acordo com a informação do @Daniel Simoes referente ao compartilhamento, eu fiz a desinstalação TOTAL da impressora incluindo o spooler, aí instalei ela novamente, mas usando o método de instalação de Porta Serial Virtual, conforme artigo aqui mesmo do
  8. Coloquei um teste de ativação e a ativação vai rápido mesmo, o que está demorando é o envio do comando para abertura...
  9. Exato, reparei exatamente nisso e retirei no meu sistema isso, achoi que estava indo pq usei da mesma forma que uso para impressão, com uma variável TStringList if g_usa_padrao_gaveta_esc_pos = 'S' then begin {v_texto := TStringList.Create; v_texto.Add('</abre_gaveta>'); MD.ACBrPosPrinterGaveta.Buffer.Add(v_texto.Text); MD.ACBrPosPrinterGaveta.Imprimir; v_texto.Free;} MD.ACBrPosPrinterGaveta.Buffer.Add('</abre_gaveta>'); MD.ACBrPosPrinterGaveta.Imprimir; end else begin {v_texto := TStringList.
  10. Ok. Eu mudei a configuração dos tempos, segue o log : -------------------------------------------------------------------------------- ATIVAR - 28/04/20 09:03:13:259 - Modelo.: EscElgin - TimeOut: 3 - Arquivo: \\localhost\VOX -------------------------------------------------------------------------------- -- 28/04 09:03:13:279 - LerStatusImpressora( 1 ) -- 28/04 09:03:13:279 - stNaoSerial, -- 28/04 09:03:13:279 - Imprimir, Copias:1, DecodificarTags:SIM, TraduzirTags:SIM -- 28/04 09:03:13:284 - </abre_gaveta>[CR][LF][LF] -- 28/04 09:03:1
  11. Em todas as outras impressoras e marcas tudo ok, funcionando perfeito, sei que o problema é com meu sistema, só não sei onde estou errando. Só com a vox que não vai...
  12. @Daniel Simoes olha eu voltando mais uma vez com este problema... Ainda não consigo fazer abrir a gaveta usando uma impressora VOX (em todos os clientes, deve ter uns 5 que ainda usam este demônio de impressora velha) Segue o trecho do Log, no PosPrinterTeste eu consigo abrir a gaveta e no meu sistema não.... Log Meu Sistema (Aqui não abre a gaveta) -------------------------------------------------------------------------------- ATIVAR - 27/04/20 18:23:31:659 - Modelo.: EscElgin - TimeOut: 3 - Arquivo: \\localhost\VOX ---------------------------------------------
  13. @Italo Jurisato Junior eu preciso gerar o XML completo para imprimir o evento, gerar um PDF para envio pro Cliente. Por isso preciso do arquivo. A maior dúvida é pq o XML da carta de correção não está sendo gerada no disco !
  14. @EMBarbosa muito obrigado !!! @Italo Jurisato Junior vamos lá, o que ocorreu foi o seguinte, o cliente gerou a NFe e deu erro de consumo indevido, após isso, foi efetuada novamente a mesma NFe, como deu erro de consumo indevido a numeração da NFe não deu sequencia, pois o resultado da entrega da NFe à sefaz foi negativa, como deu erro não sei se a NFe foi recebida pela sefaz, o sistema entende que a NFe não foi efetuada, porém ao gerar novamente a mesma NFe usando o mesmo número, eis que deu erro de Duplicidade de NFe, então paramos e fomos efetuar a consulta MANUALMENTE na sefaz pela cha
  15. Conosco aconteceu também, mas pulamos anumeração e informamos a contabilidade de cada cliente o ocorrido. Não sei se este é o procedimento correto, mas foi o que fizemos...
×
×
  • Create New...