Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

Seja-Profissional-Saiba-mais.png Beneficios_banner.png

 

fefevilela

Membros Pro
  • Posts

    111
  • Joined

  • Last visited

Everything posted by fefevilela

  1. estava e eu mudei para prEsquerda e de nenhum modo ele mostra o canhoto.. não entendi o motivo
  2. Estou usando o FAST na versão 6.9.3
  3. Pessoal, boa tarde. Não estou conseguindo fazer o dacte_paisagem exibir o canhoto (LATERAL ESQUERDA). Qual propriedade preciso acionar para que seja exibido?
  4. Até poderia... Mas só está ocorrendo isso com este componente> Vou instalar o FORTES apenas na 10.4 e remover do 11 até que tenhamos uma solução mais elaborada para o tema. Obrigado. Peço fecharem o tópico.
  5. Pessoal, fiz o procedimento citado pelo @Juliomar Marchetti porem o problema persiste. Ele instala o delphi 10.4 normalmente. Quando ele vai compilar o 11, ele está buscando o pacote no LIB27 do Fortes ao inves de buscar na pasta LIB28. Já verifiquei que no Fortes as instalações estão separadas em LIB27 e LIB28 No ACBr ele gera a pasta LIB27 e instala. Tambem gera a pasta LIB28 e compila os pacotes normais do ACBr. Quando chega no pacote FORTES ele dá o erro conforme descrito abaixo onde pode ser claramente visivel que ele está apontando para o pacote errado. Acredito que seja algo no instalador do ACBr mesmo. Cleaning package cache for ACBrDFeReportRL.bpl Cleaning ok Compiling package D:\projetos\Componentes\ACBr\Pacotes\Delphi\ACBrDFe\ACBrDFeReportRL.dpk D:\Programas\Embarcadero\Studio\22.0\bin\dcc32.exe "D:\projetos\Componentes\ACBr\Pacotes\Delphi\ACBrDFe\ACBrDFeReportRL.dpk" Embarcadero Delphi for Win32 compiler version 35.0 Copyright (c) 1983,2021 Embarcadero Technologies, Inc. D:\projetos\Componentes\ACBr\Fontes\ACBrDFe\ACBrDFeReportFortes.pas(48) Fatal: E2213 Bad packaged unit format: D:\projetos\Componentes\FortesReport\trunk\Binary\LibD27\frce.dcp.RLReport - Expected version: 35.0, Windows Unicode(x86) Found version: 34.0, Windows Unicode(x86) Compilation failure Erro ao compilar o pacote "ACBrDFeReportRL.dpk". Abortando... Ocorreram erros na compilação dos pacotes.
  6. Já fiz isso.. foi feito a remoção completa e instalado a ultima versão baixada... Vou tentar a solução do @Juliomar Marchetti
  7. O problema é que eu temnho mesmo duas versão (10.4 e a 11) ambas precisam conviver simulataneamente durante um tempo, até que os BUGs dos componentes utilizados sejam adequados. O FASTReports instalou perfeitamente, o problema está residindo apenas na instalação do FORTES
  8. Pessoal, Ao tentar instalar o ACBr no Delphi 11 Alexandria, o instalador aborta a instalação devido estar buscando o pacote do Fortes ERRADO. Segue o LOG da compilação Cleaning package cache for ACBrDFeReportRL.bpl Cleaning ok Compiling package D:\projetos\Componentes\ACBr\Pacotes\Delphi\ACBrDFe\ACBrDFeReportRL.dpk D:\Programas\Embarcadero\Studio\22.0\bin\dcc32.exe "D:\projetos\Componentes\ACBr\Pacotes\Delphi\ACBrDFe\ACBrDFeReportRL.dpk" Embarcadero Delphi for Win32 compiler version 35.0 Copyright (c) 1983,2021 Embarcadero Technologies, Inc. D:\projetos\Componentes\ACBr\Fontes\ACBrDFe\ACBrDFeReportFortes.pas(48) Fatal: E2213 Bad packaged unit format: D:\projetos\Componentes\FortesReport\trunk\Binary\LibD27\frce.dcp.RLReport - Expected version: 35.0, Windows Unicode(x86) Found version: 34.0, Windows Unicode(x86) Compilation failure
  9. Olá pessoal. Comecei a receber esse tipo de erro para quaisquer cartas de correção que tento enviar para CT-e. Estou abrindo esse tópico pois não consegui ver nenhum atualizado que possa identificar o problema. Poderiam me informar o que pode estar errado ? 1-eve-soap.xml 1-ped-eve-soap.xml
  10. Pessoal.. Acho que eu to ficando maluco.... Refiz a atualização para a ultima 20793, gerei a NF e enviei e agora deu certo... segue anexo as evidencias O RPS vai com a aliquota dividida por 100 e 4 decimais, o xml da nfse volta com aliquota inteiro. O que nao entendo é como a ginfes estava reclamando que a aliquota estava indo com a formatação errada???? observem a resposta que estava recebendo ontem na imagem erro ontem.jpg peço finalizarem o topico então. 9573UNICA-nfse.xml 9573UNICA-rps.xml
  11. ok.. estou preparando um teste completo com a revisao 20723 e a revisao 20793.. vou postar aqui as duas evidencias e teremos como descobrir o que esta interferindo....
  12. eu me pautei na revisao 20723 pois era a ultima que eu estava utilizando e tudo funcionava corretamente. Eu sei que nao foi nessa versão que foi feito alguma alteração, mas as evidencias são que a aliquota nessa revisão gera numero inteiro e corresponde ao que a prefeitura espera. A partir da alteração feita, onde voce publicou a revisão feita pelo colega Willian, a coisa desandou... Estou mantendo a revisao 20723 como produção para que os processos dos clientes continuem funcionando. Em relação tcDec4 eu vi no codigo que ele faz isso porem quando o componente salva o xml de remessa ele ja salva com numero inteiro e depois o xml que retorna da ginfes tambem volta inteiro, inclusive o danfs mostra exatamente o numero corretamente (4,00%) então tem algo bem diferente entre ao codigo que existia na 20723 e nessa 20790. se voce quiser posso fazer um novo teste usando o mesmo exemplo anterior com as duas revisões e enviar os resultados novamente.
  13. Oi Italo... Os testes foram diferentes. Na primeira mensagem era uma operação com 4% de ISS, e conforme demonstrado tanto no xml de envio quando no xml definitivo a aliquota está como "4" Nesse outro teste que fiz agora para valiar a nova revisão liberada, fiz o teste com outro pedido onde a aliquota é 1%, ao gerar o xml ele gerou conforme acima dividido por 100 e com 4 decimais. A prefeitura nao está aceitando numeros nesse formato conforme informei inicialmente. Voltei a versao 20723 e gerou corretamente. Não sei explicar o que está ocorrendo, porem só pude concluir até pela primeira mensagem de retorno que a aliquota tem que ser enviada no padrao 5(2), porem se observarmos a versao 20723 faz correto pois acredito que o campo é 5 caracteres "00004" que seria os 4% divididos por 100 porem em numero inteiro. acho que é essa a pegadinha da GINFES
  14. Pessoal, boa tarde. Desculpa intervir novamente porem a alteração não está satisfatória conforme exemplo em anexo. Não sei se é particularidade de Guarulhos, mas a ALIQUOTA Não pode ser dividida por 100
  15. Pessoal, temos problemas. primeiramente o GINFES de Guarulhos está reclamando que a a aliquota tem que ser enviada com 5 casas sendo 2 decimais. A alteração proposta pelo colega coloca 4 decimais Outro problema é que teoricamente a quantidade de digitos deveria ser atribuida em função do tipo3.xml onde a tcAliquota é definida certo? revisao 20723 está ok segue anexo imagens que demonstram como Guarulhos está recebendo as informações e estão adequadas.
  16. Obrigado. Podem finalizar este post.
  17. Olá pessoal. Abri esse tópico pois não achei nada a respeito. Supondo que uma NF-e já está cancelada na Sefaz por algum motivo (digamos que o usuario entrou pelo site e cancelou).... Quando tento enviar o cancelamento, a WS vai responder o cStat = 218 (NF-e já está cancelada na base de dados da SEFAZ [nRec:999999999999999] ) Nesse caso, como eu posso pegar o XML do cancelamento para atualizar a minha base de dados? Agradeço qualquer informação.
  18. Pessoal. ao compilar a revisão, está apresentando esse erro (Delphi Rio e Sydney) Compiling package D:\Programas\ACBr\Pacotes\Delphi\ACBrTCP\ACBr_TCP.dpk d:\Programas\Embarcadero\Studio\20.0\bin\dcc32.exe "D:\Programas\ACBr\Pacotes\Delphi\ACBrTCP\ACBr_TCP.dpk" Embarcadero Delphi for Win32 compiler version 33.0 Copyright (c) 1983,2018 Embarcadero Technologies, Inc. D:\Programas\ACBr\Fontes\ACBrTCP\ACBrIBGE.pas(386) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' D:\Programas\ACBr\Fontes\ACBrTCP\ACBrIBGE.pas(429) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' D:\Programas\ACBr\Fontes\ACBrTCP\ACBrIBGE.pas(443) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' D:\Programas\ACBr\Fontes\ACBrTCP\ACBrIBGE.pas(742) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' D:\Programas\ACBr\Fontes\ACBrTCP\ACBrIBGE.pas(767) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' D:\Programas\ACBr\Fontes\ACBrTCP\ACBrIBGE.pas(782) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' D:\Programas\ACBr\Fontes\ACBrTCP\ACBrIBGE.pas(796) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' D:\Programas\ACBr\Fontes\ACBrTCP\ACBrCEP.pas(2338) Fatal: F2063 Could not compile used unit 'ACBrIBGE.pas' Compilation failure Erro ao compilar o pacote "ACBr_TCP.dpk". Abortando... Ocorreram erros na compilação dos pacotes.
  19. Sim... eu sei.. mas acredito que a DEMO que foi feita em Fortes está bem mais "detalhado".... Acho que se tivermos duas versão IGUAIS com Geradores de Relatórios distintos vai ficar mais didático, concorda? Caso não seja de interesse, eu faço apenas o DACTE então.. voces decidem ok? Abraço forte e Fast..
  20. Ok... darei minha contribuição montando um DEMO em FASTReports para NFe e para CTe.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.