Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

Patrick William Cavalheiro

Membros
  • Content Count

    21
  • Joined

  • Last visited

Community Reputation

4 Neutral

About Patrick William Cavalheiro

  • Rank
    Novato

Profile Information

  • Sexo
    Masculino
  • Location
    São Miguel do Oeste

Recent Profile Visitors

740 profile views
  1. Bom dia, Reinstalei meu ACBr todo atualizado e não resolveu, então fui a fundo buscar uma solução. Como eu não tinha uma ECF Daruma FS 800I, debuguei e fiz testes com um emulador Bematech 4200 TH FI II que usa o EscECF porém não dava o erro, foi mais para tentar chegar no ponto da exceção. E então na linha 957 do ACBrECFEscECF.pas já existia uma validação do problema para impressoras bematechs, o que eu fiz foi adicionar a daruma também na validação: ((IsBematech) OR (IsDaruma)) and Não reportei aqui antes pois estava deixando rodar no cliente por alguns dias para
  2. @Juliomar Marchetti alguma previsão de quando irá conseguir disponibilizar isto? Obrigado.
  3. Olá, estava acompanhando este problema no fórum aberto, mas faz meses que estou com ele e ainda não consegui resolver, estou quase perdendo o cliente, então resolvemos contratar o SAC para nos auxiliar. Neste tópico criado por outro membro relato o meu problema: O Daniel Simoes me enviou um binário compilado em Lazarus, e com este binário o problema não ocorre. Porém, atualizei meu ACBr e compilei o ECFTeste em Delphi 2010 e com ele o problema volta a ocorrer (loop infinito ao gerar a RZ). Minha aplicação é em Delphi, então preciso que funcione em Delphi. Peço ajud
  4. @Daniel Simoes Você pode postar o fonte deste ECFTeste que você tem atualizado? Acabei de atualizar o fonte da pasta ".\Exemplos\ACBrSerial\ACBrECF\Delphi" e não está como este binário que você me enviou. Pois no meu sistema não funcionou com a atualização do ACBr, quero comparar o que tem de diferente com o ECFTeste. Desde já, muito obrigado. valeu...
  5. Funcionou com seu EXE Daniel... Tinha atualizado meus fontes no mês passado, vou atualizar novamente. Muito obrigado pela força. Abraços
  6. Fizemos alguns testes la na assistência com o ECFTeste, e deu novamente o problema... E ai a assistência fez um teste com um outro software que usa ACBR e o erro não ocorreu.. vou anexar os logs, e peço ajuda para encontrar a diferença entre o log do ECFTeste e o log do outro software que também usa ACBr. Vejam que no log do outro software no final do arquivo ele faz a redução Z sem problemas nenhum, e no log do ECFTeste (acbrlog.txt) ele fica com loop infinito ao fazer a Z. Se puderem me ajudar.. Muito obrigado. LogECF_030817.log acbrlog.txt
  7. @Daniel Simoes entrei em contato com a Daruma e o Sw. Basico da ECF já está atualizado. Enviamos novamente a impressora para a assistência (Obs.: já tinha sido enviado uma vez, eles trocaram um componente chamado impressor, mas não resolveu), eles fizeram alguns testes e não encontraram nada, ai eles fizeram testes com um outro sistema PAF-ECF que eles usam e que segundo eles não usa ACBr e o problema não ocorreu. Alguma ideia do que pode ser? será que não tem como aplicar o timeout nessas requisições? pois no componente ACBrECF o timeout está configurado como 30, mas parece que
  8. Olá, fiz o teste @Juliomar Marchetti com o ECFTeste e o erro persiste. Segue anexo o log (veja que no final do log apresenta um loop de status infinito). Abri o ECFTeste, configurei o modelo e a porta, abri a tela das configurações da serial para ver se estava tudo certo, ativei, cliquei em LerDadosRZ para ler os dados (só pra simular o que meu software faz antes de gerar a RZ), e depois cliquei em Relatórios -> Redução Z. Anexo também está a imagem de como fica o ECFTeste após fazer a Z (travado e ai só finalizando pelo gerenciador de tarefas para sair). Fiz também uma
  9. Alguém poderia me ajudar? estou com este problema de retorno repetidas vezes.. ainda não consegui resolver.
  10. @gabrielhs você poderia postar o código de como fez? Para mim não resolveu. Fiz algo mais ou menos assim: FDataModule.ACBrECF.Desativar; sleep(2000); FDataModule.ACBrECF.Ativar; FDataModule.ACBrECF.ReducaoZ; é uma Daruma FS800I. Está acontecendo quando gera a RZ.
  11. Verdade, também tive os mesmos problemas. A Daruma FS800i não funciona com a propriedade ControlePorta ativa, relatei isso em um tópico que fiz no ano passado, e resolvi desativando a propriedade: E agora estou com o mesmo problema do @gabrielhs na redução Z. Vou tentar implementar esse fechamento e abertura de porta antes da Z. Obrigado por postar aqui.
  12. Olá Pessoal, Atualizei meu Trunk2 no dia de hoje. E analisando este tópico: e aplicando algumas modificações em meu fonte com base nos exemplos do ACBr, encontrei um possível erro no exemplo ECFTeste. Na aba Menu Fiscal tem os botões Arq. MF e Arq. MFD, porém os dois botões estão chamando a mesma função: PafMF_ArqMFD_Binario. No caso do MF não seria: PafMF_ArqMF_Binario ? Enfim, só quero contribuir. Não encontrei nenhum tópico falando disso. Abraços.
  13. Obrigado pela cooperação amigos, só pra compartilhar pra vocês como resolvi: Deixei a propriedade ControlePorta desativada e resolveu. Faz 5 dias já que estão usando sem problema nenhum. Abraços
  14. Olá @Juliomar Marchetti, deixei dois dias (ontem e hoje) configurado com a velocidade 115200, e também apresentou o mesmo erro. Configurei a velocidade tanto no driver, quanto no sistema. Esse log que está anexo é do dia 30/01.
×
×
  • Create New...