Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

Luiz Carlos Panoni Junior

Membros
  • Content Count

    54
  • Joined

  • Last visited

Community Reputation

6 Neutral

About Luiz Carlos Panoni Junior

  • Rank
    Membro

Recent Profile Visitors

874 profile views
  1. Prezados, estou tentado enviar um RPS em ambiente de homologação com o provedor Sigcorp na Prefeitura de Avaré porem estou recebendo o retorno baixo, o estranho e que o RPS é cadastrado e não me deixa mais utilizar o mesmo número; " Inicio TNFSeGerarNFSe ERRO: Erro Interno: 0 Erro HTTP: 500 URL: http://abrasfavareteste.sigbancos.com.br/servico.asmx <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  2. Sim, mais como eu uso o xmlsec o comportamento é diferente preciso alterar o ACBR.INC e descomentar a linha que habilita o uso, então acredito que esteja se comportando de maneira diferente.
  3. Ola pessoal, estou tentando pegar o valor de: vtblDownloadNFE.FieldByName('DataEmissao').AsString := DateTimeToStr(ACBrNFe1.WebServices.DistribuicaoDFe.retDistDFeInt.docZip.Items[0].resDFe.dhEmi); Mais o valor retornado na string é 30/12/1899, pelo que vi é retornado este valor quando o campo é nulo, mais olhando o XML de retorno ele contem a informação: <?xml version="1.0" encoding="UTF-8"?> -<resNFe xmlns="http://www.portalfiscal.inf.br/nfe" versao="1.01" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema
  4. Obrigado amigo, vou analisar aqui, será que a ordem do CTE é a mesma do NFE ?, mais vou verificar muito obrigado.
  5. Acho que não é caso pois não informo em momento algum o serial somente os itens abaixo: ACBrNFe1.Configuracoes.Certificados.ArquivoPFX := edtCaminho.Text; ACBrNFe1.Configuracoes.Certificados.Senha := edtSenha.Text; ACBrNFe1.Configuracoes.Certificados.NumeroSerie := ''; Uma coisa estanha é que debugando o codigo vi que o local da mensagem é : procedure TDFeSSLCryptClass.CarregarCertificado; begin DescarregarCertificado; Clear; if not EstaVazio(FpDFeSSL.URLPFX) then CarregarCertificadoDeURLPFX else
  6. Prezados, sempre utilizei o arquivo pfx normalmente até a ultima atualização que fiz no acbrnfe, não sei dizer a quanto tempo eu estava sem update, agora, ele funciona normalmente, mais sempre exibe a mensagem "dadospfx arquivopfx ou numeroserie não especificados" Como uso windows 2003 server utilizo sempre: LibLOpenSLL cryOpenSSL httpOpenSSL xsXmlSec LT_TLSv1_2 E por usar somente o PFX não carrego o numero de série, porém quando coloco para testar da erro Certificado Serie XXXXXXXXXXXXX não encontrado. Esta validação foi implementada recentemente
  7. Entendei Juliomar, mais eu realmente estava passando o index, é que fiz tanta mudança que posso ter lhe enviado sem, mais eu estava usando items...., mais agradeço muito, resolvido.
  8. Juliomar, é muito estranho, não aparece mais no meu XE8 aparece, removi todos os fontes do ACBR para o D7 e reinstalei, agora apareceu, é muita loucura rsrsrsr. Muito obrigado pelo seu tempo, foi de grande ajuda, resolvi.
  9. Peço desculpas e entendo que isto gera confusão no post, pode me ajudar com a situação das propriedades da nfe ?
  10. Show, esta parte do boleto resolvido apenas declarando ACBrBoletoConversao, agora persiste o problema de não existir o vnf e o cSitNFe
  11. Primeiramente muito obrigado pela ajuda. Acabei de atualizar e agora estou tendo outros problemas como por exemplo no boleto, os codigos abaixo não funcionam mais: Titulo := central.ACBrBoleto.CriarTituloNaLista; with Titulo do begin Aceite := atNao; <- Aparentemente não existe mais sacado.Pessoa := pFisica <- Também exibe erro sacado.Pessoa := pJuridica; <- Também Mesmo apos atualizado o fonte, o vnf não parece neste codigo abaixo: ACBrNFe1.WebServices.DistribuicaoDFe.retDistDFeInt.docZip.Item
  12. Sim estas duas propriedades não existem aqui para mim, pode ser atualização dos fontes ? Sim, estas duas propriedades não existem aqui pra mim, pode ser atualização dos fontes ?
  13. Prezados, pesquisei muito mais não consigo saber onde pegar as Tags vNF e cSitNFe no resumo da distribuição DFe Estou pegando as informações conforme abaixo, existe uma maneira de ir buscar direto no resNFe ? vtblDownloadNFE.FieldByName('chaveacesso').AsString := ACBrNFe1.WebServices.DistribuicaoDFe.retDistDFeInt.docZip.Items.resDFe.chDFe; vtblDownloadNFE.FieldByName('numeronf').AsString := copy(ACBrNFe1.WebServices.DistribuicaoDFe.retDistDFeInt.docZip.Items.resDFe.chDFe,26,9); vtblDownloadNFE.FieldByName('cnpj').AsString := ACBrNFe1.WebServices.
  14. Ola Juliana, obrigado por sua resposta, analisando aqui não sei por qual motivo meus fontes estavam desatualizados mesmo apos o update do svn, apaguei a pasta criei o repositorio novamente e deu certo. Muito obrigado.
×
×
  • Create New...