Jump to content

LEANDRO LANA

Membros
  • Posts

    47
  • Joined

  • Last visited

Everything posted by LEANDRO LANA

  1. Ola pessoal, Alguém está conseguindo utilizar a NFS-e para a prefeitura de São Luis/MA? Estou gerando o arquivo, atualizei os fontes e eschemas do ACBR e quando envio, tanto produção quanto homologação, me retorna erro de status 500: Erro Interno: 0 Erro HTTP: 500 URL: https://sistemas.semfaz.saoluis.ma.gov.br/WsNFe2/LoteRps.jws?wsdl Pelo que eu vi status 500 é que a página que está tentando acessar não existe, mas seu eu clico no link acima, ele abre o wsdll normalmente. Alguém tem alguma idéia do que mais pode ser? Poderia ser a configuração da SSLIB?
  2. Falei com eles hoje e disseram que são os schemas da Abrasf. Então acho que é o padrão abrasf mesmo.
  3. Eles me passaram essas URLs: Envio de RPS de forma Síncrona: https://siapsistemas.com.br/rpsstmhomologa/servlet/arecepcionarloterpssincrono?wsdl Consultar Lote de RPS: https://siapsistemas.com.br/rpsstmhomologa/servlet/aconsultarloterps?wsdl
  4. Bom dia, Alguém já desenvolveu NFSe para a prefeitura de Santarém/PA? Pelo cidades.ini consta como ginfes, porém não é. Eles utilizam outro provedor (https://siapsistemas.com.br/santarempgiss/servlet/mainsantarem). Tentei acesso pelo ginfes mas recusa dizendo que o login não existe.
  5. Boa tarde Italo, De produção não tenho, pois é uma base do meu cliente. Estou enviando em anexo o que eu fiz agora no ambiente de homologação, onde cancelou com sucesso. NFSe.rarNFSe
  6. Ola pessoal. Alguém poderia me dar um suporte nessa questão? Não estou mais conseguindo cancelar NFS-e Ginfes para a Prefeitura de São Bernardo do Campo. Não sei quando começou esse problema, mas desde ontem estou tentando cancelar uma NFSe em produção e sempre me retorna o mesmo erro: "Arquivo enviado fora da estrutura do arquivo XML de entrada. Envie um arquivo dentro do schema do arquivo XML de entrada." Em ambiente de testes, funciona normal. Consigo fazer o cancelamento sem problemas, porém no ambiente de produção não cancela. Acabei de atualizar os componentes ACBR e fiz os testes novamente e nada de funcionar. Alguma dica? Anexo os XMLS . Configuração: GinfesXML.rar
  7. Sim, provavelmente é algum detalhe que não estou vendo. Por isso mandei essa pergunta, para ver se já passaram por isso, eu ainda não consegui fazer aparecer os logos nesse navegador.
  8. Bom dia, É HTML, quando gero um boleto em HTML e mando visualizar no EDGE os logos do banco não são carregados, segue print de um teste. Obrigado
  9. Boa tarde, Eu já pesquisei aqui e não encontrei nenhum tópico sobre isso, então me desculpem caso seja repetido. Eu estou gerando boletos com o componente do ACBr, funciona normalmente, porem somente no navegador Edge do Windows 10 os logos dos bancos não estão aparecendo. Existe alguma configuração a ser feita? Alguém já passou por isso? Muito Obrigado.
  10. Bom dia, Desculpem caso esse tópico seja repetido, Eu procurei no forum sobre o assunto porem não encontrei nada claro. Eu atualizei, hoje 26/02/2016, os fontes do ACBr pelo svn tortoise. Rodei o .bat apagarAcbr; Tentei instalar o ACBr utlizando o ACBrInstall_Trunk2, porem não consegui, foi gerado um log que esta em anexo. Vocês poderiam me auxiliar nessa instalação, por favor? log_Delphi_XE3.txt
  11. Bom dia. Sabem me informar se o componente já possui opção de gerar o código de rastreamento do Correios ou há algum componente para isso aqui no ACBR?
  12. Estou tentando registrar esta manifestação pois quero utilizar a função de DownloadNFe. Porem quando tento fazer este download o seguinte erro é retornado: <retDownloadNFe versao="1.00" xmlns="http://www.portalfiscal.inf.br/nfe"><tpAmb>2</tpAmb><verAplic>AN_2.1.1</verAplic><cStat>139</cStat><xMotivo>Pedido de Download processado</xMotivo><dhResp>2015-11-13T16:53:21</dhResp><retNFe><chNFe>35151150630466000149550000000096231000350941</chNFe><cStat>633</cStat><xMotivo>Rejeicao: NF-e indisponivel para download devido a ausencia de Manifestacao do Destinatario</xMotivo></retNFe></retDownloadNFe> Será necessário emitir uma nota em Produção e o cliente registrar a manifestação para ai sim poder testar/executar esse download?
  13. Bom dia, Obrigado pelo retorno. Não tinha percebido que criei dois tópicos, desculpe. Ok, a chave não foi encontrar. Eu faturei uma nota hoje, chave[35151150630466000149550000000096221000350936], em homologação e consultei nestes links e a chave foi encontrada: https://homologacao.nfe.fazenda.sp.gov.br/ConsultaNFe/consulta/publica/ConsultarNFe.aspx, http://hom.nfe.fazenda.gov.br/portal/consulta.aspx?tipoConsulta=completa&tipoConteudo=XbSeqxE8pl8= Tentei registrar a manifestação hoje desta mesma chave, mas retornou o erro cStat-999 xMotivo- 2212 - Falha ao pesquisar a base de dados O código esta assim agora: ACBrNFe.EventoNFe.idLote := idLote; with ACBrNFe.EventoNFe.Evento.Add do begin InfEvento.tpAmb := TpcnTipoAmbiente.taHomologacao; InfEvento.cOrgao := 91; InfEvento.chNFe := infoFat.CDCHAVACESNFE; InfEvento.CNPJ := infoFat.NRCGCCPF; InfEvento.dhEvento := Now; InfEvento.tpEvento := teManifDestCiencia; InfEvento.detEvento.xJust := 'Manifestacao da Operacao'; end; ACBrNFe.EnviarEventoNFe(idLote); Como posso registrar a manifestação?
  14. Bom dia, Eu procurei no fórum sobre Manifestação Destinatário antes de abrir esse tópico, porem não achei conteúdos que me ajudassem. Estou com um problema de não conseguir registrar a Manifestação do Destinatário, segue código: ACBrNFe.EventoNFe.idLote := xxxx; ACBrNFe.EventoNFe.Evento.Add; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.cOrgao := 91; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.chNFe := ssss; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.CNPJ := ssss; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.dhEvento := Now; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.tpEvento := teManifDestCiencia; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.detEvento.xJust := 'Manifestacao da Operacao'; ACBrNFe.EnviarEventoNFe(xxxx); Em resposta recebo esse XML: <retEnvEvento versao="1.00" xmlns="http://www.portalfiscal.inf.br/nfe"><idLote>9615</idLote><tpAmb>2</tpAmb><verAplic>AN_1.0.0</verAplic><cOrgao>91</cOrgao><cStat>128</cStat><xMotivo>Lote de evento processado</xMotivo><retEvento versao="1.00"><infEvento><tpAmb>2</tpAmb><verAplic>AN_1.0.0</verAplic><cOrgao>91</cOrgao><cStat>999</cStat><xMotivo>2212 - Falha ao pesquisar a base de dados</xMotivo><chNFe>35151050630466000149550000000096151000350113</chNFe><tpEvento>210210</tpEvento><xEvento>Ciencia da Operacao</xEvento><nSeqEvento>1</nSeqEvento><dhRegEvento>2015-11-12T11:07:34-02:00</dhRegEvento></infEvento></retEvento></retEnvEvento> Esta sempre retornando o erro: cStat-999 xMotivo- 2212 - Falha ao pesquisar a base de dados. Estou fazendo testes então o ambiente esta sempre em Homologação, esses testes foram realizados hoje. Vocês poderiam me ajudar por favor? Alguma ideia do que pode ser esse erro? Obrigado.
  15. Bom dia, Eu procurei no fórum sobre Manifestação Destinatário antes de abrir esse tópico, porem não achei conteúdos que me ajudassem. Estou com um problema de não conseguir registrar a Manifestação do Destinatário, segue código: ACBrNFe.EventoNFe.idLote := xxxx; ACBrNFe.EventoNFe.Evento.Add; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.cOrgao := 91; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.chNFe := ssss; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.CNPJ := ssss; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.dhEvento := Now; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.tpEvento := teManifDestCiencia; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.detEvento.xJust := 'Manifestacao da Operacao'; ACBrNFe.EnviarEventoNFe(xxxx); Em resposta recebo esse XML: <retEnvEvento versao="1.00" xmlns="http://www.portalfiscal.inf.br/nfe"><idLote>9615</idLote><tpAmb>2</tpAmb><verAplic>AN_1.0.0</verAplic><cOrgao>91</cOrgao><cStat>128</cStat><xMotivo>Lote de evento processado</xMotivo><retEvento versao="1.00"><infEvento><tpAmb>2</tpAmb><verAplic>AN_1.0.0</verAplic><cOrgao>91</cOrgao><cStat>999</cStat><xMotivo>2212 - Falha ao pesquisar a base de dados</xMotivo><chNFe>35151050630466000149550000000096151000350113</chNFe><tpEvento>210210</tpEvento><xEvento>Ciencia da Operacao</xEvento><nSeqEvento>1</nSeqEvento><dhRegEvento>2015-11-12T11:07:34-02:00</dhRegEvento></infEvento></retEvento></retEnvEvento> Esta sempre retornando o erro: cStat-999 xMotivo- 2212 - Falha ao pesquisar a base de dados. Estou fazendo testes então o ambiente esta sempre em Homologação, esses testes foram realizados hoje. Vocês poderiam me ajudar por favor? Alguma ideia do que pode ser esse erro? Obrigado.
  16. Bom dia, Eu procurei no fórum sobre Manifestação Destinatário antes de abrir esse tópico, porem não achei conteúdos que me ajudassem. Estou com um problema de não conseguir registrar a Manifestação do Destinatário, segue código: ACBrNFe.EventoNFe.idLote := xxxx; ACBrNFe.EventoNFe.Evento.Add; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.cOrgao := 91; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.chNFe := infoFat.CDCHAVACESNFE; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.CNPJ := infoFat.NRCGCCPF; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.dhEvento := Now; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.tpEvento := teManifDestCiencia; ACBrNFe.EventoNFe.Evento.Items[0].InfEvento.detEvento.xJust := 'Manifestacao da Operacao'; ACBrNFe.EnviarEventoNFe(idLote);
  17. Bom dia, Eu verifiquei a questão de permissão de usuário e vi que Eu não tinha acesso a pasta \System32\spool\printers, liberei o acesso e agora consigo imprimir. O estranho agora é que ele esta imprimindo um pagina para cada linha. Por exemplo, o campo valor do cheque é R$30,00, isso é impresso em uma pagina, o valor por extenso "Trinta Reais" é impresso em outra pagina. Isso é configuração de componente? ou tem alguma coisa no código que esta errado?
  18. Boa Tarde Eu fiz a alteração solicitada: Mudei de: {$IFDEF FPC} {$DEFINE Use_Stream} {$ENDIF} Para: {$DEFINE Use_Stream} E agora aparece o seguinte erro "Cannot create file "\\.\LPT2". Acesso negado"
  19. Boa Tarde, Desculpe a demora para responder. Eu entrei no link enviado e segui os passos do Método um para mapear a porta da impressora, e funcionou. Consegui fazer algumas impressões de teste utilizando o programa que me passou. Porem quando vou utilizar o componente do ACBrCHQ ocorre o seguinte erro "The specified file was not found". O valor da porta: ACBrCHQ.Porta := 'LPT2'; Debugando, Ocorre um exception no unit ACBrDevice, método TACBrDevice.EnviaStringArquivo linha 931. Essa rotina foi chamada pelo método TACBrDevice.Ativar linha 378, que por sua vez foi chamada pelo método ImprimirCheque. No método TACBrDevice.EnviaStringArquivo, é executado o seguinte trecho: AssignFile( ArqPrn, Porta ); try if IsTXTFilePort and FileExists(Porta) then <------- Esse if esta estranho para mim, poderia me explicar melhor o que ele verifica exatamente? Append( ArqPrn ) else Rewrite( ArqPrn ); <----- O Exception é disparado nesta linha while I <= Max do begin Write( ArqPrn, copy(AString, I, NBytes ) ) ; if fsSendBytesInterval > 0 then Sleep( fsSendBytesInterval ) ; I := I + NBytes ; end ; Flush( ArqPrn ) ; finally {$I-} {$IFNDEF FPC}System.{$ENDIF}CloseFile( ArqPrn ) ; {$I+} end ; Eu não entendi direito essa parte, Eu sei que o erro ocorre porque a variavel ArqPrn não esta apontando para um arquivo existente, então onde Eu altero para que ela esteja correta? Obrigado.
  20. Bom dia, As permissões de acesso a essa impressa estão todas liberadas, e foi testado com um usuário Administrador com acesso liberado em tudo. Existe alguma configuração padrão para impressora comum neste programa que me passou?
  21. Boa Tarde. Desculpe a demora para retornar. Eu fiz download do programa e configurei o Modelo para "ppTexto" e a porta para "\\172.16.2.1\Comercial", ocorre o seguinte erro: " Unable to open file "\\172.16.2.2\Comercial". Press OK to ignore and risk data corruption. Press Cancel to kill the program. "
  22. Boa Tarde, Desculpe a demora para responder. Eu alterei o nome do compartilhamento e ficou assim: ACBrCHQ.Porta := '\\172.16.2.1\Comercial'; Porem ainda da erro só que agora é esse "'I/O error 50'". Alguma idéia?
  23. Obrigado pela resposta Daniel, Eu configurei como você informou, ficou assim: ACBrCHQ.Porta := '\\172.16.2.1\HP LaserJet P4515(Produção)'; Porém na hora de Imprimir o cheque retorna o erro "I/O Error 53", ao debugar cheguei ao fonte ACBrDevice na rotina EnviaStringArquivo, linha 926 que é o momento onde é feito um "AssignFile( ArqPrn, Porta );". Ocorre um exception nessa linha. Eu ainda não estou configurando certo, alguma idéia? Talvez o nome da impressora esta errado, Eu o peguei nas configurações de Dispositivos e Impressoras no painel de controle.
  24. Bom dia, Estou utilizando o componente ACBrCHQ para Impressora Comum, porem não sei dizer se estou configurando ele corretamente, segue código: ACBrCHQ.Modelo := chqImpressoraComum; ACBrCHQ.Porta := '172.16.2.1'; ACBrCHQ.Banco := qryCheque.FieldByName('CDBANCO').AsString; ACBrCHQ.Cidade := TiraAcento(qryCheque.FieldByName('DSCIDADE').AsString); ACBrCHQ.Favorecido := TiraAcento(qryCheque.FieldByName('DSFAVORECIDO').AsString); ACBrCHQ.Valor := qryCheque.FieldByName ('VLLANC').AsFloat; ACBrCHQ.Data := qryCheque.FieldByName('DTCHEQUE').AsDateTime; ACBrCHQ.ImprimirCheque; A impressora que tenho que acessar esta em rede, no IP que coloquei na Porta. Ao chamar a rotina ImprimirCheque, não ocorre nada, não aparece mensagem de erro e nem de sucesso. Vocês poderiam me auxiliar por favor?
  25. Dercide Alvarez, por favor envie para este e-mail "[email protected]". Muito obrigado.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.