Ir para conteúdo
  • Cadastre-se

Marcos Peixoto

Membros
  • Total de ítens

    24
  • Registro em

  • Última visita

Reputação

5 Neutro

Sobre Marcos Peixoto

  • Rank
    Novato

Profile Information

  • Sexo
    Masculino
  • Localização
    Ubá-MG

Últimos Visitantes

O bloco dos últimos visitantes está desativado e não está sendo visualizado por outros usuários.

  1. Bom dia Ítalo, Passou a gerar o erro abaixo no cancelamento da NFS-e pelo provedor VersaTecnologia.ini. Modifiquei no .ini e estou enviando o arquivo corrigido para distribuir. Att. Marcos VersaTecnologia.ini
  2. Boa tarde Ítalo, Respondendo suas perguntas: Sim, o lote foi processado corretamente. Observação: Eu trabalho enviando apenas 1 lote por vez. Eu utilizo o Gerar() conforme instruções do fórum. ACBrNFSe.Gerar(IdentificacaoRps, NumeroLote, False); Espero ter ajudado, Marcos
  3. Boa tarde, Tive problema com emissões de NFS-e pelo Provedor Bethav2 (município de Cláudio-MG). Estava retornando esse erro ao tentar transmitir: Analisando as causas identifiquei que era ao tentar assinar o RPS. Verificando o arquivo Bethav2.ini, percebi que estava marcado para assinar RPS(1). Só parou de apresentar o problema quando marcado para NÃO ASSINAR RPS (0), conforme abaixo: Não sei se outros passaram pelo mesmo problema, mas creio que o Bethav2.ini estava configurado errado. Estou anexando para avaliação da comunidade e disponibilização no repositório. Marcos Bethav2.ini
  4. Boa tarde Ítalo, Favor atualizar arquivo cidades.ini. Adicionada cidade de Arapongas-PR também atendida pela IPM. Obrigado, Marcos Cidades.ini
  5. Bom dia Filipe e demais, Estou implementando NFS-e para município também atendido pela IPM (Arapongas-PR) e estou com seguintes impasses: O primeiro é que na chamada de ConsultarLoteRps() ocorrendo 'Argument out of range' na função ExtrairNotasRetorno() da unit ACBrNFSeWebServices.pas, quando chega no teste adicionado para proIPM (+- linha 1130 da versão q estou usando). Tive que adicionar as linhas que destaco abaixo para funcionar. Podem rever se procede? if (FProvedor = proIPM) then begin if FNotasFiscais.Count = 0 then // <<<<<====== Teste adicionado para funcionar FNotasFiscais.Add; FNotasFiscais.Items[0].NFSe.Autenticador := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.Autenticador; FNotasFiscais.Items[0].NFSe.Link := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.Link; FNotasFiscais.Items[0].NFSe.Numero := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.Numero; FNotasFiscais.Items[0].NFSe.dhRecebimento := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.dhRecebimento; FNotasFiscais.Items[0].NFSe.CodigoVerificacao := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.CodigoVerificacao; FNotasFiscais.Items[0].NFSe.Protocolo := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.Protocolo; FNotasFiscais.Items[0].NFSe.Competencia := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.Competencia; FNotasFiscais.Items[0].NFSe.Cancelada := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.Cancelada; FNotasFiscais.Items[0].NFSe.Status := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.Status; if (Trim(FXML_NFSe) <> '') then FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.XML := FXML_NFSe; FNotasFiscais.Items[0].NFSe.XML := FRetornoNFSe.ListaNFSe.CompNFSe.Items[0].NFSe.XML; Break; end; O segundo ponto: Uma vez confirmado através do ConsultarLoteRps() que a Nota Fiscal foi validada, como pegar as informações de emissão (Numero, dhRecebimento, CodigoVerificacao, etc...) para serem gravados em banco de dados. Não encontrei forma de pegar essas informações. Como estão fazendo isso? Poderiam por favor apresentar uma sugestão ou exemplo. Agradeço antecipadamente a atenção. Marcos
  6. Olá administradores, Por favor, adicionem ao arquivo cidades.ini mais um município (Arapongas-PR) também atendido pela IPM. [4101507] Nome=Arapongas UF=PR Provedor=IPM Grato. Marcos
  7. Bom dia Régys, Estou passando por esse problema reportado nesse post de 2014. Tive que reinstalar o Delphi 2010, porém, por nada consegui colocar o autocomplete funcionar. Curiosamente essa configuração na máquina antiga também não está preenchido, mas o autocomplete funciona. Não entendi o que seria preenchido nesse "unit aliases"? Pode me ajudar nisso? Marcos
  8. Alguém sabe dizer se houve mudanças no retorno do provedor Bethav2 na tag <Discriminacao> do serviço prestado. No XML da NFS-e retornado, a referida tag está retornando com dados de valores conforme o formato a seguir; <Discriminacao>{[[Descricao=CONSERTO DE BENS DE TERCEIROS][ItemServico=1401][Quantidade=1][ValorUnitario=100][ValorServico=100][ValorBaseCalculo=100][Aliquota=5]]}</Discriminacao> Notem que retorna outras tags entre colchetes. Sabem se existiram alterações por parte do provedor? Marcos Cesar Peixoto
  9. Boa dia Ítalo, Confirmando: Emissão, Cancelamento e Consulta estão funcionando. Na Substituição faço seguinte observação: O processo é realizado, porém, não consegui pegar as informações da substituição diretas no retorno. Contornei realizando uma nova consulta para obter as informações necessárias. Não sei se é uma limitação do provedor, ou uma falha no componente ou talvez eu que esteja fazendo de forma incorreta. Uso seguinte procedimento: ACBrNFSe.SubstituirNFSe(MotivoCancelamento, NumeroNFSubstituida, DescricaoMotivoCancelamento); // Na linha abaixo tento pegar o retorno, mas o conteúdo vem vazio. XML_NFSe := ACBrNFSe.WebServices.SubNFSe.XML_NFSe; Caso queira dar uma olhada, estou anexando os XML gerados tanto na substituição, quanto posteriormente da consulta onde confirmo a substituição. Marcos XMLsSubstituicao.rar XMLsConsulta.rar
  10. Bom dia, Na tentativa de substituição da NFS-e via provedor SH3, retornou o erro abaixo: 000 - O XML recebido esta mal formado: Linha 2, coluna 1, mensagem Start tag expected, '<' not found. Refira-se ao processamento 414437 para ajuda ou suporte. Se o XML em questão for "201700000000024-ped-sub" não vi problema algum. Saberiam do que se trata esse processamento 414437? Estou anexando os XMLs gerados. Obrigado. Marcos 201700000000024-ped-sub.xml 201700000000024-ped-sub-soap.xml 201700000000024-sub.xml 201700000000024-sub-soap.xml
  11. Boa tarde, Pessoal, apenas compartilhando que provedor SH3 estão funcionando. Ítalo, mais uma vez, obrigado pelo apoio. Seguem contatos do suporte da SH3 caso alguém necessite: andrey@sh3.com.br Fone: (32) 3379-3100 Mais informações do provedor aqui. Marcos
  12. Bom dia Ítalo, Estranho, eu estava tentando justamente o município de São Geraldo-MG e deu o problema. Vou contactar o provedor e ver se nos ajudam. Por hora, obrigado.
  13. Bom dia Ítalo, Realizando os testes SH3, passou pelo GerarLote() porém dá erro em Enviar(). A mensagem de erro não foi interpretada não apresentando nada, mas no XML consta "000 - Este ambiente nao foi configurado" O problema ocorre em ACBrDFeWebService (linha 4937) na chamada abaixo: function TWebServices.Envia(ALote: String): Boolean; ... Result := FEnviarLoteRPS.Executar; <<<<-------------------------- AQUI Os XMLs gerados foram anexados. Também a tela no código fonte (caso ajude em alguma coisa)... Não consegui identificar as causas do problema. Pode dar mais uma força ai? Obs: Temos troca de e-mails sobre esse assunto, estou adicionando aqui também caso outros também passem por dificuldades com Provedor SH3. Agradecido, Marcos 1-env-lot.xml 1-env-lot-soap.xml 1-lot-rps.xml 1-lot-rps-soap.xml 1-rec.xml 1-rec-soap.xml
  14. Bom dia Ítalo, Lhe enviei os arquivos alterados por e-mail, conforme solicitado. Obrigado! Marcos
×
×
  • Criar Novo...