Jump to content

Danilo Junior

Membros
  • Posts

    18
  • Joined

  • Last visited

Everything posted by Danilo Junior

  1. Boa Noite, Alguém sabe explicar em qual momento e para preencher os campos de validade idePeriodo "iniValid" e "fimValid" e os campos da nova validade novaValidade "iniValid" e "fimValid" nas operações inclusão, alteração e exclusão dos eventos? Agradeço, Danilo Junior
  2. Boa Noite, Baixei os fontes do e-Social em outra máquina e comparei com os meus que aparentemente estavam atualizados. Na comparação, o soapaction estava diferente nos fontes que estou usando. Corrigi e agora deu certo. FPServico := 'http://www.esocial.gov.br/servicos/empregador/lote/eventos/envio/consulta/retornoProcessamento/v1_1_0/ServicoConsultarLoteEventos/ConsultarLoteEventos'; No meu fonte estava v_1_1_1 e o correto era v1_1_0. Obrigado Pela Atenção, Danilo Junior
  3. Bom dia, Estou usando o exemplo do e-social do Acbr e está atualizado. Já fiz um teste criando um novo projeto só para a consulta do protocolo e apareceu o mesmo erro.Tem como mandar as URLs e NameSpace para eu testar?
  4. Bom Dia, Ao consultar o protocolo pelo web service <?xml version="1.0" encoding="UTF-8"?> <soap:Envelope xmlns:v1="http://www.esocial.gov.br/schema/lote/eventos/envio/v1_1_1" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"> <soap:Body> <v1:ConsultarLoteEventos> <v1:loteEventos> <eSocial xmlns="http://www.esocial.gov.br/schema/lote/eventos/envio/consulta/retornoProcessamento/v1_0_0"> <consultaLoteEventos> <protocoloEnvio>1.2.201807.0000000000024114196</protocoloEnvio> </consultaLoteEventos> </eSocial> </v1:loteEventos> </v1:ConsultarLoteEventos> </soap:Body> </soap:Envelope> está aparecendo o seguinte erro <?xml version="1.0"?> <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"> <s:Body> <s:Fault> <faultcode xmlns:a="http://schemas.microsoft.com/ws/2005/05/addressing/none">a:ActionNotSupported</faultcode> <faultstring xml:lang="en-US">The message with Action 'http://www.esocial.gov.br/servicos/empregador/lote/eventos/envio/consulta/retornoProcessamento/v1_1_1/ServicoConsultarLoteEventos/ConsultarLoteEventos' cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).</faultstring> </s:Fault> </s:Body> </s:Envelope> Alguém sabe como resolver este problema? Agradeço, Danilo Junior
  5. Boa Tarde, Pela mensagem "Não pode ser processado no receptor, devido a uma incompatibilidade de ContractFilter no EndpointDispatcher. Isso pode ser devido a uma incompatibilidade de contrato (Ações incompatíveis entre remetente e destinatário) ou uma incompatibilidade de ligação / segurança entre o remetente e o destinatário. Verifique se o remetente e o destinatário têm o mesmo contrato e a mesma ligação (incluindo requisitos de segurança, por exemplo, Mensagem, Transporte." É problema de ambiente do meu computador eu acho Estou usando o Win7 64bits e o Delphi 10.2.3. Já testei com todos os SSL LIb. Deve ser algum problema na segurança ou algo parecido. O envio do lote foi sem problema, recebi o número do protocolo de envio. Mais quando vou consultar o mesmo, ocorre este erro.
  6. Boa Tarde, Estou usando o programa de exemplo.
  7. Boa Tarde, Continua apresentando o mesmo erro.
  8. Boa Noite, Estou querendo consultar um protocolo de envio e está aparecendo o seguinte erro: Debugando o retorno no código no arquivo ACBrDFeHttpOpenSSL.pas // Lendo a resposta // if OK then begin // DEBUG // //HTTP.Document.SaveToFile('c:\temp\ReqResp.xml'); FHTTP.Document.Position := 0; Result := String( ReadStrFromStream(FHTTP.Document, FHTTP.Document.Size) ); end; esta retornando o seguinte mensagem: cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport. Alguém sabe o que esta ocorrendo? Att., Danilo Junior
  9. Bom Dia Pessoal, Alguém já implementou o e-Social para Órgão Gestor de Mão de Obra (OGMO)? Agradeço, Danilo Junior
  10. Boa Noite Pessoal, Estou tentando enviar o evento S-1000 para o Web service e está aparecênda a seguinte tela de erro: Alguém pode me ajudar? Agradeço Danilo Junior
  11. Boa Noite @RicardoVoigt Fiz as alterações conforme você orientou, mais o erro persiste. Fiz uma analise na rotina, o erro ocorre na unit ACBrDFeXsXmlSec no trecho do código schema := xmlSchemaParse(parser_ctxt); // the schema itself is not valid if (schema = nil) then begin MsgErro := 'Error: the schema itself is not valid'; Exit; end; Att., Danilo Junior evtInfoEmpregador.xml evtInfoEmpregador_error.xml
  12. Boa Tarde, Baixei os arquivos do eSocial para testes e ao executar o programa de exemplo selecionando o S-1000, está aparecendo a seguinte mensagem: <!--Falha na validação dos dados do evento: evtInfoEmpregador Error: the schema itself is not valid--> Alguém tem alguma ideia de como resolver isso? Segue anexo o xml gerado. Agradeço, Danilo Junior evtInfoEmpregador.xml evtInfoEmpregador_error.xml
  13. Bom dia, Fiz umas adaptações nos componentes da ACBR para poder funcionar aqui para Natal. Veja os métodos: ACBrNFSe1.NotasFiscais.AssinarRps; Usar no final de cada rps gerada. ACBrNFSe1.GerarLote(NumLote); Usar quando for gerar o lote. Estou usando Capicom e a assinatura por um Token. Abraços, Danilo Junior ACBrNFSe.rar ACBr_NFSe.rar
  14. Aqui em Natal/RN, não usam o Serviço de Webservices, tenho que gera a remessa e enviar pelo portal da prefeitura e quanto a assinatura infelizmente tem que ser uma a uma, no meu ver, bastaria no final do lote. Obrigado pela atenção, Danilo Junior
  15. Bom Dia, Trabalho para um colégio aqui em Natal/RN, e tive que desenvolver a geração das NFS-e para a prefeitura das mensalidades, a rotina esta funcionando perfeitamente, o problema e que gero uma faixa de 6000 RPSs e tenho que fazer a assinatura uma a uma das mesmas. O problema e que para cada RPS, a rotina de assinatura leva cerca de 1/2 segundo para ser executado, este tempo não e nada, mais como são mais de 6000 assinaturas, este processo esta demorando mais de 30 minutos para ser executado. Fiz o teste bloqueando a assinatura e gerando só o arquivo, a mesma rotina não demora menos que 5 minutos. Gostaria de saber se tem como otimizar esta rotina assinatura ou fazer algum procedimento para melhorar este tempo. Estou usando um Computador com Processador I3 com 4GB de memória. Danilo Junior
  16. Bom dia, Estou conseguindo gerar e validar os lotes gerados pelo componente, o problema e a demorando grande para gerar as mesmas. Cada lote tem 50 rps e demora cerca de 1min. Como aqui em Natal/RN não usa Webservice, montei uma rotina usando o componente ACBrSe para gerar os lotes. Alguém já teve algum problema com a demora nas assinaturas. Danilo Junior
  17. Oi Italo, É que eu gerei o xsd pelo XML Data Binding gerando um .pas e montando usando o XMLDocument para montar o arquivo, eu já estou gerando o XML, o que eu queria era aproveitar esta função para criar a parte da assintaura no XML. Danilo Junior
  18. Bom dia Pessoal, Estou precisando de um exemplo de como eu passo os parâmetros para a função ACBrNFSeUtil.Assinar usando a CAPICOM, para assinar o loterps e o arquivo XML. Desde já agradeço a ajuda. Danilo Junior
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.