Jump to content

vinicius

Membros
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

1 Neutral

About vinicius

  • Rank
    Novato
  • Birthday 10/04/1971

Recent Profile Visitors

429 profile views
  1. Problema é o seguinte. Ao escolher a impressora funciona, mas ao escolher a segunda impressora ou voltar para a padrão, fica na 1 escolhida. Vou colocar o código fonte. if (pos('<mod>65</mod>', linha) > 0) then begin ACBrNFeDANFeRL1.TipoDANFE:=tiNFCe; ACBrNFe1.DANFE:=ACBrNFeDANFCeFortes1; ACBrNFeDANFCeFortes1.Impressora:=Trim(qry_empresa.FieldByName('impressora_nfce').AsString); // primeira escolha ACBrNFe1.NotasFiscais.Items[0].NFe.Ide.tpImp := tiNFCe; end else begin ACBrNFe1.DANFE:=ACBrNFeDANFeRL1; //ACBrNFeDANFCeFortes1.Impressora:=Printer.Printers[Printer.PrinterIndex]; //depois não volta mais if rgTipoDanfe.ItemIndex = 0 then begin ACBrNFe1.NotasFiscais.Items[0].NFe.Ide.tpImp := tiRetrato; ACBrNFe1.DANFE.TipoDANFE := tiRetrato; end else begin ACBrNFe1.NotasFiscais.Items[0].NFe.Ide.tpImp := tiPaisagem; ACBrNFe1.DANFE.TipoDANFE := tiPaisagem; end; end; Alguem ja passou por isso ?
  2. A nota passou, mas na hora de imprimir, apareceu no modelo de nfe, e não de nfce. O layout da impressao. No acbr exemplo nao diz nada sobre isso. Onde posso ver sobre isso e tambem, cancelamento, consulta, etc....
  3. Agora deu 464 : Código do HASH no Qr-Code diferente do calculado 31190933872083000168650010000000021000001510
  4. Estou gerando a chave da seguinte forma chave := GerarChaveAcesso(UFtoCUF(edtEmitUF.Text), // Código da UF do emitente do Documento Fiscal //); now, // Data da emissao // edtEmitCNPJ.Text, // CNPJ do emitente StrToInt(Trim(Dtm_Venda.cds_vendaIDT_serie.AsString)), // Serie // StrToInt(NumNFe), // numero da nf, 1, // tipo de emissao Dtm_Venda.cds_vendaid_nota.asinteger , // Nota Técnica 2019/001 ALA 17/06/2019 65); // Modelo 65
  5. Configurei NFCe. Arrumei os erros. Agora não consigo sair desse. 397 : parâmetro do qr-code divergente da nota fiscal (chNFe) Tava passando errado o cNF do meu programa. Deixei vazio para que o componente gere o cNF. NFCe em Minas Gerais. 31190933872083000168650010000000011530880247-nfe.xml -<qrCode> <![CDATA[https://nfce.fazenda.mg.gov.br/portalnfce/sistema/qrcode.xhtml?chNFe=31190933872083000168650010000000011530880247&nVersao=100&tpAmb=1&dhEmi=323031392D30392D31305431363A31323A31352D30333A3030&vNF=18.69&vICMS=0.00&digVal=6B3263456E7643784430563742704F765A567432376750437765453D&cIdToken=000001&cHashQRCode=C264296B950D9E5E65D0309014AF22E60AD88367]]> </qrCode> 31190933872083000168650010000000011530880247-nfe.xml
  6. Socorro. Atualizei ACBR pra rodar NFe 4.0 Compila normal, mas ao gerar nfe da o seguinte erro raised exception with message 'Invalid property value' ja tentei com 0, 1, 2, 000, 100, 200 - todos com a mesma mensagem. O que eu faço, ja procurei esse erro nos comentarios da internet e não achei To pensando em reinstalar o ACBr pra ver se para. Socorro
  7. O componente IBGE não traz o código quando tem nome composto. Ex: Belo Horizonte. Não acha a cidade. Percebi que a url fica https://ww2.ibge.gov.br/home/geociencias/areaterritorial/area.php?nome=Belo%2520Horizonte ao invés de https://ww2.ibge.gov.br/home/geociencias/areaterritorial/area.php?nome=Belo%20Horizonte que retorna o correto. Alguem sabe o que fazer?
  8. affff, aleluia..... aqui em BH, em 1 cliente, quando da homologação, passa normal, quando na produção da o seguinte erro: O identificador não está no estado correto para a operação solicitada - URL:https://bhissdigital.pbh.gov.br/bhiss-ws/nfse - SOAPAction:http://ws.bhiss.pbh.gov.br/RecepcionarLoteRps Parece que o lote RPS não passa. pois acontece bem rápido
  9. Cara to agarrado com isso até agora, voce conseguiu descobrir ?
  10. Tive que pedir pra ele usar o programa gratis do governo de CTe, que vergonha !!!!!
  11. o executavel é o mesmo. A validade ta ok. Pendência no SEFAZ não olhei ..... Mas pensando no assunto, será que ao problema na SEFAZ, o erro retornado seria esse ? Muito genérico. Esse tipo de resposta de erro deixa qualquer um doido....
  12. o executavel é o mesmo. A validade ta ok. Pendência no SEFAZ não olhei .....
  13. Bom dia. Todos os meus clientes estão fazendo CTe normalmente, menos 1, e a 3 dias. Mensagem de erro: Versão Layout: 2.00 Ambiente : 1 Versão Aplicativo: 1.1.4 Status Código: 225 Satus Descrição: Rejeição: Falha no Schema do CT-e UF: MG Recibo: Recebimento: Tempo Médio: 0 Quando faço em contingencia ele gera o CTe normalmente, conferi as informações e ta tudo certo. Ao fazer oficial acontece a falha, até 3 dias atras estava tirando os CTe normalmente, de repente parou e não da nenhuma informação a não ser essa mensagem de erro. Será que pode ser problema do certificado da empresa junto a receita ? Ja to 3 dias sem dormir, não sei mais o que fazer. Peguei a base de dados e o certificado dele e instalei na minha máquina. Da o mesmo erro. Socorro !!!! Vou passar 2 cte. o 16006 passou normalmente e o 16007 parou de passar. dai pra frente não passa mais nada. 31170102940638000138570010000160061000160068-cte.xml 31170102940638000138570010000160071000160073-cte.xml
×
×
  • Create New...