Jump to content

vinicius

Membros
  • Posts

    26
  • Joined

  • Last visited

Recent Profile Visitors

802 profile views

vinicius's Achievements

Explorer

Explorer (4/14)

  • First Post
  • Collaborator Rare
  • Week One Done
  • One Month Later
  • One Year In

Recent Badges

1

Reputation

  1. Ai é estranho, não atualizei arquivo ini nem schemas. Componentes foram recompilados pois ao atualizar sistema desinstalo todo o ACBr e reinstalo do zero de novo. O estranho é que o sistema antigo continua funcionando, mas pode ser por causa de algum arquivo ini antigo. vou tentar essa ideia.
  2. Bastante tempo. Não sei como executar esse exemplo. vou colocar parte do meu código fonte, talvez ajude. ACBrNFSe1.NotasFiscais.Clear; AlimentaComponente(vAux); criou_nota:=false; ACBrNFSe1.Enviar(vNumLote); Sleep(5000);{Aguarda 5 segundos para o site de belo horizonte responder} ACBrNFSe1.ConsultarNFSeporRps(ACBrNFSe1.NotasFiscais.Items[0].NFSe.IdentificacaoRps.Numero, ACBrNFSe1.NotasFiscais.Items[0].NFSe.IdentificacaoRps.Serie, TipoRPSToStr(ACBrNFSe1.NotasFiscais.Items[0].NFSe.IdentificacaoRps.Tipo)); MemoResp.Lines.Text := UTF8Encode(ACBrNFSe1.WebServices.ConsNfseRps.RetWS); memoRespWS.Lines.Text := UTF8Encode(ACBrNFSe1.WebServices.ConsNfseRps.RetWS); LoadXML(MemoResp, WBResposta);
  3. Continuo com o problema, não achei nada na internet. Socorro.....
  4. Esse eu não conheço. Só atualizei o ACBR para resolver problema de versão de SPED FISCAL, resolvi o sped, mas o acbr atualizou algo no NFSe que começou a dar esse erro. Não troquei de TACBRNFSe para TACBRNFseX não. Esse ainda nem sabia que existia, e ainda nao sei pra que serve.
  5. Bom dia. Atualizei ACBr e na NFSe, após escolher o certificado, recebo o erro: O documento XML de entrada do servico esta fora do padrao especificado. (O atributo da Tag referencia deve informar a referencia local do conteudo usado no processo de assinatura.) Não achei nada na internet sobre o assunto. Minha versão anterior do sistema continua funcionando normalmente. Não fiz nenhuma alteração no fonte do programa. Delphi 2010
  6. Problema é o seguinte. Ao escolher a impressora funciona, mas ao escolher a segunda impressora ou voltar para a padrão, fica na 1 escolhida. Vou colocar o código fonte. if (pos('<mod>65</mod>', linha) > 0) then begin ACBrNFeDANFeRL1.TipoDANFE:=tiNFCe; ACBrNFe1.DANFE:=ACBrNFeDANFCeFortes1; ACBrNFeDANFCeFortes1.Impressora:=Trim(qry_empresa.FieldByName('impressora_nfce').AsString); // primeira escolha ACBrNFe1.NotasFiscais.Items[0].NFe.Ide.tpImp := tiNFCe; end else begin ACBrNFe1.DANFE:=ACBrNFeDANFeRL1; //ACBrNFeDANFCeFortes1.Impressora:=Printer.Printers[Printer.PrinterIndex]; //depois não volta mais if rgTipoDanfe.ItemIndex = 0 then begin ACBrNFe1.NotasFiscais.Items[0].NFe.Ide.tpImp := tiRetrato; ACBrNFe1.DANFE.TipoDANFE := tiRetrato; end else begin ACBrNFe1.NotasFiscais.Items[0].NFe.Ide.tpImp := tiPaisagem; ACBrNFe1.DANFE.TipoDANFE := tiPaisagem; end; end; Alguem ja passou por isso ?
  7. A nota passou, mas na hora de imprimir, apareceu no modelo de nfe, e não de nfce. O layout da impressao. No acbr exemplo nao diz nada sobre isso. Onde posso ver sobre isso e tambem, cancelamento, consulta, etc....
  8. Agora deu 464 : Código do HASH no Qr-Code diferente do calculado 31190933872083000168650010000000021000001510
  9. Estou gerando a chave da seguinte forma chave := GerarChaveAcesso(UFtoCUF(edtEmitUF.Text), // Código da UF do emitente do Documento Fiscal //); now, // Data da emissao // edtEmitCNPJ.Text, // CNPJ do emitente StrToInt(Trim(Dtm_Venda.cds_vendaIDT_serie.AsString)), // Serie // StrToInt(NumNFe), // numero da nf, 1, // tipo de emissao Dtm_Venda.cds_vendaid_nota.asinteger , // Nota Técnica 2019/001 ALA 17/06/2019 65); // Modelo 65
  10. Configurei NFCe. Arrumei os erros. Agora não consigo sair desse. 397 : parâmetro do qr-code divergente da nota fiscal (chNFe) Tava passando errado o cNF do meu programa. Deixei vazio para que o componente gere o cNF. NFCe em Minas Gerais. 31190933872083000168650010000000011530880247-nfe.xml -<qrCode> <![CDATA[https://nfce.fazenda.mg.gov.br/portalnfce/sistema/qrcode.xhtml?chNFe=31190933872083000168650010000000011530880247&nVersao=100&tpAmb=1&dhEmi=323031392D30392D31305431363A31323A31352D30333A3030&vNF=18.69&vICMS=0.00&digVal=6B3263456E7643784430563742704F765A567432376750437765453D&cIdToken=000001&cHashQRCode=C264296B950D9E5E65D0309014AF22E60AD88367]]> </qrCode> 31190933872083000168650010000000011530880247-nfe.xml
  11. vinicius

    VersaoQRCode

    Socorro. Atualizei ACBR pra rodar NFe 4.0 Compila normal, mas ao gerar nfe da o seguinte erro raised exception with message 'Invalid property value' ja tentei com 0, 1, 2, 000, 100, 200 - todos com a mesma mensagem. O que eu faço, ja procurei esse erro nos comentarios da internet e não achei To pensando em reinstalar o ACBr pra ver se para. Socorro
  12. O componente IBGE não traz o código quando tem nome composto. Ex: Belo Horizonte. Não acha a cidade. Percebi que a url fica https://ww2.ibge.gov.br/home/geociencias/areaterritorial/area.php?nome=Belo%2520Horizonte ao invés de https://ww2.ibge.gov.br/home/geociencias/areaterritorial/area.php?nome=Belo%20Horizonte que retorna o correto. Alguem sabe o que fazer?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.