Jump to content

Renata Albergoni

Membros
  • Posts

    70
  • Joined

  • Last visited

2 Followers

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Renata Albergoni's Achievements

Enthusiast

Enthusiast (6/14)

  • First Post
  • Collaborator Rare
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

2

Reputation

2

Community Answers

  1. Deu certo! \o/ Resumindo.. o meu problema era apagar os eventos ACBrSAT1GetcodigoDeAtivacao e ACBrSAT1GetsignAC e criar novamente com o mesmo conteúdo. E o pior de tudo é que eu havia lido isso nesse tópico, só que eu não tinha entendido muito bem o que fazer. Pensei que meu problema fosse outro. Desculpas pelo incômodo, eu deveria ter prestado mas atenção no que já havia descrito no tópico. Muito muito obrigada!
  2. Daniel Simoes Aconteceu algo curioso agora. Quando fiz o teste com a demo que você me passou eu percebi que no emulador quando eu selecionei a opção de enviar venda apresentou o seguinte erro 2015-06-22 15:23:10.215]:Validando Campos do CFe. [2015-06-22 15:23:10.224]:Campo 'ICMS00', 'ICMS40', 'ICMSSN102' ou 'ICMSSN900' nao informado. [2015-06-22 15:23:10.232]:Erro no Grupo 'ICMS' [2015-06-22 15:23:10.241]:Erro no campo 'imposto' [2015-06-22 15:23:10.252]:ERRO NA EMISSAO: 1999: Rejeicao: Erro nao identificado Ou seja, está sim se comunicando com o emulador, porém está apresentando erro no cadastro de icms. Agora se eu compilo a demo apresenta o erro de codigo de ativação inválido. O que posso fazer para corrigir o erro da demo? Tem alguma solução? Obrigada
  3. Muito obrigada por estar respondendo minhas perguntas, mas infelizmente ainda estou sem sucesso. Vou tentar detalhar o máximo possível de como estou fazendo. 1- Desinstalei o emulador, ativação e aplicativo comercial da fazenda, apaguei as pastas do C:\ (SAT, AC). Limpei tudo. 2- Instalei conforme manual da receita em ordem o "Emulador, Ativação, Aplicativo comercial". Copiei a pasta "SAT" que vem junto com os arquivos da receita para C:\ ficando assim "C:\SAT". 3- Abri o arquivo "Configurações.xml" de dentro da pasta "C:\SAT" e mudei a seguinte linha de código De <versaoSchema>0.03</versaoSchema> <versaoLayoutCFe>0.03</versaoLayoutCFe> Para <versaoSchema>0.05</versaoSchema> <versaoLayoutCFe>0.05</versaoLayoutCFe> Fiz isso acima pois vi que na demo do acbr existe um campo chamado "Versão" com o valor de 0.05. 4- Abri o "Emulador SAT-CFe". 5- Abri a "Ativação SAT-CFe". 6- Na "Ativação SAT-CFe" cliquei no primeiro botão "ATIVAR SAT", preenchi os seguintes campos: Informe o tipo de certificado: Tipo de certificado = AC-SAT/SEFAZ CNPJ: 11.111.111/1111-11 Código de ativação SAT: 123456 Confirmação do código de ativação SAT: 123456789 Após confirmar a ativação aparece "Resultado: Ativado corretamente". Se clicar em testar comunicação aparece "Resultado: Emitido com sucesso.". 7- No botão Associar assinatura coloquei os seguintes campos CNPJ do contribuinte: 11.111.111/1111-11 CNPJ Software House: 11.111.111/1111-11 Assinatura AC: 123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijlffffffffffffffffffffffffffffffffff Cliquei em enviar assinatura e aparece "Resultado: Assinatura do AC Registrado". A assinatura acima eu inventei, coloquei qualquer coisa com um total de 344 caracteres. 8- Abri o aplicativo comercial da receita fui em "Configurar aplicativo" e preenchi os seguintes campos: Senha de Ativação: 123456789 Assinatura: 123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijlffffffffffffffffffffffffffffffffff CNPJ da Software House: 11.111.111/1111-11 Numero do caixa: 002 Versão de entrada: 0.02 Cliquei em Salvar. 9- Depois fui em configurar contribuinte e preenchi os seguintes campos: IE: 111.111.111.111 IM: 123123 CNPJ: 11.111.111/1111-11 Código do regime de tributação do issqn: (Em Branco) Indicador de rateiro do ISSQN (S ou N): N Cliquei em OK Depois configurar produto 001 e coloquei um código de barras válido para conseguir efetuar o teste. Código de barras: 7893151068349 Depois fui até o campo referencia, entrei com 001, inseri o produto 3x, coloquei o valor pago igual ao valor total e cliquei em fechar venda. Apareceu "Emitido com sucesso + conteúdo de notas" e imprimir o comprovante. Toda essa parte acima foi para ver se funcionava com o emulador, ativado, e aplicativo comercial da receita. Funcionou OK. Depois parti para a demo do ACBR. Dando sequência no que já havia feito, fiz da seguinte maneira. 1- Fechei o aplicativo comercial da receita e o Ativador da receita, fiquei apenas com o emulador da receita aberto. 2- Abri a demo compilada SATTeste que você postou acima e preenchi os seguintes campos. Inicialização: satDinamico_cdecl (Escolhi esse por escolher, não sei qual é o correto). -DADOS DO SAT-CFE Arq.Log: ACBrSAT.log Nome DDL: C:\SAT\SAT.DLL Código de ativação: 123456789 Cód UF: 35 Num. Caixa: 002 Ambiente: taHomologacao UTF8: (unchecked) Formatar XML: (Checked) Pág. Codigo: 0 Versão: 0,05 Salvar CFes: (Checked) -DADOS EMITENTE CNPJ: 11.111.111/1111-11 IE: 111.111.111.111 IM: 123123 Regime Tributário: RTSimples Nacional Regime Tributário ISSQN: RTISSMicroEmpresa Ind.Rat.ISSQN: irSim -DADOS SOFT. HOUSE CNPJ: 11.111.111/1111-11 Assinatura: 123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijl123456789abcdefghijlffffffffffffffffffffffffffffffffffffffffffff -REDE E IMPRESSÃO não mudei nada. Cliquei em salvar parametros 3- Cliquei em Inicializar e apareceu "ACBrSAT.Inicializado". 4- Depois fui em Venda, Gerar venda, Enviar venda e apresentou o erro: NumeroSessao: 534169 - Resposta:534169|06010|1999|Rejeição: Erro não identificado|| Depois tentei ir em Ativação, ativar sat e apresentou o erro -- 14:56:31:751 - numeroSessao: 215298 - Comando: AtivarSAT( 1, 11.111.111/1111-11, 35 ) NumeroSessao: 215298 - Resposta:215298|04099|Erro desconhecido na ativação|| Acredito que se foi ativado com o emulador, não preciso ativar novamente, correto? ou não? =\ Bom enfim, parei por aqui. Se volto para o aplicativo comercial da receita consigo fazer vendas normal. O que você sugere que estou fazendo errado? Desculpa o enorme texto, é que quero resolver isso para ontem e tentei matar todas as dúvidas do que estou fazendo. E novamente muito obrigada =D
  4. Ainda não peguei o aparelho, provavelmente vou pegar daqui 1 semana. Eu fui até o site da receita e baixei o "Emulador SAT-CFe", "Ativação SAT-CFe", "Aplicativo Comercial". Com esta combinação tudo funciona, consigo fazer vendas, cancelar, tudo ok. Mas se eu tento "Emulador SAT-CFe" + "Demo do acbr" ele apresenta erro na ativação, no envio para impressora, não consigo fazer nada. Dá o erro . NumeroSessao: 633872 - Resposta:633872|06001|0000|Código de ativação inválido.|| E não estou conseguindo resolver isso. O que será que estou fazendo de errado? Obrigada pela resposta
  5. Olá Pessoal. Estou com o mesmo problema "Código de ativação inválido". No emulador funciona, consigo fazer vendas e tudo mais. No demo do acbr não consigo. Alguém poderia me ajudar plz? Já tentei de tudo, não sei o que estou fazendo de errado. =\
  6. Para quem está com dificuldades Tente fazer o seguinte: Até os testes que fiz está funcionando, ainda não coloquei para os clientes. // Inscrição Estadual [Para quem não tem CNPJ, ou seja Pessoa física e não tem Inscrição estadual] if (Pessoa.Tipo = 'FISICA') then Begin Dest.IE := ''; // Em BRANCO Dest.indIEDest := inNaoContribuinte; End; // Inscrição Estadual [Para quem tem CNPJ e não tem Inscrição estadual] if (Pessoa.Tipo = 'JURIDICA') and ((Pessoa.Tipo = '') or (Pessoa.Tipo = 'ISENTO')) Then Begin Dest.IE := 'ISENTO'; Dest.indIEDest := inIsento; End; // Inscrição Estadual [Para quem tem CNPJ e tem Inscrição estadual] if (Pessoa.Tipo = 'JURIDICA') and (Pessoa.RGIE <> '') and (Pessoa.Tipo <> 'ISENTO') Then Begin Dest.IE := TiraPontos(Pessoa.RGIE; Dest.indIEDest := inContribuinte; End;
  7. Pessoal, já não sei mais o que fazer. O "mardito" erro "The node is neither valid nor invalid because no DTD/Schema declaration was found." continua... Coloquei o caminho do Schemas no arquivo INI, ou seja, deixei fixo em arquivo. O caminho concerteza está correto. Outro teste que fiz foi colocar o caminho do Schemas de forma incorreta para ver o erro que apresentava e.. O erro que apresenta é diferente de " The node is neither valid nor invalid because no DTD/Schema declaration was found. " Quando coloco o caminho de proposito errado, ele me aparece "Diretório de Schemas não encontrado C:\Programa\Schemass\" Ou seja, a exceção dos dois não ocorre no mesmo lugar. O que será que é? Alguma boa alma para me ajudar? Obrigada
  8. Fiz "N" procedimentos, testes, hoje enviei mais de 50 notas em homologacao de todo jeito e vai normal. Eu mesmo não vi o tal do erro acontecer, só os clientes que me reportaram, e o pior é que é varios clientes, portanto acho que seja a minha programacao. Vou formatar minha maquina de desenvolvimento, Instalar o Delphi XE5 novo que compramos aqui, e fazer mais testes novamente. Posto os resultados... Obrigado por enquanto
  9. Gente Muito Obrigada pelas respostas. Mas o erro persiste. Hoje 8 horas da manhã o cliente me ligou, outro cliente, com o mesmo erro de schema Pedi para o cliente reiniciar a maquina. Ele reiniciou enviou a nota e foi normal. Vou tentar fazer algum procedimento que o jorge andrade me falou. Posto resultados. Obrigada novamente.
  10. Debuguei, comigo esse erro nunca aconteceu na vdd. Acontece apenas com alguns clientes. Já testei em rede, em outras maquinas e comigo sempre funciona. Vou colocar para obter o caminho da pasta schemas através do arquivo INI e vou testar. Posto o resultado após os testes. Obrigada
  11. Você sabe de algum programa que talvez possa apresentar conflito com a acbrNFE? Alguma dll, algum processo, não sei. Porque a impressão que tenho é que esse erro está apresentando pois esta gerando o XML de forma incorreta e não porque não consegue pegar o SCHEMA Pode ser isso também? XML gerado de forma incorreta? Obrigada
  12. Regys, ainda continuo com o mesmo problema. Não é o arquivo SCHEMA... Isso está acontecendo com mta frequência em alguns clientes. " The node is neither valid nor invalid because no DTD/Schema declaration was found. " Esse problema acontece do nada. Está funcionando, o cliente emite sei lá, 20 notas, e do nada da o erro. Ele liga para mim, as vezes só reinicio a maquina e já volta, outras vezes eu apago a pasta arquivo SCHEMAS, coloco dinovo o mesmíssimo arquivo e vai, as vezes faço uma simpatia, do dois pulinho, viro, reinicio e vai. kkkkkkkkkkkkkkk Se você puder me ajudar por favor, eu agradeceria mto!
  13. Atualizei o ACBR novamente. Instalei todos os componentes que queria menos o ACBrNFeDanfeFRpkg pelo ACBrInstall Agora estou tentando compilar novamente ACBrNFeDanfeFRpkg e aparece a seguinte mensagem [dcc32 Fatal Error] frxe15.dpk(68): F2051 Unit frxExportODF was compiled with a different version of frxClass.FR_VERSION e para na linha frxrcExports in 'frxrcExports.pas'; =\
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.