Jump to content

Isael Faria Junior

Membros
  • Content Count

    31
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About Isael Faria Junior

  • Rank
    Membro

Recent Profile Visitors

467 profile views
  1. Boa noite Pessoal, Hoje 02/08/2018, quando faço qualquer função, que consulto informação na receita de SP, o mesmo me retorna a seguinte mensagem Ao invés de retornar a situação da nota, por exemplo. Porém, no caso dos outros estados, não apresenta nenhum erro. Alguém está passando pelo mesmo problema ? grato,
  2. Boa noite Graça, Segue o xml que estou tentando evniar 000005288_1NE.xml
  3. Bom dia Senhores, Estou tendo o seguinte problema. Na minha aplicação, estou fazendo todo o processo sem problemas, geração, validação e assinatura. Porem, quando tento enviar para o ambiente de homologação, o componente me retorna o erro 500, pagina não encontrada. Estou fazendo o envio da nfe alterada para a versão 4.0. Alguém poderia me ajudar com este problema ? grato,
  4. Bom dia pessoal, Gostaria de saber se o componente já está atendendo a versão 4.0 da Nfe, se sim, o que devo fazer para atualizar a nova versão, basta atualizar o diretório do componente no svn ? Ou se ainda temos que aguardar, alguém saberia a previsão para a liberação da nova versão ? grato,
  5. Estou com o mesmo problema, porem, fiz os procedimentos citados acima e não resolveu, alguma ideia ?
  6. Bom dia Pessoal, estou tentando utlizar o acbr no meu projeto, porém assim que instalo, e tento compilar o meu projeto para pode executar da o seguinte erro. Já fiz atualização, tentei comentar, mais ai aparecem mais, já desistalei tudo, inclusive o delphi e apresenta o mesmo erro. Alguém pode me ajudar ? Estou utilizando o Delphi xe 8
  7. Boa noite Pessoal, estou gerando a carta de correção da nfe, porem não consigo salvar ela. Procurei e não encontrei nenhum exemplo. Alguém pode me ajudar ?
  8. É um validador da nfe, preciso poder escolher os dois tipos de certificados.
  9. Como faço para usar, pois pode ser escolhido o tipo do certificado ?
  10. Boa Tarde Pessoal, estou com o erro da imagem a abaixo, Quando selecciono o certificado A3, ao tentar carregar, apresenta o seguinte erro. TDF OpenSSL Não Suportado Alguém saberia me dizer o porque deste erro ? Grato pela ajuda.
  11. Consegui resolver o Problema, copiando as dll's de dentro da pasta XMLSec e adicionando a pasta do projeto. Obrigado pessoal pela ajuda.
  12. Boa tarde Juliomar, Está maquina, que postei, 32 bits, então copiei, para o system32 dela. Está dll's nunca foram usadas antes, pois não tinha mais nada instalado na maquina. Creio que o RegSvr32, esteja correto, conforme o que postei. Se puder dar uma olhada e ver se ta certo, já ajuda.
  13. Boa Noite Pessoal, Fiz a minha aplicação utilizando o componente ACBR, com o Delphi xe8. Na maquina que eu fiz o desenvolvimento não apresenta o problema. Porem, quando copio a pasta do executável para o a maquina no cliente e tendo validar o mesmo da o seguinte erro. Exception: Error: unable to load default xmlsec-crypto library. Make sure that you have it installed and check shared libraries path (LD_LIBRARY_PATH) environment variable. Erro: Erro Completo: Já copiei todas a dll's para a pasta do projeto, conforme a imagem (dlls) e fiz também o registro das dll's, utilizando o seguinte script. if EXIST %windir%\SysWOW64 goto Win64 :Win32 ECHO *** Copiando as DLLs *** if NOT EXIST %windir%\System32\capicom.dll copy capicom.dll %windir%\System32 if NOT EXIST %windir%\System32\msxml5.dll copy msxml5.dll %windir%\System32 if NOT EXIST %windir%\System32\msxml5r.dll copy msxml5r.dll %windir%\System32 if NOT EXIST %windir%\System32\ssleay32.dll copy ssleay32.dll %windir%\System32 if NOT EXIST %windir%\System32\libeay32.dll copy libeay32.dll %windir%\System32 ECHO *** Registrando as DLLs *** regsvr32 %windir%\System32\capicom.dll regsvr32 %windir%\System32\msxml5.dll regsvr32 %windir%\System32\ssleay32.dll regsvr32 %windir%\System32\libeay32.dll goto end :Win64 ECHO *** Copiando as DLLs x64 *** if NOT EXIST %windir%\SysWOW64\capicom.dll copy capicom.dll %windir%\SysWOW64 if NOT EXIST %windir%\SysWOW64\msxml5.dll copy msxml5.dll %windir%\SysWOW64 if NOT EXIST %windir%\SysWOW64\msxml5r.dll copy msxml5r.dll %windir%\SysWOW64 if NOT EXIST %windir%\SysWOW64\ssleay32.dll copy ssleay32.dll %windir%\SysWOW64 if NOT EXIST %windir%\SysWOW64\libeay32.dll copy libeay32.dll %windir%\SysWOW64 ECHO *** Registrando as DLLs x64 *** regsvr32 %windir%\SysWOW64\capicom.dll regsvr32 %windir%\SysWOW64\msxml5.dll regsvr32 %windir%\SysWOW64\ssleay32.dll regsvr32 %windir%\SysWOW64\libeay32.dll /s goto end pause :end pause Porem, apresenta ao tentar registrar nas seguintes linhas regsvr32 %windir%\System32\capicom.dll regsvr32 %windir%\System32\msxml5.dll regsvr32 %windir%\System32\ssleay32.dll regsvr32 %windir%\System32\libeay32.dll Alguém poderia me ajudar a resolver o problema ou me indicar, se estou fazendo algo de errado ? Alguém poderia me ajudar, pois, preciso fazer isso funcionar no cliente. Grato,
  14. No demo não apresenta o mesmo erro. Mais estou fazendo o mesmo metodo, que está no demo.
  15. Boa Noite Pessoal, Estou fazendo o seguinte metodo para gerar um PDF. procedure TFormValidadorNfe.brnGerarPDFClick(Sender: TObject); begin OpenDialog.Title := 'Selecione a NFE'; OpenDialog.DefaultExt := '*-nfe.XML'; OpenDialog.Filter := 'Arquivos XML (*.xml)|*.xml|Todos os Arquivos (*.*)|*.*'; OpenDialog.InitialDir := pPathEnviado; procedure TFormValidadorNfe.brnGerarPDFClick(Sender: TObject); begin OpenDialog.Title := 'Selecione a NFE'; OpenDialog.DefaultExt := '*-nfe.XML'; OpenDialog.Filter := 'Arquivos XML (*.xml)|*.xml|Todos os Arquivos (*.*)|*.*'; OpenDialog.InitialDir := pPathEnviado; if OpenDialog.Execute then begin ACBrNFe1.NotasFiscais.Clear; ACBrNFe1.DANFE.Logo := pPathLogo+'\'+pNomeLogo; ACBrNFe1.NotasFiscais.LoadFromFile(OpenDialog.FileName,False); ACBrNFeDANFeRL1.PathPDF := pPathPDF+'\'; ACBrNFe1.NotasFiscais.ImprimirPDF; end; end; Porem.,quando mando executar, apresenta o seguinte erro Estou fazendo a seguinte carga de variáveis, with ACBrNFe1.Configuracoes.WebServices do begin UF := pUF; Ambiente := StrToTpAmb(Ok,IntToStr(StrToInt(pTipoAmbiente))); Visualizar := False; end; with ACBrNFe1.Configuracoes.Geral do begin Salvar := True; end; Alguém, saberia me ajudar com este problema ? Pois, só falta isso, para o ,,meu projeto estár ok. Outro detalhe, e que esse erro, só da na primeira vez, que tento executar a função, na segunda, não da erro. Grato.
×
×
  • Create New...