Jump to content

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

lgerard

Membros
  • Posts

    26
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

lgerard's Achievements

Apprentice

Apprentice (3/14)

  • First Post
  • Collaborator Rare
  • Week One Done
  • One Month Later
  • One Year In

Recent Badges

0

Reputation

  1. Resovido o problema acima! Te toda forma, esperamos o componente atualizado pra testar!
  2. Fiz as alterações oferecidas pelo colega de Pelotas e o envio do XML com a tag <token> dentro da tag <Prestador> deu certo. O problema agora é o retorno: Na procedure "EnviarDados" nesta parte do código FPRetornoWS := FPDFeOwner.SSL.Enviar(FPEnvelopeSoap, FPURL, FPSoapAction, FPMimeType, FPAuthorizationHeader); o primeiro critério é a real estrutura do xml contendo a tag <token> sendo enviado para aprovação e o retorno, no qual é guardado na var FPRetornoWS, chega sem esta tag. ps: Eu acerte o Nfse.xsd assim: 1º <xsd:simpleType name="tsToken"> <xsd:restriction base="xsd:string"> <xsd:maxLength value="32" /> <xsd:minLength value="1" /> <xsd:whiteSpace value="collapse" /> </xsd:restriction> </xsd:simpleType> 2º <xsd:complexType name="tcIdentificacaoPrestador"> <xsd:sequence> <xsd:element name="CpfCnpj" type="tcCpfCnpj" minOccurs="0" maxOccurs="1" /> <xsd:element name="InscricaoMunicipal" type="tsInscricaoMunicipal" minOccurs="0" maxOccurs="1" /> <xsd:element name="Token" type="tsToken" minOccurs="0" maxOccurs="1" /> </xsd:sequence> </xsd:complexType> Estou fazendo algo errado?
  3. lgerard

    Nfse

    Eu! Não se foi coincidência ou não, mas eu estava com este erro e ao colocar esta linha corrigiu NFSe.Configuracoes.Geral.Emitente.Token := wToken; Mesmo assim, o token esta gravando no arquivo 1988A-con-nfse-rps.xml mas não esta chegando neste 1988A-comp-nfse.xml por sua vez, não gerar certo o xml grande final. 1988 é o rps aqui
  4. lgerard

    Nfse

    Blz, é que eu repeti o que tu fez e pra mim ainda faltou algo! Mas vamos indo! Já ajudou muito!
  5. lgerard

    Nfse

    Eu fiz isto tbm e deu certo na criação do arquivo 1988A-con-nfse-rps.xml mas o arquivo q tem "comp" em seu nome, um pré aquivos igual ao final, não cria! nfse.xsd
  6. lgerard

    Nfse

    Veleiro, eu apliquei o que tu fez e deu certo, apanhei para enviar a informação mas deu certo. nfse.xsd#/schema/complexType[6][@name = 'tcIdentificacaoPrestador']/sequence O erro agora eu acredito que seja nos schemas, tu obteve este erro? Tu precisou mexer nos schemas
  7. Boa tarde, tu terias uma previsão de ajuste no componente? Estamos tendo problema com nossos clientes, pois para fazer direto pelo site da prefeitura é um transtorno, algo que é simples pelo sistema.
  8. Pelotas/RS Este material explica tudo! https://intra.avmb-asten.com.br/repositorio/Suporte/NfseToken.pdf
  9. lgerard

    Nfse

    Bom dia, estamos com o mesmo problema, pensamos em adicionar manualmente esta tag, mas em uma próxima atualização iriamos perder, tendo em vista que usamos outros componentes acbr.
  10. Na minha cidade, foi implementado uma nova tag para receber o token, onde esta tag se posiciona dentro da tab prestador. Ela já consta no componente NFSe?
  11. Felipe, obrigado por responder e desculpe a falta de informações A respeito do DNS é o ip configurado no roteador e o alternativo é 8.8.4.4 O antivírus é o PANDA e desativei ele Sem proxy e firewall desativado direto *Estas são parte da configuração que utilizamos no caixa* [WebService] AguardaConsultaRet=0 AjustaAguardaConsultaRet=Não IntervaloTentativas=0 NumeroTentativas=5 UF=RS Ambiente=1 QuebradeLinha=| Salvar=Sim Visualizar=Não TimeOut=5000 SSLType=LT_TLSv1_1 Versao=ve400 ***tempo em segundos*** Ciclo=30 NumeroCaixa=3 SSLCryptLib=cryWinCrypt SSLHttpLib=httpWinHttp SSLLib=libWinCrypt SSLXmlSignLib=xsLibXml2 ICMSEfetivo=Sim
  12. Nosso sistema de Caixa, esta retornando pelo menos 3 a 5 vezes ao dia o erro em anexo. Eu gostaria de saber se alguém esta passando por isto, pois começou com mais frequência agora no último mês? Já analisamos internet, trocamos o computador e vimos a rede! O fato acontece muito mais no wind7 e menos vezes no win10.
  13. Bom dia, estou recebendo um erro com o seguinte texto: 'PFXDataToCertContextWinApi: DadosPFX informado não são válidos', isto quando, o meu sistema feito em DelphiXE5 esta sendo executado em Linux via Wine. Na imagem abaixo, listo a esquerda meu arquivo .ini com as configurações para estabelecer comunicação e a direita o local das Dlls que uso e junto o executável do sistema! Este mesmo sistema quando copiado todo para uma máquina windows e em vez de usar o certificado .crt e sim o pfx funciona corretamente! Seria algo na conversão do pfx par crt? Utilizei este comando para a conversão: openssl pkcs12 -in /home/marcos/.wine/drive_c/ANTONIOAUGUSTO*************************************.pfx -clcerts -nokeys -out /home/marcos/.wine/drive_c/ANTONIOAUGUSTO*************************************.crt. Bom, na verdade, a ideia é fazer o nosso gerenciadorNFeNFCe funcionar também no Linux como o resto de todos os nossos sistemas, onde hoje usamos com tranquilidade nosso ERP e demais sistema menores construídos ao longo de 25 anos. Alguém tem alguma dica ou pode nos ajudar?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.