Jump to content

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

Problema Esquisito Acbrtefd No Visual Studio - Urgente!


  • Este tópico foi criado há 1423 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Faz dois meses que migrei para ACBr para ECF aqui na empresa onde trabalho e vem funcionando perfeitamente.

É perfeito para impressão em várias ECFs diferentes.

 

Tenho que implementar o TEF usando o ACBr e estou tendo um problema que não achei nada parecido no google e nem aqui...

Estou usando um projeto de teste que uso para descobrir como funciona para poder implementar de forma organizada no projeto principal.

Mas no evento OnInfoECF está acontecendo uma doidera esquisita. O e.Operacao, que é do tipo InfoECF, no qual seus valores poderão ser 0, 1 ou 2, ta vindo um valor grande e doido, não entrando nas condições não passando assim a informação requerida pelo ACBrTEFD  que sempre dar erro por conta da falta dessas informações. E toda vez vem um valor estranho que não corresponde a nenhum dos valores possíveis para InfoECF... Testei também no vs2010 e deu o mesmo problema. Testei o projeto de teste que baixei do SVN do ACBr usando esse projeto para VB2012 e também deu a mesma doidera... e eu realmente não sei o que é. Já o uso do ACBrECF funciona perfeitamente.

 

E o pior é que meu patrão da me pressionando pois tem cliente querendo usar o TEF no nosso PDV.

 

O que pode ser?

 

Lembrando que to usando o ACBrFramework.Net.dll de versão 0.9.4.0 de 17/06/2013 baixado do http://sourceforge.net/projects/acbrframework/.

 

Fui passando linha a linha escolhendo meio que no chute, qual deveria ser o valor correto de e.Operacao e vi em outro enum que ta ficando com doidera é o TipoRelatorio em ACBrTEFD_OnComandaECFImprimeVia... Outros enums estão vindo com valores normais...

 

Meus caros, aproveitando eu ter uma máquina virtual com windows xp instalado... instalei nela o VS2010.

Usei o mesmo exemplo e o mais triste... também deu essa mesma doidera...

Isso levando em conta que poderia ser putaria do meu framework do meu computador...

 

E ai, alguém sabe?

post-10243-0-29738100-1373548768_thumb.j

post-10243-0-34440100-1373551205_thumb.j

Edited by alyssonlime

Desenvolvedor C#, Delphi e VB6.

Link to comment
Share on other sites

  • 4 years later...
  • Este tópico foi criado há 1423 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.