Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Estado após AbreCupom()


ivan
  • Este tópico foi criado há 3798 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Olá...

Fiz a atualização do ACBR pelo SVN. Depois desta atualização não estou conseguindo fazer o sistema rodar como era antes. Está ocorrendo na Daruma e Bematech. Não testei nas outras.

Eu tenho um timer, onde imprimo os ítens do cupom que estão em uma fila.

No timer eu executo isto:

1) Verifico se existem itens pendentes de impressão.

2) Verifico o estado da impressora

3) Abro o cupom ou imprimo os itens, sendo que são executados isoladamente, ou seja, numa passagem pelo timer ele abre o cupom e na outra imprime os itens.

Está ocorrendo que insiro o primeiro ítem na venda, o sistema abre o cupom normalmente e então quando entra novamente no código do timer para imprimir o primeiro item, ele da a mensagem de "aguardando resposta do comando anterior". Debugando o código do ACBrECF, vi que ocorre a mensagem na linha 4335 da ACBrECFDaruma.pas.

Depois que usei o AbreCupom, eu posso pedir o estado da impressora mesmo de pois de uns 20 segundos e o erro sempre ocorre.

Segue log:

-- 17:11:16 AbreCupom( , , )

-- 17:11:20 Estado

----------------- ERRO -----------------

Componente ACBrECF ocupado

Aguardando resposta do comando anterior

----------------------------------------

[]'s

Ivan

Link to comment
Share on other sites

  • Moderadores

Você testou com o ECFTeste, fiz alguns testes aqui, inclusive com venda de itens na sequência e está tudo normal.

Experimente no ECFTeste a rotina "Teste de Velocidade", criar um Cupom de 100 Itens por exemplo e verifique se ocorre o problema.

Verifique também as propriedades:

- ACBrECF.TimeOut: aumente para que ele espere mais tempo para emitir o erro.

- ACBrECF.IntervaloAposComando: aumente este tempo para que ele espere mais entre os comandos.

- ACBrECF.Device.ProcessMessages: imita o Application.ProcessMessages.

Caso continue ocorrendo envio o arquivo texto do log por completo.

Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi
Link to comment
Share on other sites

  • Consultores

Régys acredito que o problema esteja sendo a venda frenética

onde isso me ocorreu em 2008, eu não verifica se estava em impressão ou aguardando resposta

e já fazia a venda do próximo produto, assim ficava travando a toda a hora a venda

acredito que ele deva de fazer a verificação de aguardando impressão e aguardando resposta

para dai continuar o registro do próximo item.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro

Bem... boas notícias...

O problema da venda frenética não poderia ser, uma vez que ocorria somente antes do primeiro item, no comando AbreCupom e depois não ocorria mais com nenhum ítem.

Voltei para a versão anterior do ACBr que eu utilizava... dei um Build no projeto... e beleza, rodou 100%, sem nenhum problema. Cheguei a verificar as diferenças nos fontes do acbr (ACBrECF, ACBrECFClass.. etc), mas não havia nenhuma alteração que pudesse gerar o problema.

Então, voltei para a versão atual novamente, Build no projeto e tudo funcionou certinho. Realmente não sei o que aconteceu, mas é melhor assim.

[]'s

Ivan

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.