Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

ACESS VIOLATION AO ENVIAR EVENTO


Junior Salzano
  • Este tópico foi criado há 1491 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Fala galera..

Bom dia...

Galera... estou com um problema aqui na hora de fazer o envio do evento.

 

Estou vinculando as dll no sistema na mão.

 

Quando eu vou fazer o envio de um evento do EFD-REINF gera um ACESS VIOLATION;

 

Windows 7 tem alguma diferença para vincular as DLL ?

 

No windows 10 não tive problemas, estou tendo problemas com windows 7, alguem tem alguma informação ?

 

Valeu galera!


aBRAÇO!

Link to comment
Share on other sites

  • 3 weeks later...

Não sei exatamente o seu problema e nem essa questão da versão do windows, porém, muitas vezes realmente da acess violation por causa do xml. Digamos que vc está pegando os dados do usuário sem fazer alguma validação antes, ai existe um campo que recebe um item de uma coleção, só que o usuário não cadastrou nada. Ai a propriedade do objeto recebe um valor "(out of bound)". Então, quando o componente for gerar o xml irá dar um acess violation; 

Link to comment
Share on other sites

  • Este tópico foi criado há 1491 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.