Jump to content

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Vinibarr Vinibarr

ANSWERED Novo no Sat: tag   <ICMS> </ICMS> vazia

Recommended Posts

Olá pessoal;

Peguei o exemplo do SAT do acbr, fiz ele funcionar e consegui gerar um sat.

Então naturalmente peguei os fontes, copiei e fui adaptando às minhas necessidades. Rodando com a mesma parametrização do teste que deu certo, infelizmente eu devo ter feito algo de errado pois a tag ICMS tá vindo em branco, e daí não consigo emitir o sat, pois dá erro 6010.

O que eu devo ter feito de errado ?

Obrigado

      <det nItem="1">
         <prod>
            <cProd>1</cProd>
            <cEAN>7894900530001</cEAN>
            <xProd>AGUA SEM GAS</xProd>
            <NCM>22011000</NCM>
            <CFOP>5405</CFOP>
            <uCom>UN</uCom>
            <qCom>1.0000</qCom>
            <vUnCom>5.00</vUnCom>
            <indRegra>A</indRegra>
            <obsFiscoDet xCampoDet="campo">
               <xTextoDet>texto</xTextoDet>
            </obsFiscoDet>
         </prod>
         <imposto>
            <vItem12741>0.60</vItem12741>
            <ICMS>
            </ICMS>
            <PIS>
               <PISNT>
                  <CST>04</CST>
               </PISNT>
            </PIS>
            <COFINS>
               <COFINSNT>
                  <CST>04</CST>
               </COFINSNT>
            </COFINS>
         </imposto>
      </det>

Share this post


Link to post
Share on other sites

acho que resolvi; 

            <ICMS>
               <ICMSSN102>
                  <Orig>0</Orig>
                  <CSOSN>500</CSOSN>
               </ICMSSN102>
            </ICMS>

Tinha um if errado definindo se era simples nacional ou não.

Share this post


Link to post
Share on other sites

Bom dia.. que otimo que resolveu.

na proxima vez, para facilitar nossas vidas, em vez de escrever mande em anexo o Xml, e o xml de retorno tambem.

blz..

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hora atrás, Amarildo de Matos disse:

Bom dia.. que otimo que resolveu.

na proxima vez, para facilitar nossas vidas, em vez de escrever mande em anexo o Xml, e o xml de retorno tambem.

blz..

 

Obrigado pela dica Amarildo; farei conforme sua sugestão; muito obrigado.

  • Like 2

Share this post


Link to post
Share on other sites

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

  • Like 1

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...