Jump to content

logo_acbr_paygo.png

Chegou o TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao_saibamais.png

beneficios.png

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

José M. S. Junior

OpenSSL para rodar o ACBr no Linux

  • Este tópico foi criado há 183 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

ATUALIZAÇÃO:

As informações abaixo podem ser desconsideradas. Veja o próximo post que mostra que o ACBr é compatível com o OpenSSL 1.1.x.

 

Olá,

Como sabemos, diversos componentes do ACBr utilizam a lib OpenSSL para comunicação segura. No Linux utilizamos  exclusivamente a lib OpenSSL, até o momento o ACBr é compatível apenas com versões 1.0.v da OpenSSL mas algumas distros do Linux instalam por padrão, a versão 1.1.v, neste caso é necessário baixar e instar a versão anterior para funcionar com o ACBr...

Segue abaixo o procedimento para atualização:

   1-  Para saber qual versão OpenSSl está instalada no Linux, utilize o comando:

# openssl version

Se estiver utilizando a versão 1_1_v, precisará baixar e instalar a versão 1_0_v.

 

   2-   No nosso exemplo estamos utilizamos a distro OpenSuse Leap 15.1, que por padrão é instalada com a versão 1_1_v da OpenSSL.

Utilizando a ferramenta de Instalação de Pacotes YaST do OpenSuse, selecionamos a opção: "Software" e "Gerenciamento de Software". Pesquisamos por: "OpenSSL"

-   Selecione para instalar a versão OpenSSL-1_0_0 que esta disponível no seu repositório (Note que é a versão 1.0.2p), será informado que precisa desinstalar algumas dependências da versão atual. Selecione a primeira opção e dê OK.

2.png

 

-   Selecione para instalar também a LibOpenSSL-1_0_0. (caso essa dependência não seja adicionada automaticamente no passo anterior). Click em Aceitar para Baixar e Instalar...

3.png

 

3-   Confira os pacotes da versão OpenSSL 1_0_0 que precisam estar instalados:

3.png

 

obs: Caso esteja obtendo o erro abaixo na tentativa de comunicação com a SEFAZ, significa que está faltando alguma dependência da OpenSSL-1_0_0 para ser instalada, basta instalar todas as dependências conforme está no passo 3.

image.png

 

Edited by EMBarbosa
Adicionada nota de atualização
  • Like 5
  • Thanks 1

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

A partir desta postagem os fontes ACBr passaram por ajustes, ficando compatível com a versão 1.1.1 da lib OpenSSL. Sendo assim desconsidere as configurações acima, se a sua Distro Linux já utiliza a versão 1.1 da OpenSSL.

Se a sua Distro utiliza a versão anterior da OpenSSL , vai funcionar da mesma forma, porém apenas a versão 1.1 será mantida atualizada pelo projeto OpenSSL, até mesmo por isso o ACBr atualizou-a no Projeto.

Saiba mais detalhes no post abaixo:

 

  • Like 3

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

×
×
  • Create New...