Jump to content

dev botao

problema ao gerar sped com CT-e


bpinformatica
  • Este tópico foi criado há 4454 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde pessoal,

Mais uma vez parabéns pelo projeto!

Bom estou gerando o sped fiscal com o conhecimentos de transporte e verifiquei que está acontecendo dois casos diferentes que acusa erro no SPED.

1: Para CT-e's de emissão própria com a situação cancelada o campo "IND_FRT" está vindo sempre preenchido com o valor "0" emissão de terceiro, mesmo quando não é passado valor para o campo, isso causa erros no SPED pois o campo não deve ser preenchido.

2: para CT-e's inutilizados o campo "IND_FRT" também está vindo preenchido sempre e os valores referente a impostos.. assim como base de calculo ICMS, ALIQUOTA, etc... estão vindo preenchidos com valor "0,00" que também está causando erros na validação.

Espero que possam ajudar.. Muito obrigado desde já.

Att.

Elvis Scorpioni

Link to comment
Share on other sites

  • Consultores

Qual é o registro?

[]'s

Consultor SAC ACBr

Elton
Profissionalize o ACBr na sua empresa, conheça o ACBr Pro.

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Um engenheiro de Controle de Qualidade(QA) entra num bar. Pede uma cerveja. Pede zero cervejas.
Pede 99999999 cervejas. Pede -1 cervejas. Pede um jacaré. Pede asdfdhklçkh.
Link to comment
Share on other sites

Boa tarde pessoal,

Mais uma vez parabéns pelo projeto!

Bom estou gerando o sped fiscal com o conhecimentos de transporte e verifiquei que está acontecendo dois casos diferentes que acusa erro no SPED.

1: Para CT-e's de emissão própria com a situação cancelada o campo "IND_FRT" está vindo sempre preenchido com o valor "0" emissão de terceiro, mesmo quando não é passado valor para o campo, isso causa erros no SPED pois o campo não deve ser preenchido.

2: para CT-e's inutilizados o campo "IND_FRT" também está vindo preenchido sempre e os valores referente a impostos.. assim como base de calculo ICMS, ALIQUOTA, etc... estão vindo preenchidos com valor "0,00" que também está causando erros na validação.

Espero que possam ajudar.. Muito obrigado desde já.

Att.

Elvis Scorpioni

Bom dia Elvis

1: Para CT-e's de emissão própria com a situação cancelada o campo "IND_FRT" está vindo sempre preenchido com o valor "0" emissão de terceiro, mesmo quando não é passado valor para o campo, isso causa erros no SPED pois o campo não deve ser preenchido.

Res: Você deve alimentar o campo com "tfSemCobrancaFrete", isso irá fazer com que o valor saia no TXT "9" que quer dizer "Sem Cobrança de Frente"

2: para CT-e's inutilizados o campo "IND_FRT" também está vindo preenchido sempre e os valores referente a impostos.. assim como base de calculo ICMS, ALIQUOTA, etc... estão vindo preenchidos com valor "0,00" que também está causando erros na validação.

Res: Esse caso segue a mesma indicação acima, e como é inutilizado o campo "COD_SIT" deve ser igual "sdDoctoNumInutilizada", que sairá no TXT o valor "5", e os campo de Base ICMS, Aliquota, e ICMS, você mesmo deve informar 0, passando zero sairá no TXT vazio.

Passei essas informações para você baseado no fonte atual do SVN, verifique se você está com os fontes atualizados.

Tenha um bom dia.

--
Isaque Pinheiro
Aracruz/ES - Brasil
___________________________________________________________________________
Site Oficial: www.isaquepinheiro.com.br 
Youtube: youtube.com/isaquepinheirooficialbr
Facebook: facebook.com.br/isaquepinheirooficialbr
Instagram: instagram.com/isaquepinheirooficialbr
Linkdin: https://www.linkedin.com/in/isaquepinheirooficialbr

Conheça o Projeto ORMBr Framework for Delphi - https://www.ormbr.com.br

 

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.