Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

logos

Texto.png

p200

click.png

click.png

click.png

Erro ao enviar NF-e


Go to solution Solved by Daniel Simoes,
  • Este tópico foi criado há 146 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Desde que atualizei o acbr para a versão 20986 não consigo mais enviar NF-e,

de 10 tentativas consigo emitir uma nota sem que apareça o erro abaixo.

COmando de envio

FDataModule.ACBrNFe1.Enviar(1, False);
aProcolo               := FDataModule.ACBrNFe1.WebServices.Retorno.Protocolo;
aRecibo                := FDataModule.ACBrNFe1.WebServices.Retorno.Recibo;
xmotivo                := FDataModule.ACBrNFe1.WebServices.Retorno.xMotivo;
cStat                  := IntToStr(FDataModule.ACBrNFe1.WebServices.Retorno.cStat);

Mensagem de erro e configurações nas imagens

O estranho é que as vezes mudo para LT_all ai consigo emitir uma nota, na proxima nota dá a mensagem

ai mudo para LTTLSV1_2 ai consigo emitir a nota na proxima dá o erro.

ai fico fazendo esse jogo de troca o SSLTYpe,  Hoje das 7 da manha até agora 12:00 só consegui emitir 5 notas

e tenho umas 100 para emitir.

 

Qualquer dica eu agradeço.

Obrigado.

 

Observação estou usando Windows 7 servicepack 1

Sem título-1.jpg

Sem título-3.jpg

Sem título-2.jpg

Link to post
Share on other sites
  • Fundadores

TLS_v12, é obrigatório para todos os Documentos Fiscais eletrônicos...

A mensagem indica erro de TimeOut...

Qual foi o tempo que você definiu, para TimeOut ?

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites

defini TimeOut como 15.000, ConsultaRet em 30000  Ajust ConsultReto para True

Então Daniel em algumas maquinas com Win7 Service PAck1 funciona

Envo,Consulta,Consulta NF-e,Consulta Destinadas,Manifestação Destinadas, Download Destinadas somente com LT_All,

e em outras maquinas com Win7 só com LT LTTLSV1_2 (Win7).

Como eu disse eu fico testando o SSLType toda vez que acontece, já com win10 não tenho problema nenhum todos funcionam perfeitamente com  LTTLSV1_2

 

Link to post
Share on other sites
  • Fundadores
  • Solution

@Arnaldo Cruz, evite configurar como LT_All, uma vez que todos os WebServices atuais abrigam o uso de TLSv12

Se o TLSv12 não funcionar, isso pode ser resolvido, com Atualizações do Windows, ou usando OpenSSL com A1

  • Like 3
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
×
×
  • Create New...