Jump to content

dev botao

Importar dados do SQL Server 2014 Collation Latin1_General_CI_AS com Zeos


Edson Alves
  • Este tópico foi criado há 1180 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Estou com problemas na importação de uma tabela do SQL Server 2014 com Zeos.

Os campos são do tipo Varchar e collation Latin1_General_CI_AS 

No Microsoft SQL Server Management Studio tudo está ok, mas no DBGrid do meu utilitário de importação (LAZARUS+ZEOS) os nomes com acento são exibidos com "?" . 

 

Link to comment
Share on other sites

  • Moderadores

Depende de como está fazendo a conexão no zeos, via odbc ou direto via driver cliente

então se possível poste um projeto de exemplo e assim poderemos lhe auxiliar

Consultor SAC ACBr Juliomar Marchetti
 

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
 

 

Link to comment
Share on other sites

12 horas atrás, Juliomar Marchetti disse:

Depende de como está fazendo a conexão no zeos, via odbc ou direto via driver cliente

então se possível poste um projeto de exemplo e assim poderemos lhe auxiliar

Fiz direto com Zeos e via ODBC com o componente TODBCConnection e TSQLQuery 

Ambos com o mesmo resultado, sempre com as "?" .

 

Link to comment
Share on other sites

  • Este tópico foi criado há 1180 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

The popup will be closed in 10 seconds...