Jump to content

dev botao

sessões do ini não sao encontradas


Marcelo Manoel da Silva
Go to solution Solved by Marcelo Manoel da Silva,
  • Este tópico foi criado há 514 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Olá a todos... Consegui (com a ajuda de vocês) gerar os boletos no exemplo demo.

agora migrei todo o projeto para dentro do meu e encontrei uma dificuldade.

na hora de ler o arquivo d configuração, não localiza algumas sessões. são elas:

    txtClientID.Text = boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "ClientID")
    txtClientSecret.Text = boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "ClientSecret")
    txtKeyUser.Text = boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "KeyUser")
    txtScope.Text = boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "Scope")
    chkIndicadorPix.Value = CLng(boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "IndicadorPix"))
    chkGravarLog.Value = CLng(boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "LogRegistro"))
    txtPathLog.Text = boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "PathGravarRegistro")
    
    Dim ambiente As String
    ambiente = boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "Ambiente")
    rdbHomologacao.Value = CBool(ambiente)
    rdbProducao.Value = Not CBool(ambiente)
    
    cmbOperacao.ListIndex = CLng(boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "Operacao"))
    cmbSSlType.ListIndex = CLng(boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "SSLType"))
    cmbHttp.ListIndex = CLng(boleto.ConfigLerValor(SESSAO_DFE, "SSLHttpLib"))
    txtVersao.Text = boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "VersaoDF")
    nudTimeOut.Value = CLng(boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "Timeout"))

e no arquivo ini, elas estao lá:

image.png.b04268c8626849e88b3b5a9613512195.png

olha o que mostra no log:

Citar

26/09/22 18:35:19:268 - LIB_ConfigLerValor(Email, TLS)
26/09/22 18:35:19:268 - TLibBoletoConfig.PrecisaCriptografar(Email,TLS)
26/09/22 18:35:19:268 - TLibBoletoConfig.PrecisaCriptografar - Feito Result: False
26/09/22 18:35:19:268 - TLibBoletoConfig.AjustarValor(tfLer,Email,TLS,0)
26/09/22 18:35:19:268 - TLibBoletoConfig.AjustarValor - Feito
26/09/22 18:35:19:268 - TLibBoletoConfig.PrecisaCriptografar(Email,TLS)
26/09/22 18:35:19:268 - TLibBoletoConfig.PrecisaCriptografar - Feito Result: False
26/09/22 18:35:19:268 -    Valor:0, len:1
26/09/22 18:35:19:268 -    SetRetorno(0, 0)
26/09/22 18:35:19:268 - LIB_ConfigLerValor(, ClientID)
26/09/22 18:35:19:268 -    SetRetorno(-3, Sessão não [%s] existe no arquivo de configuração)
26/09/22 18:35:19:268 - LIB_UltimoRetorno
26/09/22 18:35:19:268 -    Codigo:-3, Mensagem:Sess[195][163]o n[195][163]o [%s] existe no arquivo de configura[195][167][195][163]o
 

a versao da dll é a mais recente:

image.png.6884af7271d67eee4995d4232ccfba22.png

mesmo form com mesmos modulos funcionam em um projeto, porem em outro não.

 

Link to comment
Share on other sites

por favor, alguem apague esse topico... errei de forum. era para por no boletos. ja repliquei ele lá, so apagar esse aqui.

obriigado.

 

 

1 hora atrás, Renato Rubinho disse:

Boa noite Marcelo,

Tente sem o prefixo "SESSAO_".

boleto.ConfigLerValor("BOLETOCEDENTEWS","ClientID")

ao invés de 

boleto.ConfigLerValor("SESSAO_BOLETOCEDENTEWS","ClientID")

 

 

olá...

deu o mesmo erro...

favor mover esse topico para os boletos, o de lá foi fechado... era para fechar esse aqui...

 

Link to comment
Share on other sites

45 minutos atrás, Juliomar Marchetti disse:

se trata de Lib então coloquei no local adequado

ocorre o mesmo com o demo para sua linguagem usando a lib?

o demo original funcionou 100%

ai, copiei os forms e modulos e dll e *.ini que estavam funcionais para dentro de meu projeto. e nesse momento apareceu esse problema.
veja que no log de erros nao apareceu 

LIB_ConfigLerValor("sessao", "campo")

apareceu 

26/09/22 18:35:19:268 - LIB_ConfigLerValor(, ClientID)

sem a sessão...

é como se a lib nao tivesse reconhecendo essa parte do arquivo INI...

Link to comment
Share on other sites

  • Solution

eu mudei disso:

    txtClientID.Text = boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "ClientID")
    txtClientSecret.Text = boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "ClientSecret")
    txtKeyUser.Text = boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "KeyUser")
    txtScope.Text = boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "Scope")
    chkIndicadorPix.Value = CLng(boleto.ConfigLerValor(SESSAO_BOLETOCEDENTEWS, "IndicadorPix"))
    chkGravarLog.Value = CLng(boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "LogRegistro"))
    txtPathLog.Text = boleto.ConfigLerValor(SESSAO_BOLETOWEBSERVICE, "PathGravarRegistro")

para isso:

470       txtClientID.Text = boleto.ConfigLerValor("BoletoCedenteWS", "ClientID")
480       txtClientSecret.Text = boleto.ConfigLerValor("BoletoCedenteWS", "ClientSecret")
490       txtKeyUser.Text = boleto.ConfigLerValor("BoletoCedenteWS", "KeyUser")
500       txtScope.Text = boleto.ConfigLerValor("BoletoCedenteWS", "Scope")
510       chkIndicadorPix.Value = CLng(boleto.ConfigLerValor("BoletoCedenteWS", "IndicadorPix"))
520       chkGravarLog.Value = Int(boleto.ConfigLerValor("BoletoWebSevice", "LogRegistro"))
530       txtPathLog.Text = boleto.ConfigLerValor("BoletoWebSevice", "PathGravarRegistro")

e funcionou...

 

Link to comment
Share on other sites

  • Moderadores
5 horas atrás, Marcelo Manoel da Silva disse:

o demo original funcionou 100%

ai, copiei os forms e modulos e dll e *.ini que estavam funcionais para dentro de meu projeto. e nesse momento apareceu esse problema.
veja que no log de erros nao apareceu 

LIB_ConfigLerValor("sessao", "campo")

apareceu 

26/09/22 18:35:19:268 - LIB_ConfigLerValor(, ClientID)

sem a sessão...

é como se a lib nao tivesse reconhecendo essa parte do arquivo INI...

 A ideia é tu pegar e entender com ele funciona e escrever conforme sua aplicação.

geralmente quando se copia e cola não se entende o que é e como foi feito. sugestão é escrever para sua aplicaçaõ

Consultor SAC ACBr Juliomar Marchetti
 

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
 

 

Link to comment
Share on other sites

  • Este tópico foi criado há 514 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.