Jump to content

wilson_jr

Membros
  • Posts

    144
  • Joined

  • Last visited

Recent Profile Visitors

1,184 profile views

wilson_jr's Achievements

Collaborator

Collaborator (7/14)

  • Reacting Well Rare
  • First Post
  • Collaborator Rare
  • Week One Done
  • One Month Later

Recent Badges

28

Reputation

5

Community Answers

  1. Atualizado e funcionando. Obrigado a todos! Att, Wilson
  2. Bom dia! Não estou conseguindo consultar o IBGE quando passo o estado. Na consulta só por nome retorna normal, mas se adiciono a UF retorna esse erro. Exemplo: Efetuando consulta HTTP em: https://servicodados.ibge.gov.br/api/v1/localidades/estados/35/municipios Erro HTTP: 400 Bad Request Socket Error: 0 URL: https://servicodados.ibge.gov.br/api/v1/localidades/estados/35/municipios Resposta HTTP: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <html><head> <title>400 Bad Request</title> </head><body> <h1>Bad Request</h1> <p>Your browser sent a request that this server could not understand.<br /> </p> </body></html> Testando a chamada pelo postman ela está funcionando. Exemplo: Tentei debugar as units ACBrIBGE e ACBrSocket mas não consegui achar nada que pudesse estar causando isso. Alguém saberia o que é? Att, Wilson
  3. Bom dia Italo! Sim, como o pessoal estava precisando emitir as notas até na sexta acabei configurando com libWinCrypt, ai consegui emitir. Mas com a libOpenSSL me retorna esse erro. Att, Wilson
  4. Boa tarde, Verifiquei que é quando utilizo o certificado A1 configurando o Acbr com libOpenSSL.
  5. Boa tarde! você conseguiu emitir em produção? Em um cliente está ocorrendo a mensagem no momento da emissão: Aqui em homologação foi normal. Att, Wilson
  6. Bom dia! O que fiz até agora foi alterar o arquivo ACBrNFSeXServicos.ini [3511102] Nome=Catanduva UF=SP Provedor=Fiorilli Versao=2.00 ProRecepcionar=http://catanduva.sp.gov.br:58080/IssWeb-ejb/IssWebWS/IssWebWS ProLinkURL=http://catanduva.sp.gov.br:58080/issweb/formGerarNF.jsf?nroNota=%NumeroNFSe%&codVerificacao=%CodVerif%&cnpj=%Cnpj%&hash=%ChaveAcesso% Ligar na Fiorilli e pedir para liberar o cnpj que estou utilizando para homologação. Depois disso consegui emitir em homologação. Agora estou ajustando meu sistema com ACBrNFSeX pois ainda estava com o componente antigo. Após isso vou tentar em produção. Att, Wilson
  7. Bom dia Rene, Hoje estarei tentando homologar, vamos postando aqui o progresso que conseguirmos. Att, Wilson
  8. Olá Rene! Dê uma olhada nesse link: Comunicado Acabei de ver esse comunicado. Att, Wilson
  9. Olá, Bom dia! Fiz vários testes em homologação para o estado do RJ e não tive problemas, mas no cliente em produção estou recebendo uns erros estranhos. (Outros estados enviou normal). Exemplo: <ns1:codigo>700</ns1:codigo> <ns1:descricao>Ocorreu um erro desconhecido durante o processamento da sua solicitacao. :: No plugin found for delimiter text/javascript! Registered plugins: [[email protected]e427].</ns1:descricao> </ns1:motivo> <ns1:motivo> <ns1:codigo>700</ns1:codigo> <ns1:descricao>Ocorreu um erro desconhecido durante o processamento da sua solicitacao. :: Could not extract response: no suitable HttpMessageConverter found for response type [org.springframewor[email protected]8352b47] and content type [image/png]</ns1:descricao> </ns1:motivo> alguém já viu isso? Att, Wilson
  10. @João Paulo Alcântara Não sei se vc já progrediu com isso mas fiz assim: HttpClient := TIdHTTP.Create( nil ); SSL := TIdSSLIOHandlerSocketOpenSSL.Create(nil); HttpClient.IOHandler := SSL; with ssl.SSLOptions do begin CertFile := Certificado; //mudar caminho certificado aqui KeyFile := Chave; //mudar caminho certificado aqui Mode := sslmUnassigned; SSLVersions := [sslvTLSv1_2]; end; with HttpClient do begin Request.CustomHeaders.Values['x-inter-conta-corrente'] := Conta; //sua conta corrente Request.ContentType := 'application/json'; Request.CharSet := 'utf-8'; Request.UserAgent := 'Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; Acoo Browser; GTB5; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; Maxthon; InfoPath.1; .NET CLR 3.5.30729; .NET CLR 3.0.30618)'; HandleRedirects := True; HTTPOptions := [hoKeepOrigProtocol, hoInProcessAuth]; end;
  11. @Daniel Simoes Era problema com as dlls msm. Substitui pelas da pasta acbr e foi. Só tem essa questão de não compilar de primeira o AcbrComum precisando ter que trocar o .otares por .dres, do mais tudo certo. Muito obrigado novamente! att, Wilson
  12. Rapaz, sabe que é pode ser isso msm, formatei o note e copiei o backup dos projetos, dlls, etc, mas não atualizei com as dlls da pasta do ACBr. Assim que chegar em casa faço isso e reporto aqui, mas é certeza que é falta de dll. Nem lembrei disso
  13. Boa tarde! Quando tentei também deu essa mensagem já no DCLACBr_Comum. Não sei se isso seria a solução adequada, mas fiz dois testes de instalação, o primeiro foi alterar no fonte o *.otares para *.dres, com isso esse componente foi instalado. Chegou no Boleto e não instalou. O segundo foi renomear/trocar os arquivos .dres e .otares Porém a instalação também não dá certo em alguns componentes como boleto, sat, nfe.... Estou parado nisso. Att, Wilson
  14. Bom dia Daniel! Somente tratando com AnsiString não deu, o que fiz foi mudar a propriedade para utilizar BOM. QRCode.Encoding := qrUTF8BOM; Mudando leu corretamente e foi pago. Obrigado! Podem finalizar.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.