Jump to content

Atilio

Membros
  • Posts

    213
  • Joined

  • Last visited

  • Days Won

    1

Atilio last won the day on September 7 2014

Atilio had the most liked content!

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Atilio's Achievements

Community Regular

Community Regular (8/14)

  • First Post
  • Collaborator Rare
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

4

Reputation

2

Community Answers

  1. Obrigado pela ajuda @EMBarbosa e @Juliomar Marchetti mas não funcionou. Tenho só um Delphi no micro que é o XE8. Tenho apenas um ACBr e um Fortes no computador. Para tirar da dúvida removi do Delphi XE8 os pacotes do ACBr e do Fortes, também apaguei as DCU da minha solução. Depois instalei o Fortes no Delphi pelo pacote sem usar o programa de instalação, dei um Build e um Install, instalou sem problemas. Depois instalei o ACBr utilizando o programa de instalação utilizando a opção de remoção de arquivos antigos, também instalou sem problemas. Minha solução abre mas quando tento compilar dá o erro acima. O arquivo DPR da minha solução faz uses no RLConst. Antigamente eu setava a versão do Fortes [RLConsts.SetVersion(3,71,'B')] mas deixou essa linha comentada por não estar mais utilizando-a e mesmo se ativar não não funciona. Alguma dica mais? Algum arquivo específico que devo procurar no meu HD para apagá-lo? Muito obrigado pessoal !!!
  2. Boa tarde a todos, hoje resolvi atualizar o ACBr e o Fortes (utilizei os instaladores de ambos), tudo funcionou bem. Ao instalar nova versão de ACBr sempre peço para remover arquivos antigos (opção que indica que demora bastante) e também apago a pasta onde descarrego os meus DCUs. Quando tentei compilar minha aplicação comecei a receber um erro de versão diferente de RLConsts.MMAsPixels conforme print abaixo. Optei por desinstalar o novo Fortes e instalar o antigo que eu ainda tinha (tem uns 6 meses), tudo voltou a funcionar normalmente. Utilizo Delphi XE8 e Windows 10.
  3. Obrigado @luisclaudio_jr e @Italo Jurisato Junior ajudaram bastante !!! Obrigado mesmo !
  4. Boa tarde a todos, terei que desenvolver o CTe para uma transportadora e comecei a estudar isso agora, até o momento só trabalhei com NFe. Num CTe (conhecimento de transporte) posso ter mais de uma NFe? Ou pelo que entendi é um CTe para cada NFe? Grato por qualquer colaboração...
  5. Bom dia @Juliana Tamizou , muito grato pela dica, realmente faltava eu setar no meu software o tipo do cliente (pFisica/pJurídica/pOutras) e com isso foi resolvido o problema do segmento Q. Já a atualização sugerida para o segmento P resolveu meu problema inclusive já está em produção em nossos clientes, espero que seja útil. Muito grato pelo auxílio.
  6. Que loucura que é nossa legislação tributária. Se não me engano hoje a cobrança da substituição tributária na venda de sorvetes também encontra-se o IVA conforme a marca do fabricante do sorvete, o IVA é por pauta.
  7. Obrigado pela atenção Juliana, não informei a propriedade Sacado.Pessoa pois até onde eu sei o componente "encontra" isso sozinho. Ou acho que era para encontrar, pois uso o ACBrBoleto há pelo menos 1 ano e nunca informei o tipo da pessoa. Isso mesmo ou agora tenho que informar, e se tenho qual seria a propriedade? Acredito que não devo informar Sacado.Pessoa por ser read-only e o CNPJ ou CPF do sacado sempre informei...
  8. @Juliana Tamizou boa tarde, minha última atualização do ACBr foi hoje 27/07/2016 as 10:00 da manhã. Com as correções acima a qual eu "limpo" os campos aNossoNumero e aDV em remessas SIMPLES o segmento P foi aprovado em homologação. Porém tive rejeição no segmento Q em remessa SIMPLES para pessoa jurídica (importante) carteira 11 e 17 CNAB 240 convênio 7 posições. A crítica do banco (ver abaixo) pede para informar "2" na posição 18 do segmento Q se sacado for pessoa jurídica e estranhamente a propriedade Sacada.Pessoa sempre permanece em pFisica. Nos meus fontes ao alimentar o ACBrBoleto somente tenho a opção de informar o CNPJ/CPF do sacado e o componente "sozinho" descobre se ele é pessoa jurídica ou física, né? Enfim, veja a gambiarra que fiz em anexo (imagem e arquivo PAS) para o componente descobrir se cliente é pessoa física ou jurídica, como só uso banco do Brasil optei por não mexer no ACBrBoleto.pas, importante lembrar que no PAS em anexo foram alterados os segmentos P e Q. Grato, coloquei um monte de 9 no CNPJ do meu cliente. Boa tarde! Arquivo "CC9240_SQ2415.REM" analisado. ==================================================================================================== Segmento Q > Lote 0001 ---------------------------------------------------------------------------------------------------- 08.3Q Tipo de Inscrição 018 a 018 (01)N G005 [1] 09.3Q Número de Inscrição 019 a 033 (15)N G006 [999999999999999] Conforme Manual, posição 018 os TIPOS DE INSCRIÇÃO DO SACADO podem ser: 1 - CPF 2 – CNPJ Após ajustes, reenvie o arquivo para processamento. Podemos encerrar o protocolo? ATT, REBECCA DIANA Unidade de Apoio _________________________________________ BANCO DO BRASIL S/A CENOP Serviços - Recife 0800 729 0500 - Demais localidades 3003 0500 - Capitais [email protected] Antes de imprimir, pense em sua responsabilidade com o meio ambiente. ATENÇÃO: O protocolo em epígrafe será encerrado automaticamente após 25 dias de iniciado. ACBrBancoBrasil - correção segmento P linha 503 e segmento Q linha 555 banco do brasil.pas
  9. @Juliana Tamizou, descobri hoje um novo problema: se a carteira 11 ou 17 BB CNAB 240 7 posições emitida pelo banco ( ACBrBoleto.Cedente.ResponEmissao = tbBancoEmite ) for: ====> SIMPLES: posições 038 a 057 deverá ser preenchida com brancos ou zeros; ====> DESCONTADA: preenche-se normalmente com nosso número; Sendo assim alterei o código conforme o que estou sugerindo abaixo, também segue arquivo em anexo. Nos testes que fizemos ontem tivemos sucesso com a carteira 17 simples porém com a 17 descontada começou a dar problemas. {se banco emite, se carteira 11 ou 17, se convênio 7 dígitos, se CNAB 240 então APENAS no seguimento P preencher com vazio ou zeros Atenção: se carteira for SIMPLES não se deve informar posições 038 a 057, se carteira for DESCONTADA informa-se normalmente reposta homologação bancária ==> Posições 038 a 057: Conforme cadastramento do convênio, quem fará a numeração dos títulos será o Banco do Brasil, nesse caso, preencher com brancos ou zeros} if (ACBrBoleto.Cedente.ResponEmissao = tbBancoEmite) then if (wCarteira = 11) or (wCarteira = 17) then if (CaracTitulo = tcSimples) then begin ANossoNumero := ''; aDV := ''; end; ACBrBancoBrasil.pas
  10. Bom dia Juliana, muito grato pela sua resposta. Porém em novos testes percebi que estou sim setando a propriedade ACBrBoleto.Cedente.ResponEmissao = tbBancoEmite e no segmento P nas posições 038 a 057 o conteúdo sempre é gerado (remessa carteira 11 ou 17, convênio 7 posições, CNAB 240, destinatário pessoa física ou jurídica). O estranho é que quando meu cliente upa a remessa para o banco se o cliente dele é pessoa física a remessa é aprovada e aparece no gerenciador financeiro do banco no dia posterior porém quando é pessoa jurídica é recusada, como poder ver acima mandamos o arquivo para homologação e o mesmo foi rejeitado pelos motivos já descritos. Fiz uma mudança na rotina, inclui um código na linha 480 como pode ver abaixo ou em anexo: {se banco emite, se carteira 11 ou 17, se convênio 7 dígitos, se CNAB 240 então APENAS no seguimento P preencher com vazio ou zeros reposta homologação bancária ==> Posições 038 a 057: Conforme cadastramento do convênio, quem fará a numeração dos títulos será o Banco do Brasil, nesse caso, preencher com brancos ou zeros} if (ACBrBoleto.Cedente.ResponEmissao = tbBancoEmite) then if (wCarteira = 11) or (wCarteira = 17) then begin ANossoNumero := ''; aDV := ''; end; ACBrBancoBrasil.pas
  11. Bom dia a todos, estou enfrentando uma dificuldade ao gerar uma remessa carteira 11 para o banco do Brasil, ela tem sido reprovada e então mandamos o arquivo para análise do banco que retornou o erro abaixo. Meus fontes são de 08/07/2016 e pelo que tenho acompanhado a atualização do arquivo de LOG do ACBrBoleto nenhuma alteração foi realizada até a data atual (15/07/2016). Alguém mais está enfrentando a mesma dificuldade o tem uma dica de como resolver isso? Segue abaixo resposta da análise do Banco do Brasil, dados do cliente omitido visando confidencialidade do mesmo. Grato. Boa tarde, Agencia : 2427 9 - PEDREIRA Beneficiario : 9999 1 - NOME DO CLIENTE Cart/Variacao : 11/019 SIMPLES COM REGISTRO Tipo Convenio : 1 Bco: Numera, emite e expede Situacao : 1 Normal com retorno Nr.Convenio : 1089999 Análise de Arquivo "CCREMESSA": ==================================================================================================== Segmento P > Lote 0001 ---------------------------------------------------------------------------------------------------- Posições 038 a 057: Conforme cadastramento do convênio, quem fará a numeração dos títulos será o Banco do Brasil, nesse caso, preencher com brancos ou zeros Unidade de Apoio _________________________________________ BANCO DO BRASIL S/A CENOP Serviços - Recife 0800 729 0500 - Demais localidades 3003 0500 - Capitais [email protected]
  12. Bom dia a todos. Atualizei meus fontes na sexta-feira 01/07/2016 e em testes de vendas via NFe (emitente lucro presumido comércio em SP e destinatário lucro presumido comércio contribuinte de ICMS no RJ) estou tentando gerar o FECP (ou FCEP/FCP?). Minha dúvida ao gerar valor para FECP surgiu após perceber que o ACBrNFe nesse tipo de situação (destinatário pessoa jurídica com IE) gera a tag do FECP no total da venda mas não gera nos itens. Em vendas SP->RJ para clientes sem IE (não contribuinte ICMS) ou pessoa física o FECP é gerado normalmente, mas quando uso destinatário pessoa jurídica com IE a tag referente ao FECP não é gerado nos itens, somente no total da NFe, o que ao transmitir a NFe gera erro de somatória. Gostaria de saber em operação de vendas para contribuinte devo ou não gerar o FECP. Grato a todos pela atenção!
  13. Alguém sabe informar se o estado de MG também aceita NFCe?
  14. Bom dia pessoal, tenho uma dúvida, podem me ajudar? Usando NFe 310 tenho um emitente regime normal do tipo comércio aqui em SP e está realizando uma venda para uma revenda simples nacional também aqui de SP. Como o emitente já pagou a ST resolvi realizar a venda usando CFOP 5405 com CST 60 sem ST pois o ST já foi recolhido anteriormente. Ao transmitir a NFe está acusando erro de [Total base de ICMS difere do somatório dos itens]. Analisando o XML dos produtos percebi que a base/valor de ICMS (não estou falando de ICMS/ST) não é declarada quando uso CST 60 como podem ver abaixo. Resolvi então mudar a CST para 00 e tudo foi resolvido como podem ver mais abaixo. Minha dúvida é o seguinte: é isso mesmo, não existe valor ICMS em vendas de emitente regime normal quando uso CST 60? Ou meus fontes do ACBrNFe estão desatualizados? Estou usando uma versão de três ou quatro meses atrás para emissão da NFe 3.10. =============> usando CST 60 </prod> <imposto> <vTotTrib>18.54</vTotTrib> <ICMS> <ICMS60> <orig>0</orig> <CST>60</CST> </ICMS60> </ICMS> ... =============> usando CST 00 </prod> <imposto> <vTotTrib>18.54</vTotTrib> <ICMS> <ICMS00> <orig>0</orig> <CST>00</CST> <modBC>3</modBC> <vBC>52.08</vBC> <pICMS>18.0000</pICMS> <vICMS>9.37</vICMS> </ICMS00> </ICMS> ... =============> FIM
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.