Jump to content

jburda

Membros
  • Posts

    66
  • Joined

  • Last visited

Everything posted by jburda

  1. Os Registros J1 e J2 também estão incompatíveis com o PAF-NFCe! Considerando estas mudanças, e outras que devem surgir com o PAF-DAF, creio ser mais interessante o componente ACBRrPAF deverá ficar apenas para ECF, e ser criado um componente ACBrPAF2.
  2. Inclusive, tem o registro Z, que também não está de acordo. Registro Z4 - atual TRegistroZ4 = Class private fCPF_CNPJ: string; /// Número do CPF/CNPJ identificado no campo previsto no item 2 do Requsito VIII. fVl_Total: Currency ; /// Total de vendas no mês, com duas casas decimais, ao CPF/CNPJ indicado no campo 02. fData_INI: TDateTime; /// Primeiro dia do mês a que se refere o relatório de vendas ao CPF/CNPJ identificado no campo 02 fData_FIN: TDateTime; /// Último dia do mês a que se refere o relatório de vendas ao CPF/CNPJ identificado no campo 02 public Registro Z4 - Requisitos 01 Tipo de registro 02 Número do CPF/CNPJ 03 Totalização Mensal 04 Totalização das Vendas 05 Totalização das outras saídas 06 Data Inicial das Saídas ao CPF/CNPJ 07 Data Final das Saídas ao CPF/CNPJ 08 Data da geração do relatório 09 Hora da Geração do Relatório
  3. Boa Noite! Sim, está atualizado até revisão 25797. conteudo de ACBrPAF_V.pas // REGISTRO TIPO V3 - IDENTIFICAÇÃO DO PAF-ECF TRegistroV3 = Class(TRegistroX3); //REGISTRO TIPO V4 - Relação dos equipamentos ECF autorizados a funcionar com o PAF-ECF: TRegistroV4 = Class
  4. Boa tarde! Estou implementando menu fiscal PAF-NFCe em uma aplicação na empresa em que estou trabalhando, e ao atender o arquivo IV - Controle dos DAVs (registros V1, V2, V3 e V4), os campos não condizem com o requisito, pois está atendendo apenas o Registro V do PAF-ECF. Os registros V1 e V2 são idênticos, sendo que o V3 e V4 devem ser Tipo Registo, Data do DAV e Numero do DAV, (não encerrados no V3 e sem documento fiscal no V4). Também não atende o REQUISITO XI, "O PAF-NFC-e deverá incluir o conteúdo dos arquivos gerados em um tag específico de um documento XML, assinado digitalmente com o e-CNPJ do estabelecimento,...." Existe alguma previsão para implementação destes ítens? atodiat_22_015_anexo_unico.pdf (sef.sc.gov.br)
  5. Obrigado! É exatamente este o problema, o cliente tem um NCM que deixou de existir, e ocorreu a rejeição. Devido este incidente, estou colocando uma rotina para conferir se todos os NCMs cadastrados estão na tabela de NCM vigente.
  6. Mas se cancelar e emitir nova, a chave será diferente da que consta na NFCe entregue para o cliente! Neste post, o Cleber diz que para a solução poderia haver necessidade de gerar um novo XML. Então a informação dada não está correta?
  7. Boa noite! Estou implementando a NFC-e(SC), e estou meio perdido no envio da contingência. O XML foi gerado, mas devido NCM inválido, a nota foi recusada. Agora, depois de carregar o XML no ACBrNFe, como procedo para corrigir o NCM e mudar as tags: Ide.tpEmis, Ide.xJust e Ide.dhCont ? Estou fazendo de forma errada? Tem outro método para fazer esta correção?
  8. Boa Noite! Abaixo segue a imagem dos arquivos que estou me referindo. Antes na pasta das notas, ficavam apenas as notas, mas agora, fica todos os arquivos gerados. Inclusive, antes de responder esta mensagem, apaguei a pasta exemplos do ACBr, e baixei novamente do SVN, compilei o exemplo, sem fazer nenhuma configuração no componente original, exceto certificado e demais necessários para requisitar o status do serviço. Os arquivos de requisição e retorno, foram criados no mesmo local que deveria ser gravado apenas a NFe. O componente criou por default a pasta docs e logs, mas não gravou nada em logs.
  9. sim, e como reportado, também ocorre o mesmo!
  10. Sim, ultima atualização que fiz, foi no dia 01/06/2021.
  11. Juliomar, aproveitando o assunto, foi efetuado alguma alteração no componente, quanto a gravação dos arquivos de requisições e respostas? Antes as requisições e respostas, estavam sendo gravadas na pasta de LOGs, mas depois que fiz atualização dos componentes, estes arquivos estão sendo gravados no mesmo local do XML da NF-e e NFC-e. Fiz o teste como o exemplo, e também está fazendo o mesmo! O meu arquivo de configuração está desta forma [Geral] Salvar=1 PathSalvar=S:\infokoch\LOG [Arquivos] Salvar=1 PastaMensal=1 EmissaoPathNFe=1 SepararPorCNPJ=1 SepararPorModelo=1 PathNFe=S:\infokoch\Nota_Fiscal
  12. mesmo problema em em vários clientes, que fiz atualização do programa ontem.
  13. Resolvido! por mais que meu Windows atualiza automaticamente, procurando na internet, a compilação que estava utilizando era 1803, a qual a Microsoft considera morta, não dando mais suporte. Seguindo instruções do suporte da Microsoft, para instalar uma versão do zero, arrisquei fazer uma atualização, a qual funcionou. Link para baixar Ferramenta de criação de mídia “MCT”: https://go.microsoft.com/fwlink/?LinkId=691209 Esta ferramenta efetua o download e tem a opção de criar Pen Drive para instalação do zero, ou atualizar sua versão. Todos os arquivos e licença do Windows são preservados. Após a atualização, ficou com a compilação 1909, e o teste no ambiente de homologação ocorreu tudo normal.
  14. Por acaso você já achou alguma solução? No fórum ninguém responde! Eu testei em computador com windows 7, windows10 (atualizado) e no Windows server2012 R2. Em todos funciona somente em modo produção, dando erro no homologação. Se fosse problema no Windows, também teria o mesmo problema em produção!
  15. Está TLS12, mas dá erro., vou postar imagem das configurações. Se mudar para Produção, funciona normalmente.
  16. sim, estou em São José. Já estou com este problema faz mais de 20 dias. testei em 3 computadores (Windows server2012, Windows 10 e Windows 7).
  17. Passei a ter este problema apenas em ambiente de homologação. no de produção não ocorre! Alguém pode me dar uma idéia do que fazer para resolver? Necessito efetuar alguns testes de emissão de Nf-e, e não consigo enviar a nota, apenas consigo, se enviar como produção! tentei também como o programa de exemplo, mas ocorre o mesmo problema. as configurações estão: SSLlib = libwincrypt CryptLib = cryWinCrypt HTTPlib= httpwinhttp XmlSignLib = xsLibXml2 SSlType = LT_All, mas já tentei com todas as opções.
  18. Passei a ter este problema apenas em ambiente de homologação. no de produção não ocorre! Alguém pode me dar uma idéia do que fazer para resolver? Necessito efetuar alguns testes de emissão de Nf-e, e não consigo enviar a nota, apenas consigo, se enviar como produção! tentei também como o programa de exemplo, mas ocorre o mesmo problema. as configurações estão: SSLlib = libwincrypt CryptLib = cryWinCrypt HTTPlib= httpwinhttp XmlSignLib = xsLibXml2 SSlType = LT_All, mas já tentei com todas as opções.
  19. Deu certo! Eu havia abaixado apenas o ACbrBoleto. Com a correção na Unit do Sicredi, agora o retorno está correto. Não consigo anexar o layout enviado pelo banco, pois está em pdf e é maior que o tamanho permitido para postagem. Obrigado
  20. o Arquivo original está correto. o que coloquei, mudei os dados do cliente. Este é o arquivo de retorno original 40296117.CRT
  21. Está desta forma! No postar, a pagina está removendo o "[ I ]", então substitui na postagem por [X] for X := 0 to (quant_tit - 1) do begin with ACBrBoleto1.ListadeBoletos.Objects[X} do begin ProgressBar1.Position :=X + 1;
  22. Estou utilizando desta forma ACBrBoleto1.ListadeBoletos.Clear; ACBrBoleto1.LerRetorno; quant_tit := ACBrBoleto1.ListadeBoletos.Count; for i := 0 to (quant_tit - 1) do begin with ACBrBoleto1.ListadeBoletos.Objects do begin ProgressBar1.Position := i + 1; mOcorrencia := copy(ACBrBoleto1.Banco.TipoOcorrenciaToDescricao(OcorrenciaOriginal.Tipo), 1, 2); txtOcorrencia := ACBrBoleto1.Banco.TipoOcorrenciaToDescricao(OcorrenciaOriginal.Tipo); ///// as linhas abaixo foram incluidas apenas para colocar em um memo o retorno para este post memo2.Lines.Add('ACBrBoleto1.Banco.TipoOcorrenciaToDescricao '+ACBrBoleto1.Banco.TipoOcorrenciaToDescricao(OcorrenciaOriginal.Tipo)); memo2.Lines.Add('mOcorrencia '+mOcorrencia); memo2.Lines.Add('txtOcorrencia: '+ACBrBoleto1.Banco.TipoOcorrenciaToDescricao(OcorrenciaOriginal.Tipo)); memo2.Lines.Add('-------------------------------'); ////////////////////// end; end; Este foi o retorno obtido Memo2 ACBrBoleto1.Banco.TipoOcorrenciaToDescricao 02-Entrada Confirmada Mocorrencia 02 txtOcorrencia: 02-Entrada Confirmada ------------------------------- ACBrBoleto1.Banco.TipoOcorrenciaToDescricao 02-Entrada Confirmada Mocorrencia 02 txtOcorrencia: 02-Entrada Confirmada ------------------------------- ACBrBoleto1.Banco.TipoOcorrenciaToDescricao 02-Entrada Confirmada Mocorrencia 02 txtOcorrencia: 02-Entrada Confirmada ------------------------------- ACBrBoleto1.Banco.TipoOcorrenciaToDescricao 28-Débito de Tarifas Custas Mocorrencia 28 txtOcorrencia: 28-Débito de Tarifas Custas
  23. Estou tendo problemas na leitura do arquivo de retorno do Banco SICREDI. Efetuei 3 baixas via site do banco, recebi o arquivo de retorno informando codOcorrencia 09, que de acordo com o manual é "09 -Baixado Automaticamente Via Arquivo". 1 A016OY000002 182026123 091601192019010138 1001190000000008400 K000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000 0000000000 000002 Estou recebendo do Acbr como '02-Entrada Confirmada'. Ao conferir o código fonte, constatei que a função TACBrBancoSicredi.CodOcorrenciaToTipo, está retornando toRetornoBaixadoViaArquivo, mas ao utilizar a função TACBrBancoSicredi.TipoOCorrenciaToCod, não existe o tipo de ocorrencia toRetornoBaicadoViaArquivo, tem apenas toRetornoBaixado, o que acaba provocando o retorno do Result := '02'. segue arquivo de retorno do banco 12345117.CRT
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.