Jump to content

lazarinr

Membros
  • Posts

    62
  • Joined

  • Last visited

Everything posted by lazarinr

  1. Muito Obrigado Juliana Atualizei o componente e usei a variável que você falou, Deu certo! Grato.
  2. Boa tarde Juliana, No meu caso eu uso o componente e não utilizo ACBrMonitor. Abri a unit ACBrBancoCaixa e nela não tem tratamento para código de cedente de 7 posição, somente para 6 posições.
  3. Olá SUPORTE SIG 2000 Já conseguiu a resposta para essa questão, pois estou tendo o mesmo problema, fui homologar boleto da caixa e recebi essa mesma inconsistência a mais algumas outras, do suporte da caixa. Se o componente ainda não foi adaptado irei fazer essas adaptações, mais gostaria de ter certeza que ainda não foram implementadas as exigências do manual versão abaixo: INTERCÂMBIO DE INFORMAÇÕES ENTRE BANCOS E EMPRESAS TROCA ELETRÔNICA DE DADOS – CNAB240 ABRIL/2020 67.118 v016 micro Manual_de_Leiaute_de_Arquivo_Eletronico_CNAB_240.rar
  4. Marcos conseguiu resolver o problema? Está acontecendo no meu Delphi 2010 também.
  5. Consegui resolver, desinstalei e instalei o FortesReport novamente e funcionou.
  6. Boa noite Estou tendo esse problema também. Estou com Delphi 2010 e Delphi 7 instalados, inicialmente deu erro e quase todos os pacotes. Fiz o procedimento sugerido pelo EMBarbosa de configurar o PATH e resolveu o problema de conflito (Obrigado EMBarbosa). Porém agora está dando a mensagem de erro Can´t load package - C:\Desenv\....\ACBr_BoletoRL.bpl - Não foi possível encontrar o módulo especificado. Somente nos pacote de DANFE´s. Em anexo está o arquivo de log de instalação. log_Delphi_2010.txt
  7. Descobri o problema!!! Primeiramente descobri que o erro só ocorria quando eu informava data + hora ( ex: '01/01/2017 23:59:59'), se informasse somente data ( ex: '01/01/2017') funcionava normalmente. Então fui alterando as propriedades do TZReadOnlyQuery uma-a-uma e testando para ver se alguma estava influenciando nisso, até que alterei a propriedade ParamCheck para FALSE e então funcionou. Não sei responder porque mais é isso.
  8. Mais uma coisa estranha, se utilizar os operadores >= ou <= funciona, mais com o between não funciona: qryVendas.SQL[vilIdxSQL] := 'and vrp.VRP_DATA >= '+QuotedStr(FormatDateTime('mm/dd/yyyy',dbePeriodo1.Date)); qryVendas.SQL[vilIdxSQL] := 'and vrp.VRP_DATA <= '+QuotedStr(FormatDateTime('mm/dd/yyyy',dbePeriodo2.Date)+' 23:59:59'); qryVendas.SQL[vilIdxSQL] := 'and vrp.VRP_DATA between '+QuotedStr(FormatDateTime('mm/dd/yyyy',dbePeriodo1.Date)+' 00:00:00')+' and '+QuotedStr(FormatDateTime('mm/dd/yyyy',dbePeriodo2.Date)+' 23:59:59');
  9. Juliomar, Obrigado por responder amigo! Descobri que só está acontecendo isso em um campo do tipo data. A query é essa. select vrp.VRP_CODIGO, vrp.PES_COD_CLIENTE, cli.PES_NOME, vrp.VRP_COMPLEMENTO, vrp.VRP_DATA, vrp.VRP_DATA_ENCERRAMENTO, vrp.VRP_VAL_TOTAL_LIQUIDO as VALOR_LIQUIDO, vrp.VRP_STATUS, vrp.PES_COD_VENDEDOR, vnd.PES_NOME as VENDEDOR, vrp.VRP_DATA_VALIDADE from VENDA_RAPIDA vrp left join PESSOAS cli on cli.PES_CODIGO = vrp.PES_COD_CLIENTE left join PESSOAS vnd on vnd.PES_CODIGO = vrp.PES_COD_VENDEDOR where vrp.EMP_CODIGO = 0 and vrp.VRP_STATUS in ('A','P') and vrp.PES_COD_VENDEDOR = 1 and vrp.VRP_DATA between '05/01/2016' and '05/31/2016 23:59:59' and vrp.PES_COD_CLIENTE = 1 order by vrp.VRP_CODIGO desc Os outros filtros estão funcionando, somente esse filtro pela data não funciona. Já tentei utilizar o cast() para converter a data e nada. Parece ignorar essa linha. Juliomar Sobre o CacheUpdate, como estou utilizando o TZReadOnlyQuery, que é somente leitura ele não tem cacheupdate.
  10. Estou migrando meu sistema de BDE para Zeos, e me deparei com o seguinte problema. Tenho muitas querys onde altero os comandos SQL em tempo de execução. Dou um Close na query altero os comandos e dou um Open novamente, no TwwQuery (InfoPower) e no TQuery (BDE) funciona legal. Porém no TZQuery e no TZReadOnlyQuery quando abro a query novamente não atualiza os dados, ou seja, continua os dados que tinha antes, é como se eu não houvesse mudado os comandos, mais já debuguei e ví que os comandos estão alterados. Existe alguma propriedade ou algo que tenho que fazer para funcionar?
  11. OldProgramer Estou tendo o mesmo problema porém no Firebird 2.5
  12. Boa tarde Juliana CNAB 240 Anexei o arquivo com o layout que recebi da cooperativa SICOOB na segunda feira. Layout Sistema Proprio 0001.XLS
  13. Bom dia Pessoal Fiz atualização do ACBr a duas semanas. E a partir daí comecei a ter problemas com o Banco do Brasil e com o SICOOB, com este segundo foi mais grave pois até o momento já detectei dois campos que foram alterados na unit e os arquivos remessa estão sendo rejeitados por esse motivo, são eles: - Código do Convênio - posição 33 à 53 no Header do arquivo. No manual do SICOOB fala que tem que ser vazio e agora está gerando zeros. - Código da Versão - posição 14 à 16 no Header do lote. No manual fala que tem que ser 040 agora está gerando 045. No caso do Banco do Brasil o problema está sendo o nosso número. que está gerando zerado. Após eu alterar o trecho em azul para RightStr(ANossoNumero, 5) voltou a funcionar. Ocorre que ao montagem do nosso número é feito assim: CCCCCC+NNNNN e a formatação de NNNNN colocando zeros à esquerda até completar 11 dígitos exemplo 00000000012, logo LeftStr() pegava somente zeros, quando mudei para RightStr() gerou correto if ((ACBrTitulo.Carteira = '16') or (ACBrTitulo.Carteira = '18')) and (Length(AConvenio) = 6) and (wTamNossoNum = 17) then ANossoNumero := PadLeft(ANossoNumero, 17, '0') else if Length(AConvenio) <= 4 then ANossoNumero := PadLeft(AConvenio, 4, '0') + PadLeft(ANossoNumero, 7, '0') else if (Length(AConvenio) > 4) and (Length(AConvenio) <= 6) then ANossoNumero := PadLeft(AConvenio, 6, '0') + LeftStr(ANossoNumero, 5) else if (Length(AConvenio) = 7) then ANossoNumero := PadLeft(AConvenio, 7, '0') + RightStr(ANossoNumero, 10); O Banco do Brasil já está tudo certo, mais no caso do SICCOB ainda não consegui homologar novamente o arquivo remessa, então ainda pode ter mais divergências.
  14. Olá Willbr2k, não tenho certeza, mais acho que o commit é somente para usuários que tenham permissão para gravar alterações, acho que teremos que postar a unit alterada aqui para alguém dar commit.
  15. Descobri que o motivo da divergência entre as descrições dos código de motivo de rejeição que eu citei na mensagem anterior é porque são de layout diferentes. 63: Result:='63-DV do nosso número inválido' está no manual do padrão CNAB 400 e '63' = Entrada para Título já Cadastrado.está no manual do padrão CNAB 240. Observei que o componente já faz alguns tratamentos deferentes para esses layout em outras procedures. Porém na procedure CodMotivoRejeicaoToDescricao não há esse tratamento. Como vou precisar dessa melhoria no componente, pergunto se alguém já fez esses ajustes? Para não haver retrabalho. Senão eu vou fazer e enviar a unit para ser atualizada no componente.
  16. Também já fiz a homologação no SICOOB. Realmente é o mais fácil que fiz..É como disse o acgubamg, faz os testes no planilha e quando estiver tudo certo, manda os boletos e o arquivo remessa para o banco e pronto! Homologado.
  17. Olá Pessoal No arquivo retorno do Banco do Brasil CNAB 240 segmento T posição 216 o banco está retornando o código A9. Isso está causando um erro. Verifiquei na unit ACBrBancoBrasil na procedure CodMotivoRejeicaoToDescricao e não há tratamento para esse código de motivo. Então procurei o manual de cobrança no site do Banco do Brasil a fim de entender do que se trata esse código A9. Porém os códigos de motivos de retorno que encontrei no manual não batem com os códigos que estão nessa procedure. Por exemplo o código na unit está 63: Result:='63-DV do nosso número inválido' ; no manual do FEBRABAN que baixei do site do banco está '63' = Entrada para Título já Cadastrado. Será estou consultando o manual errado? ou a procedure precisa de manutenção? Estou com a última versão do ACBR.
  18. Pessoal consegui, e é bem mais simples que no Delphi. No Lazarus tem uma função chamada ParamStrUTF8 que utilizei assim: ParamStrUTF8(1). no evento OnCreate do form, chamei o programa dessa forma "Project1.exe -TESTE" e esse comando retornou o parâmetro -TESTE.
  19. Estou tentando chamar um executável de dentro de outro executável e passar um parâmetro para o programa chamado. Faço isso no delphi, mais no lazarus não estou conseguindo. Seria algo do tipo MEUPROGRAMA -x onde -x é o parâmetro passado.
  20. Estou tendo um problema parecido, porém em apenas um cliente e a partir de ontem, antes funcionava corretamente. A partir de hoje de manhã começou a imprimir a máscara ao invés dos valores.
  21. Veja se não está utilizando uma logo muito grande. Eu tive problema com isso, era um bitmap muito grande (em bytes). foi só reduzir o solucionou o problema.
  22. Olá Amigos do ACBR Estou com o seguinte problema. Eu utilizava o Indy para enviar orçamentos de venda. Usava apenas uma conta de e-mail para login (UserName) e uma conta de e-mail para cada vendedor (From), assim cada vendedor recebia os retornos de seus clientes separadamente. Porém quando migrei para o ACBrMail só consigo enviar se na propriedade From estiver o mesmo e-mail utilizado na propriedade UserName. É assim mesmo que funciona o componente ou será que estou fazendo algo errado?
  23. Bom dia André Era isso mesmo. Muito obrigado pela ajuda.
  24. Estou imprimindo a DANFCe feita em Fortes no ambiente de homologação, e não está saindo os dados do emitente, sai apenas uma tarja azul no lugar. O restante está tudo certo. Isso está correto? 51140414929091000159650010000000031000003411.pdf
  25. Bom dia Leandro Araújo Eu estou utilizando o ambiente de homologação na versão 3.10 em MT.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.