Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

Inform Sistemas

Membros
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

4 Neutral

About Inform Sistemas

  • Rank
    Novato

Contact Methods

  • Website URL
    http://www.informsistemas.com.br

Profile Information

  • Sexo
    Indefinido
  • Location
    Maceió-AL
  1. Certamente. Para utilizar a NFC-e não precisa realizar a homologação do PAF-ECF. Em Sergipe por exemplo o PAF-ECF foi abolido assim que entrou em produção a NFC-e.
  2. Boa tarde, Consegui resolver o problema, tive que alterar a seguinte linha na unit "ACBrProvedorRecife": de: ConfigCidade.AssinaRPS := True; para: ConfigCidade.AssinaRPS := False;
  3. Bom dia, Percebi que o erro da assinatura somente ocorre quando tento gerar o lote e depois enviar, se somente utilizar a opção de enviar não ocorre o erro. Segue retorno utilizando o Demo: [Window Title] Demo_acbrnfse [Content] Código Erro : E973 Mensagem... : Assinatura RPS: RPS16439 Correção... : Verifique a assinatura dos RPS Provedor... : Recife [OK] Segue em anexo os logs da pasta Ger. Ger.rar
  4. Bom dia Italojjr, Atualizei o ACBr e fiz o teste em outra maquina. O problema está na hora de assinar o RPS, está ocorrendo a mensagem: Erro não especificado. Depurando vi que ocorre nessa linha na unit "pnfsSignature": signedKey := xmldsig.sign(dsigKey, $00000002); Observei que tanto o RPS quanto o Lote gerados estão assinados, mas ao realizar uma nova assinatura antes de envio é quando ocorre o erro. Especificamente na unit "ACBrNFSe" na linha: NotasFiscais.Assinar; <-- o erro está ocorrendo aqui // NotasFiscais.Assinar(FConfiguracoes.WebServices.Provedor <> proPub
  5. Bom dia Italojjr, A série está correta pois é a mesma utilizada hoje pelo cliente com outro software. Estou anexando um RPS emitido por ele. Verifiquei que existe apenas uma linha a mais na assinatura gerada pelo ACBr, mas mesmo removendo a mesma do código continua dando o erro: <Transform Algorithm="http://www.w3.org/TR/2001/REC-xml-c14n-20010315#WithComments"/> ENVIOLOTE_12647_13082014_091819.xml
  6. Depois de atualizar novamente e reverter todos os fontes passou a ocorrer ao assinar: --------------------------- Debugger Exception Notification --------------------------- Project InformIntegracao.exe raised exception class EOleException with message 'Erro não especificado'. --------------------------- Break Continue Help --------------------------- Depurando vi que ocorre nessa linha na unit "pnfsSignature": signedKey := xmldsig.sign(dsigKey, $00000002);
  7. Boa tarde, Ao realizar os testes passou a ocorrer o erro: <?xml version="1.0"?> -<EnviarLoteRpsResposta xmlns="http://www.abrasf.org.br/ABRASF/arquivos/nfse.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance'>http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"> -<ListaMensagemRetorno> -<MensagemRetorno> <Codigo>E973</Codigo> <Mensagem>Assinatura RPS: rps16438RPS</Mensagem> <Correcao>Verifique a assinatura dos RPS</Correcao> </MensagemRetorno> </ListaMensagemRetorno>
  8. Provavelmente sim, depende do que você utiliza hoje. Por exemplo: Para emitir nota fiscal de importação existem novos campos que precisam ser preenchidos.
  9. Boa tarde Italojjr, Segue a documentação disponível no site da prefeitura, no último link tem o exemplo do uso do WS: Manuais Técnicos de Integração via de Web Service - Manuais de Utilização do Web Service (Modelo Nacional - Versão 1.1) Manuais com as informações necessárias para fazer a comunicação com o sistema da NFS-e do Município através de Web Service. Baixe o documento contendo as instruções básicas de uso. Baixe o documento do Modelo Nacional pela ABRASF Baixe os schemas XML Baixe os arquivos de exemplos de uso do WebService
  10. Boa tarde, Estou tentando gerar e enviar utilizando o "Demo_ACBrNFSe.exe" para o provedor de Recife e está retornando: "Erro Desconhecido ao Enviar o Lote". Segue a resposta do WS: <?xml version="1.0" encoding="UTF-8"?> -<soap:Envelope xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"> -<soap:Body> -<soap:Fault> <faultcode>soap:Client</faultcode> <faultstring>O servidor nao reconheceu o valor do cabecalho HTTP SOAPAction: http://www.abras
×
×
  • Create New...