Jump to content

arce

Membros
  • Posts

    490
  • Joined

  • Last visited

  • Days Won

    3

Everything posted by arce

  1. vc está enviando utilizando schema 2.04.01 e o ws de homologação aceita apenas 2.04.02
  2. webservice em manutenção https://portal.esocial.gov.br/noticias/limpeza-da-base-de-dados-do-ambiente-de-producao-restrita-acontecera-em-18-04
  3. O lote possui o "Protocolo de Envio" (ACBreSocial.WebServices.EnvioLote.RetEnvioLote.dadosRecLote.Protocolo) que é um número que confirma o recebimento dos 50 eventos pelo webservice. O "Recibo" (ACBreSocial.WebServices.ConsultaLote.RetConsultaLote.retEventos.Items.RetEvento.Recibo.nrRecibo) é retornado na consulta, após ser processado pelo ws, este número é individual por evento. Desta forma, em um mesmo lote podem retornar eventos autorizados ou não. O "Recibo" só existirá para eventos autorizados com sucesso.
  4. Está demorando bastante para ter resposta da consulta, até mesmo eventos de tabela que normalmente retornam mais rápido, estão demorando mto.
  5. Bom dia @Italo Jurisato Junior Segue correção do evento S-1020 para gerar o grupo referente a Processo Judicial de Terceiros. Fiz duas pequenas alterações no evento S-1070 e no Gerador, para evitar problemas em layouts futuros pcesGerador.pas pcesS1020.pas pcesS1070.pas
  6. Deu certo, Obrigado. Seguindo esta mudança, em 01/maio entra em produção o 2.04.02?
  7. Boa tarde Ao transmitir o S-1070 o lote é o evento são assinados e validados corretamente (em anexo). Após realizar a consulta do lote está retornando o erro abaixo: <processamento> <cdResposta>403</cdResposta> <descResposta>Leiaute do evento inválido.</descResposta> <versaoAppProcessamento>10.0.0-A2929</versaoAppProcessamento> <dhProcessamento>2018-04-11T17:13:42.22</dhProcessamento> </processamento> Sem as informações da suspensão, está transmitindo corretamente. Alguém está passando por este problema? LOTE-S-1070.xml
  8. Verifique se vc está utilizando os schemas corretos para a versão 2.4.01 e atribua a configuração no ACBr ACBreSocial.Configuracoes.Geral.VersaoDF := ve02_04_01;
  9. @George Augusto Este é o XML do trabalhador, que é individual. Para enviar mais de um é necessário adicioná-los à um lote. Para tal, utilize desta forma. with ACBreSocial.Eventos.NaoPeriodicos.S2200.Add do begin EvtAdmissao.Trabalhador.CpfTrab := '000000000'; {...} end;
  10. arce

    Layout 2.4.02

    @Italo Jurisato Junior Segue as alterações conforme pedido pcesGerador.pas pcesS2299.pas pcesS2306.pas
  11. arce

    Layout 2.4.02

    @Italo Jurisato Junior Fiz a alteração da tag observações e identifiquei outro problema no evento S-2306. pcesGerador.pas pcesS2299.pas pcesS2300.pas pcesS2306.pas
  12. Coloquei uma condição no método GerarInfoAfastamento para aceitar esta situação. OBS: @Italo Jurisato Junior esta é uma das alterações que fiz no post do layout 2.4.02, mas esta mudança vale para todos os layouts pcesS2230.pas
  13. @PEDRO AIRTON DA SILVA deve-se enviar apenas um dos grupos: iniAfastamento ou fimAfastamento. No seu caso, alimente apenas a tag fimAfastamento. O único caso que os dois grupos podem coexistir é em caso de afastamento por férias
  14. arce

    Layout 2.4.02

    Eu substitui a property "observacao": string por "observacoes": TobservacoesCollection, no gerador fiz em caso de v02_04_01 usar o conteúdo de "observacoes" para gerar a tag "observacao" no XML, por isso o parametro GerarGrupo, assim não há necessidade de manter as duas propertys. Caso ache melhor, posso alterar e manter as duas.
  15. arce

    Layout 2.4.02

    @fabibona tbm está ocorrendo o mesmo problema comigo, enviei pela versão 2.4.01 corretamente e depois comparei os XMLs do evento S-1000 de ambas as versões e a estrutura está igual. Pesquisei em outros fóruns, e este erro tbm aconteceu qndo em outras versões tentou-se transmitir eventos que o ws do e-social ainda não estava apto à recepcionar. Talvez seja isto, enviei mensagem ao fale conosco do portal para confirmar esta hipótese.
  16. arce

    Layout 2.4.02

    Bom dia Segue algumas units alteradas para adequação do layout 2.4.02 para a análise. @Italo Jurisato Junior @Rafael Dias pcesCommon.pas pcesConversaoeSocial.pas pcesGerador.pas pcesS2230.pas pcesS2299.pas pcesS2300.pas
  17. arce

    DEBUG

    @Italo Jurisato Junior entendi o q estava fazendo de errado. Depois q reinstalei o componente pelo instalador, havia selecionado a opção de gerar as .dcu em um diretório único ..Acbr\Lib\Delphi\LibD_versao. Então add no libary path os dirs do componente ACBreSocial e funcionou.
  18. arce

    DEBUG

    Bom dia Estou migrando os fontes para a nova versão do ACBr (estava usando aquela com a units nomeadas pelo prefixo eSocial_). Na anterior era possível alterar os fontes diretamente pela IDE do Delphi e recompilar as units do componente sem a necessidade de reinstalar o ACBr. Como faço para habilitar esta funcionalidade?
  19. Estou fazendo as adequações para a versão 2.4.02 do layout e identifiquei o problema. Segue as units @Italo Jurisato Junior @Rafael Dias pcesGerador.pas pcesS2206.pas
  20. Essa é a questão que não fica clara em nenhum manual. Ao meu ver eles coexistem, mas até qndo?
  21. @Joceandro Perin qual versão do layout vc está utilizando? Este é um print do 2.04.01 - evento S-2200
  22. @Italo Jurisato Junior na resolução Resolução nº 13, de 6 de março de 2018 diz o seguinte: Desta forma, subentende-se que o webservice já pode receber os eventos no novo layout.
  23. No meu caso, como não era empregado doméstico. Não gerei as tags e realizei a transmissão. Em qual manual vc encontrou esta informação @Joceandro Perin?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.