Jump to content

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

daniboy

Membros
  • Posts

    61
  • Joined

  • Last visited

Recent Profile Visitors

854 profile views

daniboy's Achievements

Enthusiast

Enthusiast (6/14)

  • Reacting Well Rare
  • First Post
  • Collaborator Rare
  • Week One Done
  • One Month Later

Recent Badges

8

Reputation

  1. Boa tarde, pessoal! Estou implementando uma solução de boletagem para um cliente Santander. A gerente aponta críticas no arquivo remessa, registro movimento, posição 157 - 158, campo "Primeira instrução". Segundo o manual essas posições devem ser preenchidas com os valores abaixo. Consultando a unit ACBrBancoSantander.pas localizada nos fontes, verifiquei que esses campos são preenchidos através de um campo texto. Seria correto eu alimentar esse campo com algum código da nota 25? É importante ressaltar que atualizei a pasta svn.
  2. Pessoal, deu certo por aqui. Consegui resolver o problema com a permissão de adm para o Prompt. Obrigado pelo suporte @BigWings e @Juliomar Marchetti
  3. 1) Sim, havia copiado mas talvez a versão x86. 2) Sim, mas quando vou registrar recebo mensagem de erro do regsvr32 3) Não, e foi a razão de todos os problemas! Quando abri o prompt com perfil de Adm consegui registrar a msxml5.dll e a capicom.dll e num teste rápido verifiquei que havia conseguido assinar. Não permiti o envio pois se tratava de uma nota teste. Ontem, devido aos prazos de geração da NF eu acabei remontando o sistema na máquina antiga. Mas hoje irei fazer nova tentativa, dessa vez registrando apenas a msxml5.dll. Após isso irei testar com as dlls da LibXml2 (x64)
  4. Estou tentando forçar o registro das dlls capicom.dll e msxml5.dll Tanto na pasta C:\Windows\SysWow64 quanto na pasta do meu executável eu recebo essa msg de erro.
  5. Obtenho "Erro ao inicializar a biblioteca LibXML2"
  6. Sem problemas quanto ao mal entendido. Vamos lá: Eu tenho as units do exemplo em ACBrTrunk2\Exemplos\ACBrDFe\ACBrNFe\Delphi Mas não consigo compilar pois não instalo algumas bibliotecas como a do DanfeFortesReport. Vc tem esse exemplo compilado em algum repósitorio para eu fazer o download e realizar esse teste? Obrigado
  7. @Juliomar Marchetti, No outro post eu pedi uma ajuda pq migrei de um Win7x32 para um Win10x64. Nesse nova máquina não estou conseguindo gerar NFe devido ao problema "Class não registrada" no momento de assinar o documento. Você me orientou a reinstalar a biblioteca com a opção que força a remoção da Capicom pq suspeitava da utilização dessa biblioteca mesmo eu deixando claro que estou usando WinCrypt em tempo de execução. As mensagens de erro do delphi ocorreram pq o componente no DataModule estava setado com opções que não estão mais disponíveis. Fiz a alteração, rebuildei e ok! Mas o problema principal continua: Ao tentar assinar o documento obtenho a mesma mensagem. Estou pensando voltar a utilizar o win7 se for o caso. Meu cliente ta parado
  8. Juliomar, alguma outra coisa que eu possa testar?
  9. De fato o componente estava com essas opções. Eu as seto em tempo de execução. Mas agora já deixei o componente nesse default. De qualquer forma ainda não estou conseguindo assinar a NFe
  10. Fiz a declaração, rebuildei mas ainda continuo tendo a mesma mensagem
  11. Fiz o update do repositório ACBr, refiz a instalação com a opção para ignorar a Capicom marcada, ao abrir o projeto ignorei o erro, fiz novo build da aplicação, coloquei na maquina do cliente, mas mesmo assim continuo tendo o mesmo.
  12. Juliomar, bom dia! Minha opção para SSL Lib esta setada para WinCrypt. Nesse caso não estou utilizando Capicom, certo?
  13. Boa noite, pessoal! Migrei meu sistema gerador de NFe de um máquina Win7 x32 para uma Win10 x64 nesse final de semana e desde então venho recebendo o erro "Classe não registrada" quando vou assinar a nota. Tomei o cuidado de atualizar o windows 10 por completo e também já tentei copiar os arquivos capicom.dll, msxml5.dll, msxml5r.dll e instala.bat que constam na pasta DLLs do instalador para a pasta C:\Windows\SysWon64 e executei o bat. Estou utilizando as opções SSLLib -> WinCrypt CryptLib -> WinCrypt HTTPLib -> WinHttp XML Sign Lib -> MxXml Vocês teriam alguma nova sugestão?
  14. Daniel, bom dia! No meu caso o que resolveu foi excluir o repositório, baixá-lo novamente e instalar. Obrigado pela atenção
  15. Bom dia, Daniel! Inicialmente satisfação enorme em falar com o "pai da criança"! Muito obrigado pelo trabalho de vcs! Faz a uma enorme diferença na vida dos programadores!!! Procedi como me disse mas esbarrei no mesmo erro.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.