Jump to content

luiz.bazan

Membros
  • Posts

    21
  • Joined

  • Last visited

Everything posted by luiz.bazan

  1. Boa tarde , Estou com um sat de cliente já produção e o mesmo nao funciona .... pelo aplicativo deles vai normalmente ... pelo acbr ... ele fala que foi encontrado um erro no vinculo com a função !! alguem pode ajudar ?
  2. luiz.bazan

    Rede Sat

    Consigo mandar do meu computador o comando para um sat que esta em outro computador ? como no caso de lojas com mais de um PDV e apenas um aparelho ?? Ou o acbr aceita apenas se tiver na usb local ?
  3. Alguem sabe me dizer se está funcionando a função Extrair LOG? procedure TACBrSAT.ExtrairLogs(NomeArquivo: String); var SL: TStringList; begin if NomeArquivo = '' then raise EACBrSATErro.Create('Nome para Arquivo de Log não especificado'); SL := TStringList.Create; try SL.Clear; ExtrairLogs(SL); SL.SaveToFile(NomeArquivo) Finally SL.Free; end; end ; Aqui a mesma cria um arquivo vazio
  4. Olá ..... essas tags são configuradas no codigo ? <?xml version="1.0" encoding="utf-8"?> <infCFe versaoDadosEnt="0.06"> Isso que mandei acima é do exemplo da sweda... no acbr é o seguinte : <infCFe versaoDadosEnt="0.05"> apenas isso ... tem como modificar isso ?
  5. Certo deu .... Troquei as pastas deu certo apenas o teste fim a fim que não foi NumeroSessao: 76619 - Resposta:076619|09099|Erro desconhecido|| O que pode ser ?
  6. Mesmo com o aplicativo compilado do SATTESTE.exe .... o retorno acusa : ACBrSAT.Inicializado -- 15:48:04:514 - numeroSessao: 894794 - Comando: ConsultarStatusOperacional EAccessViolation - Access violation -- 15:49:26:081 - numeroSessao: 557508 - Comando: ConsultarSAT NumeroSessao: 557508 - Resposta:TimeOut - O SAT não está respondendo.
  7. Acredito que sim coloquei nas pastas a dll. Em qual pasta que devo trocar essa dll?
  8. deu outro erro no log - 14:40:01:352 - -- 14:40:01:352 - numeroSessao: 380962 - Comando: TesteFimAFim( ) - 14:41:04:165 - NumeroSessao: 380962 - Resposta:TimeOut - O SAT não está respondendo. - 14:41:04:178 - -- 14:41:04:178 - numeroSessao: 468830 - Comando: TesteFimAFim( ) - 14:42:06:729 - NumeroSessao: 468830 - Resposta:TimeOut - O SAT não está respondendo. - 14:42:22:151 - -- 14:42:22:151 - numeroSessao: 766427 - Comando: ExtrairLogs - 14:43:24:950 - NumeroSessao: 766427 - Resposta:TimeOut - O SAT não está respondendo.
  9. NSERIE.........: LAN_MAC........: STATUS_LAN.....: CONECTADO NIVEL_BATERIA..: ALTO MT_TOTAL.......: MT_USADA.......: DH_ATUAL.......: 30/12/1899 VER_SB.........: VER_LAYOUT.....: ULTIMO_CFe.....: LISTA_INICIAL..: LISTA_FINAL....: DH_CFe.........: 30/12/1899 Esse é o unico retorno do memo ... engraçado que com o DIMEP estava funcionando OK.
  10. Olá bom dia , Recentemente recebi o aparelho do sat sweda ss1000 para desenvolvimento. Porém apenas a função de ativação STDCALL executa com sucesso... as demais ele acusa não responder e não executa a função. Existe alguma configuração inicial necessária para esse aparelho da SWEDA ? Obrigado.
  11. Voce esta usando o Emulador da receita ? se vc puder posta o cml de uma venda pra mim por favor fazer o teste aqui ver se é isso
  12. É complicado esses erros né ; Aqui fala Erro na emissao de teste , e ai da erro desconhecido ... assim nao tem como achar o problema.
  13. Alem do aparelho do SAT DIMEP eu deixo o emulador aberto para ver melhor o retorno ... seguinte ele havia dado erros de CST no PIS e COFINS , troquei os códigos e não deu mais o erro mas no emulador ele fica o seguinte status no teste Fim a Fim : Carregando CFe Teste. Validando CFe Teste. Completando CFe Teste. Erro na Emissao de Teste Alguem tem idéia do pq disso ???
  14. Galera , pelo menos com a DIMEP consegui usando o emulador da sefaz ... está dando apenas erro de campos ICMS00,ICMSSN102, e alguns outros ..... arrumei os eventos do GETCODIGO E GETASSINATURA e ai deu certo.
  15. Pelo Lazarus ele acusa Acess Violation tanto no comando TrocarCodigodeAtivação como no ATIVARSAT , outras vezes ele simplesmente para de responder e trava a aplicação. Sobre o evento do ACBR ONGETCODATIVACAO está vazio , tem que ser colocado algo ??? As funçoes estão corretas na ativação .. foram feitas com STDCALL igual você falou acima
  16. Mesmo com o Demo compilado no lazarus nao deu certo ...ele deu não respondendo e fecha a aplicação.
  17. No metodo de ativação ele usa : ACBrSAT1.AtivarSAT(1, edtCnpj.text, strtoint(edtUF.text)); que é : function TACBrSAT.AtivarSAT(subComando : Integer ; CNPJ : AnsiString ; cUF : Integer) : String ; begin fsComandoLog := 'AtivarSAT( '+IntToStr(subComando)+', '+CNPJ+', '+IntToStr(cUF)+' )'; IniciaComando; Result := FinalizaComando( fsSATClass.AtivarSAT( subComando, CNPJ, cUF ) ); end ; Não achei o evento OnGetCodigoDeAtivacao
  18. O meu caso com o aparelho da DIMEP nem mesmo reiniciando pelo acbr teste funciona ... da o erro Inicialização inválida.
  19. Olá Boa tarde , Estou com alguns problemas e se possivel preciso de uma ajuda para o desenvolvimento do SAT com o aparelho da DIMEP usando ACBr , seguinte consegui fazer a inicialização porem todas as outras funções ele acusa erro de COD de ATIVACAO , porém o meu kit de desenvolvimento da dimep ja veio falando que é ativado ..e realmente fiz os testes com o marlus gerente do projeto da dimep e pelo programa deles foi normalmente. Criei outro tópico por ser especifico com o KIT da DIMEP , hávia um tópico parecido porém sem comunicação fisica. OBRIGADO
  20. Olá , estou testando o acbrSAT exemplo e todas as funçoes dão o mesmo erro "ACBrSAT não foi inicializado corretamente". Porém o emulador da SEFAZ está ok , inclusive fiz varios testes com a DLL de alto Nivel da DARUMA.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.