Jump to content

Soft Design

Membros
  • Content Count

    35
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Soft Design

  • Rank
    Membro

Contact Methods

  • Website URL
    http://www.vendaplus.com.br/

Profile Information

  • Sexo
    Masculino
  • Localização
    Piracicaba

Recent Profile Visitors

817 profile views
  1. Boa tarde, Como faço para aparecer na impressão o sequencial dos itens? Ex: Item | Código | Nome | etc... 1 | ABC123 | Primeiro item | .... 2 | 123ABC | Segundo item | .... Aah... Preciso também que caiba o endereço completo em uma linha, nos dados do emitente, ele esta jogando apenas a sigla do estado para baixo.. Desde já agradeço, obrigado!
  2. Boa tarde, Acabei de atualizar todo o ACBr por conta de um erro de "criptografia 24" com certificado a3 e a princípio este erro foi solucionado com as seguintes configurações: SSLLib: libWinCrypt CryptLib: cryWinCrypt HttpLib: httpWinHttp XMLSignLib: xsLibXml2 Porem agora esta dando o seguinte erro após colocar o PIN do certificado: Erro: Falha em obter Provedor de Criptografia do Certificado. Erro: 8009001B , erro $8009001B (Print abaixo) Pesquei em diversos lugares mas não encontrei nada com este erro. Alguém já passou por isso ?
  3. Ok.. Estou procurando porém não encontrei nada até o momento. Obrigado.
  4. Reinstalei o ACBr e esta parte da configuração OK. Agora quando vou testar no cliente mudou o erro. Erro ao emitir agora: "Falha em obter Provedor de Criptografia do Certificado. Erro: 8009001B , erro $8009001B"
  5. Abrindo este .pas esta exatamente como citou, mas vi que o .dcu que esta no Lib esta com a versão anterior, pode ser isso? Não estou encontrando a nova, mando atualizar e também não atualiza... Pelo o que vi não esta pegando deste arquivo as configurações...
  6. Exato, tentei pelo Object Inspector e via código.. Como faço para ver em qual revisão esta? (Apesar que mandei hoje mesmo atualizar). Mas, alterando as configurações para a seguinte: SSLLib: libWinCrypt SSLCryptLib: cryWinCrypt SSLHttpLib: httpWinHttp SSLXmlSignLib: xsMsXml Ele começou acessar o certificado, pedindo PIN, porém o erro altera para: O atributo ‘Algorithm’ tem valor ‘http://www.w3.org/2001/04/xmldsig-more#rsa-sha256‘ que não corresponde ao valor fixo ‘http://www.w3.org/2000/09/xmldsig#rsa-sha1‘ no DTD ou no esquema. Já pesquisei e fiz de tudo e o erro persiste. - Coloquei as dll msxml5 tanto na pasta do sistema quanto no System32, registrei, reiniciei o pc e persiste o erro. De qualquer forma travo em um dos dois...
  7. Esta sim.. Inclusive já foi instalado o trunk2 direto nesta maquina que é nova, então não tem arquivos antigos...
  8. Obrigado BigWings. Mas o SSLXmlSignLib não aparece a opção de setar xsLibXML2. Atualizei os fontes do ACBr e mesmo assim não apareceu...
  9. Boa tarde pessoal, Já passei por esta situação com o certificado A1, porém olhando o fórum resolvi sem problemas, fazendo a instalação no XP e exportando com as chaves, porém acaba de me acontecer com um cliente o mesmo erro "Não há suporte para o tipo de Provedor de Serviços de Criptografia '24'" porém ele está com um certificado A3. Liguei na certificado e falaram que todos os certificado agora tem que ser com cadeia de 2048 e que agora só será feito assim. Alguém já passou por esta situação e pode auxiliar?
  10. Peguei o projeto no meio aqui, estou tentando fazer funcionar o Emulador aqui para facilitar os testes.
  11. Brother estou verificando aqui também, meu XML parece que esta faltando bastante coisa, não sei o que aconteceu.
  12. e como é feito essa soma? pois total do cupom esta R$ 1,99 e total do pagamento R$ 2,00, mesmo assim não aparece.
  13. Boa tarde pessoal, Estou tentando colocar o troco no SAT e o mesmo não esta saindo no XML e por conta disso não é aprovada a venda. ACBrSat1.CFe.Pagto.vTroco = vlTroco; // Passando valor do troco Alguém já passou por isso e sabe como resolver? já procurei em todo lugar e não acho nada referente a isso. Desde já agradeço! Att.
  14. Boa tarde pessoal, Fiz o teste no cliente e deu certo, com o simulador não, mas em produção funcionou. Obrigado a todos!
  15. Boa tarde, Hasa, não tem esse log. Ricardo, fizemos este teste e o erro persiste.
×
×
  • Create New...