Jump to content

idez

Membros Pro
  • Posts

    125
  • Joined

  • Last visited

Everything posted by idez

  1. Bom dia Italo. Sim, realizando testes no servidor de Produção funcionou normalmente. Porém percebi que após 3 comandos consecutivos recebo o mesmo erro: Start tag expected, '<' not found. Para contornar isso eu preciso a cada comando criar um novo ACBrNFSeX. Aí não acontece o erro. Isso só me acontece no provedor IPM. Nos demais não há problemas.
  2. Bom dia Italo. Atualizei os fontes do ACBr hoje de manhã, pois acompanhei no Discord as interações sobre esse assunto. Porém ao validar NFS-e para o provedor IPM de Vera Cruz - RS recebe o erro Start tag expected, '<' not found. Em anexo os XML gerado no envio e a imagem do retorno do sistema. Reparei que no XML -ger-nfse-soap.xml há conteúdos fora de tags. Pode ser esse o problema? 1-ger-nfse.xml 1-ger-nfse-soap.xml 4322063554782000018256000000000000001-rps.xml
  3. Bom dia Italo. As NFS-e do provedor BHISS estão validando normalmente. Grato pelo auxílio.
  4. Bom dia Italo. Realizei testes com essa Unit e transmitiu a NFSe para a prefeitura. Porém o erro continuava o mesmo. Então entrei em contato com a prefeitura que fez um ajuste no servidor de homologação e com isso validou normalmente. Essa Unit vai estar no SVN na próxima atualização? Desde já agradeço pelo auxílio.
  5. Bom dia. Estou recebendo o retorno E180 - O lote foi recebido mas não foi processado. Esse erro estou recebendo na migração do ACBrNFSe para o ACBrNFSeX Provedor BHISS - Porto Alegre - RS. Em anexo os XML. 202200000000001-env-lot.xml 202200000000001-env-lot-soap.xml 202200000000001-rec.xml 202200000000001-rec-soap.xml A60102844J20224000000002-con-lot.xml A60102844J20224000000002-con-lot-soap.xml A60102844J20224000000002-con-sit.xml A60102844J20224000000002-con-sit-soap.xml A60102844J20224000000002-lista-nfse-con-lot.xml A60102844J20224000000002-lista-nfse-con-lot-soap.xml A60102844J20224000000002-sit.xml A60102844J20224000000002-sit-soap.xml
  6. Bom dia Italo. Ok, vou providenciar esse ajuste no sistema. No mais, agradeço o auxílio.
  7. Boa tarde Italo. A princípio está validando agora com o componente ACBrNFSeX. Porém estou com dificuldade para entender como obter a resposta da Prefeitura. Mesmo validando a nota na prefeitura não recebo o XML da Nota. Preciso realizar uma consulta da Nota na prefeitura para obter o XML. Isso está correto assim? ACBrNFSeX1.WebService.Emite.Erros retorna dois erros que estão na imagem que mandei junto nos arquivos. Em anexo estão os arquivos para que você possa verificar. NFSeX.rar
  8. Boa tarde Italo. Verificando novamente as diferenças entre a geração do XML de envio do componente NFSe e do componente NFSeX há uma diferença bem grande. No componente NFSeX a Tag remessa possui seu conteúdo dentro de <![CDATA[...]]> No componente NFSe a Tag remessa possui o conteúdo do XML. Em anexo novos testes com o componente NFSe que validou a Nota e o componente NFSeX que não consigo validar a Nota de forma nenhuma. Aguardo seus comentários. Arquivo NFSe.rar
  9. Boa tarde Italo. Já conseguiu ver alguma solução para esse problema?
  10. Bom dia Italo. Sim, no componente ACBrNFSe valida normalmente. Anexei arquivo zipado com duas pastas. Uma com o xml (soap) do componente ACBrNFSe e outra com o soap do ACBrNFSeX para sua apreciação. Não estou conseguindo rodar o programa exemplo do ACBr, pois não uso o Fortes Report. Utilizo o Fast, portanto está dando erro na compilação. Baixei o manual de migração também e verifiquei as instruções e aparentemente está tudo certo. NFSE.rar
  11. Boa tarde Italo! Sim, somente essa mensagem aparece no retorno. Estou fazendo testes com nosso sistema ERP, pois migrei do ACBrNFSe para o ACBrNFSeX. Com o componente ACBrNFSe eu consigo validar normalmente a NFSe. No provedor Thema já consegui validar a NFSe, porém no provedor Tecnos me retorna esse erro. Estou utilizando o modo meAutomatico no método Emitir.
  12. Estou tentando enviar NFS-e para o provedor Tecnos de Arroio do Meio - RS com o componente ACBrNFSeX e recebo o seguinte erro: X202 - Lista de NFSe não encontrada! (ListaNfse) Em anexo os XML e Soap. 1458-env-lot-sinc.xml 1458-env-lot-sinc-soap.xml 1458-lista-nfse-sinc.xml 1458-lista-nfse-sinc-soap.xml
  13. Olá. Gostaria de saber se exite algum código homologado ACBr para a comunicação com o webservice do Bradesco, para emissão e registro de boletos online, sem o envio e recebimento de remessa diário.
  14. Olá. Se ainda está vendendo, pode mandar valores de DEMO para [email protected]
  15. Bom dia Italo. Muito obrigado pelo retorno. Funcionou perfeitamente. Segui suas orientações no tópico que você mencionou. Peço desculpas, eu não tinha visto esse seu tópico onde você explica bem o que precisa ser feito. Tem alguma configuração que eu possa fazer para acompanhar seus publicações e evitar futuros problemas? Idez.
  16. Boa tarde. Atualizei os fontes do ACBr e o cancelamento de NFS-e parou de funcionar no provedor Thema e também no provedor BHISS de Porto Alegre. Começou a dar erro no carregamento do XML na assinatura. Utilizo as seguintes configurações: Geral.SSLLib := libWinCrypt; Geral.SSLXmlSignLib := xsMsXml; Geral.SSLCryptLib := cryWinCrypt; Geral.SSLHttpLib := httpWinHttp; SSL.SSLType := LT_all; Com essas configurações dá o seguinte erro: raised exception class EACBrDFeException with message 'Não foi possível carregar XML Esse erro não acontecia antes da atualização dos fontes. Alterei as configurações para o seguinte: Geral.SSLLib := libOpenSSL; Geral.SSLXmlSignLib := xsLibXml2; Geral.SSLCryptLib := cryOpenSSL; Geral.SSLHttpLib := httpOpenSSL; SSL.SSLType := LT_all; Com essas configurações o provedor Thema está anulando novamente as NFS-e. O provedor BHISS começou a reportar o seguinte erro no cancelamento: raised exception class EACBrDFeException with message 'O documento XML de entrada do servico esta fora do padrao especificado. (ParseError at [row,col]:[1,422]Message: E esperado o fechamento do elemento CancelarNfseEnvio nessa posicao, mas foi encontrado um evento START_ELEMENT). Os erros somente acontecem no cancelamento. No envio estão funcionando normalmente. O que posso fazer para resolver esse erro?
  17. Felipe. Já descobri o meu erro. Peço que finalizem esse tópico. Obrigado pela atenção.
  18. Boa tarde Felipe. Sim estou passando essa informação.
  19. Boa tarde. Estou com problemas para validar o CTe-OS quando o transporte é dentro do estado. Entrou em vigor a Nota Técnica 2018.002 onde agora é obrigatório o Número do Registro Estadual para transporte dentro do estado. Para fora do estado o TAF é obrigatório. Atualizei os fontes e mesmo assim o XML não é preenchido com a informação de Numero de Registro Estadual. Estou passando essa informação em ACBrCTe1.Conhecimentos.Items[0].CTe.infCTeNorm.rodoOS.NroRegEstadual Aguardo orientações. IDEZ.
  20. Italo. Atualizei os fontes e está funcionando perfeitamente. Obrigado pela atenção! Idez.
  21. Sim, acrescentei essa cidade no Arquivo Cidades.ini. Já utilizo essa cidade desde 2017. Estava funcionando tudo normalmente. Atualizei o ACBr no inicio de Agosto e essa semana realizei alguns testes de emissão e apresentou esse problema. A emissão da NFS-e está funcionando corretamente. Somente o anular que está apresentando esse problema. Foi isso que acrescentei no Cidades.ini [4301008] Nome=Arroio do Meio UF=RS Provedor=Tecnos NomeURL_H=arroio NomeURL_P=arroiodomeio
  22. Olá Estou com o seguinte problema ao cancelar NFS-e provedor Tecnos Arroio do Meio - RS. Está levantando a exceção abaixo quando é executada a função xmldoc.loadXML. if (not xmldoc.loadXML( WideString(AXml) )) then raise EACBrDFeException.Create('Não foi possível carregar XML'+sLineBreak+ AXml); Acabei de atualizar os fontes e o problema persiste. Idez.
  23. Também estou com o mesmo problema. Estou contornando da seguinte forma: Envio o CTe e recebo a rejeição 106 - Lote não localizado Faço a consulta desse CT-e e me retorna a autorização. Ou seja, fazendo uma consulta posteriormente aí funciona.
  24. Bom dia. Tive o mesmo problema relatado acima. Para mim resolveu aplicando a configuração sugerida pelo Agnaldo Prates. Obrigado Agnaldo!!!
  25. idez

    Erro Aliquota ISS

    Boa tarde Italo. A alíquota no meu banco de dados está como Double Precision. Se eu passar 0.0333 fixo aí sempre funciona. Acredito que possa ser mesmo isso que você falou. Você recomenda utilizar Numeric no banco de dados? Ou qual seria a sua sugestão? Idez
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.