Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

click.png

click.png

click.png

Guaracy Gimenes

Membros
  • Posts

    43
  • Joined

  • Last visited

Everything posted by Guaracy Gimenes

  1. Boa tarde meus amigos! Já consegui dar um passo , imprimiu com o qrcode, porém saiu cortado na direita estou imprimindo na mp4000 TH.
  2. Entendo Sérgio, agradeço seu tempo. Tentei a impressora até com o cd dela , ela começa imprimir interrogação sem parar, não sei se atualizo o fimeware ou chamo um pastor. Vou tentar mais um pouco aqui. abraço.
  3. Então Sérgio , só não entendo pq quando uso o fortes DM_NFCe.ACBrSAT1.Extrato := ACBrSATExtratoFortes1; DM_NFCe.ACBrSATExtratoFortes1.ImprimeQRCode := true; DM_NFCe.ACBrSATExtratoFortes1.LarguraBobina := 312; DM_NFCe.ACBrSATExtratoFortes1.Margens.Topo := 0; DM_NFCe.ACBrSATExtratoFortes1.Margens.Fundo := 0; DM_NFCe.ACBrSATExtratoFortes1.Margens.Esquerda := 1; DM_NFCe.ACBrSATExtratoFortes1.Margens.Direita := 1; ele abre o preview como relatei na imagem acima , só que imprimi igual a imagem anexada do lado do preview
  4. Boa tarde Sérgio, tentei usar o EscPos, mas será que por a impressora estar na rede, tem alguma outra configuração que seria necessário fazer? Liguei a propriedade config do escpos no acbrSat1 e no código: ACBrSAT1.Extrato := ACBrSATExtratoESCPOS1; if ACBrSAT1.Extrato = ACBrSATExtratoESCPOS1 then begin ACBrPosPrinter1.Desativar; ACBrPosPrinter1.Modelo := TACBrPosPrinterModelo( 1 ); ACBrPosPrinter1.PaginaDeCodigo := TACBrPosPaginaCodigo( DM_NFCe.ACBrPosPrinter1.PaginaDeCodigo ); ACBrPosPrinter1.Porta := DM_NFCe.ACBrPosPrinter1.Device.Porta; ACBrPosPrinter1.ColunasFonteNormal := DM_NFCe.ACBrPosPrinter1.ColunasFonteNormal; ACBrPosPrinter1.LinhasEntreCupons := DM_NFCe.ACBrPosPrinter1.LinhasEntreCupons; ACBrPosPrinter1.EspacoEntreLinhas := DM_NFCe.ACBrPosPrinter1.EspacoEntreLinhas; ACBrSATExtratoESCPOS1.ImprimeQRCode := True; ACBrSATExtratoESCPOS1.ImprimeEmUmaLinha := DM_NFCe.ACBrNFeDANFeESCPOS.ImprimeEmUmaLinha; end; mas mesmo eu passando a porta o acbrdevice diz que a porta não esta definida.
  5. Entendi, como disse, não vai acontecer novamente. Então Juliomar , usamos a função do ACBR com intuito de gerar o xml e de fato gerou, mas quando validado no site , vários campos entram em contingência, não validamos no site antes. abraço.
  6. Juliomar eu entendo as regras do fórum , não estou querendo bagunçar, é só desespero mesmo, não vai acontecer de novo. Obrigado.
  7. Ok então, obrigado Sérgio. Sérgio agora minha prioridade esta sendo neste tópico abaixo, eu até consegui gerar o xml sem o certificado, mas quando vou validar no site da divergência em quase todos os campos. principalmente sobre as datas... Já usou o ACBRBlocox ? Meu chefe está homologando o sistema e precisa fazer validar as informações , porém não estamos obtendo sucesso. agradeço a atenção. Abraço.
  8. Boa noite galera, hoje sei que to enchendo vocês, mas estamos no primeiro dia da homologação. E o homologador pediu que os arquivos do bloco x ( xml estoque e da redução z) sejam validados pelo site https://sathomologa.sef.sc.gov.br/tax.NET/sat.siv.web/validacao.aspx Gostaria de saber se consigo fazer o teste sem o certificado digital... E gostaria de saber pq está dando este erro quando vou rodar o exemplo do acbr... Desde já agradeço a atenção de vcs.
  9. Sim amigo, tive que instalar o genérico, pois o drive da impressora não funcionou.
  10. Boa tarde pessoas! To com mais um problema no sat , se alguém passou por isso , gostaria de um help. Na tela de imprimir o comprovante sai tudo correto porém a impressão sai sem o qr code , cortado... Uso a impressora TM 81 pela rede. Obrigado.
  11. Juliomar deu certo amigo... Gerei novamente e validei , deu certo, devo ter apagado algum caracter sem querer... agora meu problema ta sendo sobre o sat se puder dar uma olhada te agradeço muito.
  12. Boa tarde amigos! Antes estava validando o arquivo MFD e o MF com Ecfc.exe. Agora não valida mais, alguém tem ideia do que possa ser? Obrigado.
  13. Certo, esqueci de postar que é sobre o sat, obrigado e desculpe o vacilo.
  14. Bom dia Senhores, tudo bem? Então tenho 2 duvidas caso alguém consiga me esclarecer, agradeço muito. Meu cliente está tentando imprimir Danfe por uma impressora na rede, porém ele não consegue. Simplesmente não imprimi. Tem alguma configuração para isso ? Segunda dúvida : Estou tentando usar o emulador do sat , para que tente fazer os testes para impressão na rede, so que no emulador agora da falha de comunicação : NumeroSessao: 681751 - Resposta:Erro|Erro na abertura da porta de comunicacao com o [email protected] já fiz oque pude, porém nada deu certo.. e se eu tento enviar o xml ele retorna acess violation... grato pela atenção de todos.
  15. Bom dia Senhores, tudo bem? Então tenho 2 duvidas caso alguém consiga me esclarecer, agradeço muito. Meu cliente está tentando imprimir Danfe por uma impressora na rede, porém ele não consegue. Simplesmente nao imprimi. Segunda dúvida : Estou tentando usar o emulador do sat , para que tente fazer os testes para impressão na rede, so que no emulador agora da falha de comunicação : NumeroSessao: 681751 - Resposta:Erro|Erro na abertura da porta de comunicacao com o [email protected] já fiz oque pude, porém nada deu certo.. e se eu tento enviar o xml ele retorna acess violation... grato pela atenção de todos.
  16. Juliomar, muito obrigado amigo, funcionou corretamente agora... abraço.
  17. Então Juliomar estou falando de Fortes, era pra ser o fortes a principio...
  18. Obrigado Juliomar, mas eu exclui todos RLs da pasta bpl do delphi, baixei a versão e mandei instalar e ele continua dando file not found ACBrNFeDANFEFR.dcu sera que tento instalar denovo pelo acbrInstall_trunk2 ?
  19. Boa tarde Régys, primeiramente agradeço sua atenção. Então eu tentei fazer como diz o arquivo leia-me , que é jogar os arquivos do fortes dentro da bpl na pasta do delphi... depois eu fui no executável do fortes... porém não obtive sucesso, será que devo instalar novamente o trunk2??
  20. Bom dia amigos, to com um problema aqui que to me batendo faz um tempo ja... tentei instalar o Fortes no delphi 7 . Mas quando vou compilar ele da a mensagem de erro dizendo que não tem o .dcu do ACBrNFeDANFEFR file not found ACBrNFeDANFEFR.dcu alguém que já passou por isso pode me auxiliar a instalar este querido ? abraço.
  21. Regys , boa tarde amigo. A chamada do metodo conforme sua orientação acima: ACBrECF.IdentificaPaf('Nome app', 'xxxxx') e colocamos ela no formPrincipal( primeiro a ser instanciado). Porém toda vez que abrimos a aplicação, imprime um md5 conforme foto em anexo. Isso é normal? Regys , boa tarde amigo. A chamada do metodo conforme sua orientação acima: ACBrECF.IdentificaPaf('Nome app', 'xxxxx') e colocamos ela no formPrincipal( primeiro a ser instanciado). Porém toda vez que abrimos a aplicação, imprime um md5 conforme foto em anexo. Isso é normal?
  22. Já consegui ver aqui, mas infelizmente nao da mais tempo de homologar =(, Obrigado pela atenção Juliomar
  23. quais parametros passar? alguém tem um exemplo ?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.