Jump to content

pcpag

Membros
  • Posts

    9
  • Joined

  • Last visited

Recent Profile Visitors

929 profile views

pcpag's Achievements

Rookie

Rookie (2/14)

  • First Post
  • Conversation Starter
  • Week One Done
  • One Month Later
  • One Year In

Recent Badges

3

Reputation

1

Community Answers

  1. Consegui acertar a margem neste cliente, usando a escala, colocando 116 na "NovaEscala", porém o campo quantidade ficou dentro de valor unitário, segue abaixo:
  2. Já tinha feito o teste com 0 em todas as margens e ai imprime, porém, como fica sem margem nenhuma, o cliente não gostou muito da aparência não. e o INI que me refiro, é um aquivo meu, que gravo as configurações, e depois leio e passo para o componente. Acho que pode ser algo relacionado a este post que fala: Se estiver usando o Fortes Report, pode ser um problema relacionado ao DPI. Nesse caso, verifique as novas propriedades "AlterarEscalaPadrao" e "NovaEscala". Não sei qual valor vai ser necessário ser passado, mas tente com 96 DPI para começar. Vou testar aqui e comunico o resultado.
  3. Oi Juliomar, tudo bem? Desculpe, acho que me expressei mal, quando falei via arquivo de configuração, quis dizer, via arquivo INI. Eu não utilizo o FastReport, utilizo o componente ACBrNFeDANFeRL, e passo via código as margens.
  4. Estou setando as propriedades das margens (MargemSuperior , MargemInferior, MargemEsquerda, MargemDireita) via arquivo de configuração e sempre funcionou em todos os clientes. Porém, recentemente, em alguns clientes, esta margem direita fica cortada. Percebi que estes clientes utilizam o Windows 7, não sei se tem algo a ver. Na minha maquina que é windows 10 e na maioria das maquinas, tudo está funcionando normalmente. Achei estranho pq não é um caso isolado, será que tem algo a ver com o Windows 7?
  5. Amigo, não sei se já resolveu, você tem que informar no propriedade modalidade (Cedente), conforme mensagem respondida em:
  6. Estava com o mesmo problema no Windows 10 x64 com Rad Studio Tokyo 10.2, na hora de abrir o Delphi, dava o erro Can't load package ...\LibD25\ACBr_NFe.bpl, etc... Mas apenas copiei as dlls da XMLSec para C:\Windows\SysWOW64 e parou de dar erro, tudo funcionando... Obrigado...
  7. Só para constar, pelo que entendi, pode sim, emitir a Nota referenciando cupons CFE-SAT e NFECe conforme Portaria CAT 106, de 10-09-2015. segue link http://info.fazenda.sp.gov.br/NXT/gateway.dll/legislacao_tributaria/portaria_cat/pcat1062015.htm?f=templates&fn=default.htm&vid=sefaz_tributaria:vtribut E conforme resposta do Sefaz postado pelo DQPS, não existe campo (tag) para referenciar no XML, eles recomendam referenciar no campo informações adicionais.
  8. Pessoal, eu estava com o mesmo problema, e mesmo após atualização continuava a dar a mesma mensagem de assinatura QRCode não é válida. Só consegui resolver a alterando o código abaixo: cTam1 := Length(ACodigo) mod 256; cTam2 := Length(ACodigo) div 256; antes cTam1 := Length(ACodigo) mod 255; cTam2 := Length(ACodigo) div 255; Ai sim consegui consultar sem erro. Ao ler o qrcode que consegui validar, no meu exemplo, está sendo gerado com 410 bytes, contra 411 bytes no que dá a mensagem de inválido, parece ter um espaço em branco a mais no final do código. Os testes foram feitos em um sat bematech para desenvolvedor e impressora bematech mp-4200 TH.
  9. Boa Tarde... Tive o mesmo problema aqui. Resolvi aqui além de declarar acima da implementation, abaixo foi necessário implementar também.: {$IFDEF DELPHI7} function CharInSet(C: AnsiChar; const CharSet: TSysCharSet): Boolean; begin Result := C in CharSet; end; function CharInSet(C: WideChar; const CharSet: TSysCharSet): Boolean; begin Result := (C < #$0100) and (AnsiChar(C) in CharSet); end; {$endif}
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.