Jump to content

Moacir Ezequiel Lamego

Membros
  • Content Count

    22
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Moacir Ezequiel Lamego

  • Rank
    Novato

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Bom dia, enviei umas 20 notas e ja estou conseguindo o retorno, eu fiz um ajuste no ACBrNFSeWebServices nas linha 1498, ficou assim: if FRetornoNFSe.ListaNFSe.MsgRetorno.Count > 0 then begin ProcSucesso := False; for i := 0 to FRetornoNFSe.ListaNFSe.MsgRetorno.Count - 1 do begin // Para tratar o retorno no NotaBlu // Daqui if fProvedor = proNotaBlu then begin FNotasFiscais.Items[0].NFSe.Numero := FRetornoNFSe.ListaNFSe.MsgRetorno.Items.ChaveNFeRPS.Numero; FNotasFiscais.Items[0].NFSe.CodigoVerificacao := FRetornoNFSe.ListaNFSe.MsgRetorno.Items.ChaveNFeRPS.CodigoVerificacao; FNotasFiscais.Items[0].NFSe.SeriePrestacao := FRetornoNFSe.ListaNFSe.MsgRetorno.Items.ChaveNFeRPS.SerieRPS; FNotasFiscais.Items[0].NFSe.NumeroLote := FRetornoNFSe.ListaNFSe.MsgRetorno.Items.ChaveNFeRPS.NumeroRPS; FNotasFiscais.Items[0].Confirmada := True; FProtocolo := FRetornoNFSe.ListaNFSe.MsgRetorno.Items.ChaveNFeRPS.CodigoVerificacao; end; // Até Aqui Resolveu meu problema Moacir. ACBrNFSeWebServices.pas
  2. Quanto ao retorno positivo, com a nota gerada temos o seguinte cenário: no fonte: pnfsLerListaNFSe na Linha 300, ele tenta achar uma tag e preencher uma variável "Nivel1", no final de vários testes se ela for verdadeira ele tenta extrair os valores, mas não fica positiva. Como estou muito tempo afastado do Delphi, alguém com mais conhecimento resolvera isto rapidamente.. XML de retorno que ele esta interpretando é este. <EnvioRPSResponse xmlns="http://www.sistema.com.br/Sistema.Ws.Nfse"> <EnvioRPSResult> <Cabecalho Versao="1"> <Sucesso>true</Sucesso> </Cabecalho> <ChaveNFeRPS> <ChaveNFe> <InscricaoPrestador>83904</InscricaoPrestador> <NumeroNFe>2223</NumeroNFe> <CodigoVerificacao>F4F2D65C6</CodigoVerificacao> </ChaveNFe> <ChaveRPS> <InscricaoPrestador>83904</InscricaoPrestador> <SerieRPS>1</SerieRPS> <NumeroRPS>773</NumeroRPS> </ChaveRPS> </ChaveNFeRPS> </EnvioRPSResult> </EnvioRPSResponse> Forçando o Nivel1 para true, o tratamento do retorno no NotaBlu esta vindo nas mensagens, e pelo que pude notar no fonte de origem (ACBrNFSeWebServices), quando o retorno de numero de nota vem pela mensagem nao tem tratativa. Posso estar viajando mas acho que o problema esta neste ponto... Ainda estou tentando entender as coisas aqui, mas como falei derrepente alguem com mais experiencia resolve rapidão.... Moacir.
  3. Quanto a mensagem de Erro, realmente o que vem do serviço é somente isto, boa sorte a todos em tratarem os erros em cada caso. <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"> <s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"> <EnvioRPSResponse xmlns="http://www.sistema.com.br/Sistema.Ws.Nfse"> <EnvioRPSResult> <Erro xmlns=""> <Codigo>900</Codigo> <Descricao>Chamada ao método retornou erro.</Descricao> </Erro> </EnvioRPSResult> </EnvioRPSResponse> </s:Body> </s:Envelope> Moacir.
  4. @Rejane Lingner Funcionou era este o problema, acho que assim como não estamos conseguindo pegar o resultado (XML) o erro também deve ter algo a ser feito, pois a mensagem não ajuda em nada. Com isso vou investigar mais. Porem estas regras já estão no sistema a muito tempo, vou analisar a nova documentação para ver sobre as obrigatoriedades. " CpfCnpj tcCpfCnpj 14 Caso Tomador não identificado, preencher com 11 0-1 zeros. " Muitíssimo obrigado a todos. Link da documentação. https://nfse.blumenau.sc.gov.br/contrib/app/nfse/manual_nfse_publico?itxt=s&ixml=s&etxt=s&exml=s&ck=0
  5. Boa noite, continuo tendo problemas, segue anexo os arquivos gerados. conforme solicitado. Moacir 770-ger-nfse.xml 770-ger-nfse-soap.xml 770-lista-nfse.xml 770-lista-nfse-soap.xml 4219090955290800018256000000000000770-rps.xml
  6. Estou tendo o erro 900, chamo o metodo gerar que abre o ACBrNFSE, na linha 508 ele chama o metodo WebServices.Gera(ARps, ALote); o ARps esta sendo passado 0(zero) o ALote esta sendo passado 770
  7. Boa tarde, Informação que me foi passada pelo Contador é que o Contrato da Cidade de Blumenau para com o servidor antigo de notas acaba dia 30/09/2019, se o puxadinho que fizeram foi para emitir pelo sistema antigo e se eu entendi bem foi o que eles fizeram só deve funcionar até segunda-feira dia 30. Pelo que o contador me contou esteve em uma reunião com a prefeitura e eles esperam estar com tudo funcionado até novembro, ou seja, estamos bem ferrados.. Moacir.
  8. Bom dia, utilizávamos uma versão mais atinga do ACBR e devido a alterações de alguns servidores (Prefeituras) eu optei por atualizar os componentes do ACBR para os mais atuais disponíveis, Acredito que estes campos possam ter sido deprecados, o que veio no lugar deles ? com isto aconteceram alguns problemas ja na compilação: Rotina: ACBrNFe1.DANFE.ImprimirItens := Boolean(BluConfiguracaoNfe.NFCEIMPRIMIRITENS); ACBrNFe1.DANFE.ImprimirDetalhamentoEspecifico:= Boolean(BluConfiguracaoNfe.NFCEIMPRIMIRDETALHAMENTO); ACBrNFe1.DANFE.ViaConsumidor := Boolean(BluConfiguracaoNfe.NFCEVIACONSUMIDOR); ACBrNFe1.DANFE.MargemEsquerda := BluConfiguracaoNfe.NFCEMARGEME; ACBrNFe1.DANFE.MargemDireita := BluConfiguracaoNfe.NFCEMARGEMD; ACBrNFe1.DANFE.MargemSuperior := BluConfiguracaoNfe.NFCEMARGEMS; ACBrNFe1.DANFE.MargemInferior := BluConfiguracaoNfe.NFCEMARGEMI; ACBrNFe1.DANFE.ProdutosPorPagina := BluConfiguracaoNfe.NFCEPRODUTOSPORPAGINA; ACBrNFe1.DANFE.TamanhoFonte_DemaisCampos := BluConfiguracaoNfe.NFCETAMANHOFOTNE; Erro [dcc32 Error] uNFe.pas(357): E2003 Undeclared identifier: 'ImprimirItens' [dcc32 Error] uNFe.pas(358): E2003 Undeclared identifier: 'ImprimirDetalhamentoEspecifico' [dcc32 Error] uNFe.pas(359): E2003 Undeclared identifier: 'ViaConsumidor' [dcc32 Error] uNFe.pas(364): E2003 Undeclared identifier: 'ProdutosPorPagina' [dcc32 Error] uNFe.pas(365): E2003 Undeclared identifier: 'TamanhoFonte_DemaisCampos' Também este: ACBrNFeDANFEFR1.DescricaoViaEstabelec := 'DANFE EM CONTINGÊNCIA, IMPRESSO EM DECORRÊNCIA DE PROBLEMAS TÉCNICOS. Sua consulta está disponível após 24 horas '; Erro [dcc32 Error] uNFe.pas(2564): E2003 Undeclared identifier: 'DescricaoViaEstabelec' Obrigado. Moacir.
  9. Bom dia, Decide/Italo se eu mudo para os parâmetros indicados acontece um erro, seguindo a execução o erro que acontece : '<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><EnvioRPSResponse xmlns="http://www.sistema.com.br/Sistema.Ws.Nfse"><EnvioRPSResult><Erro xmlns=""><Codigo>900</Codigo><Descricao>Chamada ao método retornou erro.</Descricao></Erro></EnvioRPSResult></EnvioRPSResponse></s:Body></s:Envelope>' No TDFeHttpWinHttp.Enviar o Comando Result := String( ReadStrFromStream(Resp, Resp.Size) ); // Verifica se o ResultCode é: 200 OK; 201 Created; 202 Accepted o Result é 0(zero)
  10. Boa tarde, não estou usando meu programa mesmo, só atualizei os fontes do acbr recompilei atualizei os ini e mandei bala. No meu programa esta configurado assim: NFSeACBR.Configuracoes.Geral.SSLCryptLib := cryCapicom; NFSeACBR.Configuracoes.Geral.SSLHttpLib := httpIndy; NFSeACBR.Configuracoes.Geral.SSLLib := libCapicomDelphiSoap; NFSeACBR.Configuracoes.Geral.SSLXmlSignLib := xsMsXmlCapicom; Pergunta, isso mudou ? Moacir.
  11. Boa tarde, continuo com o mesmo erro, Erro: Erro Interno: 0 Erro HTTP: 0 URL: http://wsblumenaumigracao.simplissweb.com.br/nfseservice.svc Erro ao ajustar INTERNET_OPTION_CLIENT_CERT_CONTEXT: 12046 Confirmei estou usando o Método Gerar, sim esta tudo atualizado tanto os ArqINI, SCHEMAS e fontes. Aponto para a pasta NotaBlu dos schemas. Ja não sei mais o que fazer, se outros estão conseguindo com certeza o problema esta aqui. Moacir.
  12. Bom dia, Atualizei os fontes, instalei o ACBR novamente, compilei o projeto copiei o ArqINI para o cliente da nova versão, alterei o Schema para a pasta do NotaBlu E ainda estou com um erro: Erro: Erro Interno: 0 Erro HTTP: 0 URL: http://wsblumenaumigracao.simplissweb.com.br/nfseservice.svc Erro ao ajustar INTERNET_OPTION_CLIENT_CERT_CONTEXT: 12046 Desculpem se estiver cometendo alguma gafe, meu dev responsável pela emissão de nota pediu as contas e me deixou no meio deste fogo cruzado. Obrigado. Moacir.
  13. Bom dia, Pessoal alguém conseguiu algo ? O Que estão fazendo com seus clientes ? Estamos chegando ao final do mês e os clientes estao com notas acumuladas, estou pensando em mandar os clientes emitirem notas pelo site o que vocês estão planejando ? Moacir.
  14. Bom dia, sou de Blumenau, estou na mesma que todos, se puder ajudar em algo me avisem que tomarei as providencias, Moacir.
×
×
  • Create New...