Jump to content

Promoção 25 Anos de Delphi
25% de desconto em todas as versões

Saiba mais

Ganhe o curso Tributação NF-e para Desenvolvedores

Assinando o SAC Anual este mês
botao.png

 

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Onclick

Usuários SAC
  • Content Count

    37
  • Joined

  • Last visited

Community Reputation

13 Good

1 Follower

About Onclick

  • Rank
    Membro

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Boa tarde Realizei os testes e comentando a linha ele está gerando os 2 xml's corretamente agora
  2. Bom dia, Consegui gerar o xml (*-guia.xml), porém ele gera apenas um xml, a function(TratarRespostaFinal) que gera o arquivo da um break após a geração da primeira guia.
  3. Bom dia Estou transmitindo a GNRE e não está gerando este XML. Coloquei as seguintes configurações ACBrGNRE.Configuracoes.Arquivos.SalvarTXT := True; ACBrGNRE.Configuracoes.Arquivos.Salvar := True; ACBrGNRE.Configuracoes.WebServices.Salvar := True; ACBrGNRE.Configuracoes.Geral.Salvar := True; E coloquei o Enviar(True) para ver se gerava o XML, mas não aparece, apenas os *-gnre.xml. Com estes configurações está sendo gerado 9 arquivos xml. Igual ao tópico citado acima. Falta alguma configuração do componente?
  4. Boa tarde, Mesmo enviando o XML citado, referente a cada guia, estou tendo problemas, está me retornando a seguinte mensagem. Estou enviando em anexo 2 XML's, ambos são do mesmo lote, cada xml é uma receita. A data, ao ler o XML está chegando vazia no momento de popular os dados para o fast. 1-gnre.xml 2-gnre.xml
  5. Nos meus testes não, o XML de envio também já possui as 2 guias juntas. Tentei dar Load no XML de envio, mas é me retornado erro referente a campo que não consegue ler.
  6. O sistema com qual eu trabalho não utiliza fortes, então não cheguei a realizar os testes nele, somente com o Fast mesmo.
  7. Boa tarde, Estou com um problema/dúvida em relação a impressão pelo fast report da GNRE, quando modelo 1 (múltiplas notas) e modelo 2 (múltiplas receitas), ao ler o XML de retorno para a impressão, ele não está retornando que existem 2 guias no xml, e sim apenas uma. A leitura do xml é realizada da seguinte forma: ACBrGNRE.GuiasRetorno.Clear; ACBrGNRE.GuiasRetorno.LoadFromFile(strUtils.IfThen(self.QConfigNFEGNRE_DIR_GERACAOXML.AsString = '', GetTemp(), self.Guia.VerificaDiretoriosGNRE(self.QConfigNFEGNRE_DIR_GERACAOXML.AsString, Funcoes.DataServidor)) + _nReciboAPI + '-pro-rec.xml'); for I := 0 to ACBrGNRE.GuiasRetorno.Count - 1 do begin ACBrGNRE.GuiasRetorno.Imprimir; end; Ao dar o Load pelo arquivo, é retornado apenas uma GuiasRetorno, e na impressão está trazendo os dados apenas de uma guia. É necessário alguma configuração no componente ou processo que estou realizando para a impressão está incorreto? Está em anexo um XML que possui 2 guias, modelo 1 (múltiplas notas). Obrigado desde já pela ajuda. 2000303044-pro-rec.xml
  8. Atualizei o componente e deu certo, não ocorre mais o erro referente a data. Estou com um outro problema/dúvida na impressão, mas irei abrir um tópico a parte para trata-lo melhor. Muito obrigado!
  9. Boa tarde Consegui realizar a atualização, porém o erro de data na impressão ainda persiste, uma coisa que esqueci de citar é que utilizo o Fast Report, então junto ao componente do ACBrGNRE eu tenho o ACBrGNREGuiaFR configurado com o GNRE_GUIA.fr3 (atualizado em 08/2019).
  10. Realizei os procedimentos passados porém o erro ainda persiste.
  11. Bom dia Estou com alguns problemas após a atualização do ACBr. Outros módulos do ACBr estão carregados corretamente, mas quando tento habilitar um que está relacionado a ACBr_DFeComum me deparo com este erro. Já atualizei as DLL's, BPL e DCP várias vezes e nada. Utilizo o Delphi 2010. Alguém poderia ajudar?
  12. Bom dia Estou tendo problemas com a atualização do ACBr, mas para não fugir do assunto do tópico irei criar um novo.
  13. A data no XML está com padrão americano, porém na impressão, quando a mesma é passada como parâmetro para a função de formatar Data ela já se encontra no nosso padrão.
  14. Me esqueci do XML. Segue em anexo. Obrigado 2000126290-pro-rec.xml
  15. Bom dia, Estou tendo alguns problemas quando mando imprimir a GNRE pelo componente através do XML da mesma. está me retornando que a data não é valida, o XML está com a data já formatada (por exemplo 28/01/2020), e na impressão ele tenta pegar essa data e formata-la novamente, o que ocasiona o erro. O XML foi gerado pelo ACBr também. A função para formatar a data se encontra na unit ACBrGNREGuiaFRDM. A data após passar pela função fica 28//0/1/20, o que impede a impressão. Alguém já teve o mesmo problema, ou poderia me ajudar? Muito obrigado desde já.
×
×
  • Create New...