Jump to content

Luis Vicente Costa

Membros
  • Posts

    42
  • Joined

  • Last visited

Everything posted by Luis Vicente Costa

  1. Para tentar contribuir, a questão é que tem diferente na passagem de parâmetro como o uso de TeContingencia e teOffLine, no caso ele utilizou o TeContingencia. Espero ter contribuído.
  2. Bom Dia, estou tendo a rejeição 705 - NFC-e com data de entrada/saída, ou seja, não informar a tag <dhSaiEnt> porém não estou enviando, nem mesmo tem disponível no componente, se fosse o caso de querer preencher. Tentei atualizar o componente, schemas, etc, porem não consigo transmitir a nota. Não identifiquei o que estou enviando incorretamente, ou faltando preencher, alguém pode dar aquela luz? <ide> <cUF>42</cUF> <cNF>72377580</cNF> <natOp>VENDA DE MERCADORIA</natOp> <mod>65</mod> <serie>1</serie> <nNF>900001</nNF> <dhEmi>2022-01-05T08:36:30-03:00</dhEmi> <tpNF>1</tpNF> <idDest>1</idDest> <cMunFG>4201406</cMunFG> <tpImp>4</tpImp> <tpEmis>1</tpEmis> <cDV>0</cDV> <tpAmb>2</tpAmb> <finNFe>1</finNFe> <indFinal>1</indFinal> <indPres>1</indPres> <indIntermed>0</indIntermed> <procEmi>0</procEmi> <verProc>211208</verProc> </ide>
  3. Boa tarde apenas para fechar o tópico e compartilhar, mesmo não sendo uso do ACBR. Percebi que o ambiente de testes no processo síncrono é bem instável quando realizado testes em massa. No ambiente de produção ficou tudo 100%.
  4. Boa tarde, realmente, não é possível, considero fechado o tópico.
  5. Ola pessoal, eu testei todas as UFs e realmente ainda se mantém disponível apenas para alguns estados poucos.
  6. Sim! Parti do exemplo. Funciona por muitas vezes, e simplesmente para de funcionar, e em seguida volta a carregar
  7. Boa tarde! Estou tentando utilizar o CONSULTACADASTRO, porem está retornando sem os dados. (ACBrNFe.WebServices.ConsultaCadastro.Executar; ) Estou passando UF e CNPJ conforme pede a função, Ambiente está em produção '<?xml version="1.0" encoding="UTF-8"?><soap12:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap12="http://www.w3.org/2003/05/soap-envelope"><soap12:Body><nfeDadosMsg xmlns="http://www.portalfiscal.inf.br/nfe/wsdl/CadConsultaCadastro4"><ConsCad xmlns="http://www.portalfiscal.inf.br/nfe" versao="2.00"><infCons><xServ>CONS-CAD</xServ><UF>SC</UF><CNPJ>CNPJDOCLIENTE</CNPJ></infCons></ConsCad></nfeDadosMsg></soap12:Body></soap12:Envelope>' Procurei no forum, e vi outro tópico sobre o assunto fechado, conferi sobre a questão de versão, e arquivos dos schemas, mas tenho tudo de acordo com o tópico fechado. Alguém teve problemas, ou pode me dar alguma possível solução? Grato!
  8. Tenho uma Dll em c# que chama este cara ai, -> .nfeAutorizacaoLote(xmlDoc.DocumentElement) e retorno que tenho é de que é impossível se conectar ao servidor remoto. Botei um catch (Exception ex) e trouxe esta mensagem mesmo. E estranho que funciona, emite tudo 100% e do nada, começa apresentar o erro, depois volta também, sei que o forum é sobre o ACBR, mas se a turma poder dar uma luz agradeço, como disse, estou migrando para acbr mas a versão ainda não está liberada.
  9. Considerando que trata-se de um tópico acredito que possa trazer uma outra situação. Se perceberem temos várias opções Ficheiro PDF... a primeira não faz nada, e os demais geram normalmente, seria apenas um bug do gerador de relatórios ou tem finalidades distintas e eu não estou sabendo utilizar? Grato!
  10. Olá pessoal! Estou tendo dificuldades com a migração do modo Assíncrono para Síncrono. Até então como não havia validação de lotes com apenas uma nota, eu acabava enviando sempre modo assíncrono, entretanto agora é necessário a mudança. Ocorre que frequentemente estou tendo como retorno "impossível se conectar com o servidor remoto" hora funciona, hora não funciona, podem me dar alguma luz? Não sei se isso é instabilidade do servidos homologação, ou o que, estranho é que se tentar emitir NF-e funciona. Alguém mais está tendo esta dificuldade, ou teve e conseguiu resolver. Agradeço a ajuda.
  11. Estou de volta! Coloquei ACBrDANFE.OtimizaImpressaoPdf e deu mais uma aliviada no PDF. Obrigado. Entretanto , após o comentário do nosso amigo Thobias em usar Thread, me lembrei que tivemos problema tempo atrás com o componente jvGifAnimator, estando habilitando a propriedade "Threaded" tinhamos alguns problemas, desabilitei e voltou ao normal Agradeço a força pessoal, Resolvido.
  12. Opa! Juliomar, cheguei nestes pontos abaixo, postei o fluxo dos pontos com perda de performance: Primeiro ponto de perda de performance (ACBRNFeDANFEFRDM) Linha 2078->Result := frxReport.PrepareReport; (frxClass)Linha 10808-> Result := FScript.Compile (fs_iinterpreter)Linha 2218->if p.MakeILScript(FLines.Text) then (fs_iilparser)Linha 600->if Run(FRoot.FindItem('program')) and (FErrorMsg = '') then Segundo ponto de perda de performance (frxClass)Linha 10884-> EngineRun := FEngine.Run(True); (frxEngine)Linha 334-> PreviewPages.AddSourcePage(FPage); Terceiro ponto de perda de performance (ACBRNFeDANFEFRDM) Linha 2087-> AjustaMargensReports; (ACBRNFeDANFEFRDM) Linha 2528-> frxReport.PreviewPages.ModifyPage(I, Page); Quarto ponto de perda de performance (ACBRNFeDANFEFRDM) Linha 2389-> frxReport.Export(frxPDFExport); (frxClass)Linha 11145-> FPreviewPages.Export(Filter); (frxPreviewPages)Linha 2539-> DoExport Em resumo, cada procedimento deste leva 1 segundo ou mais, no final do processo os, 3 ou 4 segundos que comentei.
  13. Olá pessoal! Tenho implementado a geração do DANFE em pdf a um bom tempo, e até então de acordo com os parâmetros que vimos tanto nos exemplos, quanto no forum: ACBrDANFE.IncorporarBackgroundPdf:=False; ACBrDANFE.IncorporarFontesPdf :=False; ACBrDANFE.OtimizaImpressaoPdf :=False; ACBrNFe.NotasFiscais.LoadFromFile(FPathNfe...',False); ACBrNFe.NotasFiscais.ImprimirPDF; Ps.: Tamanho da logo é de 19k Porém, durante o .imprimirPDF ele leva em torno de 3 a 4 segundos para gerar o arquivo, que ficam de 100k pra mais, (mesmo tendo poucos itens) Gerando individualmente, ok! 3 segundo, entretanto quando há a necessidade de gerar PDF de uma seleção de notas, este tempo é considerável. Podem me dar alguma luz, ou se é isso mesmo? Desde já obrigado!
  14. Bom Dia pessoal, fiz o chekc-out de tudo novamente, refiz os testes, e o que percebi foi que ainda está com problema quanto a emissão em ambiente de homologação. Enviando o tipo de venda 1-Presencial, a sefaz está obrigando enviar a tag <indIntermediario> Coloquei e passou. Resolvido! Obrigado pela força!
  15. <ide> <cUF>43</cUF> <cNF>00000115</cNF> <natOp>VENDA DE MERCADORIA</natOp> <mod>55</mod> <serie>2</serie> <nNF>25370</nNF> <dhEmi>2021-03-09T15:07:27-03:00</dhEmi> <dhSaiEnt>2021-03-09T16:07:27-03:00</dhSaiEnt> <tpNF>1</tpNF> <idDest>2</idDest> <cMunFG>4321667</cMunFG> <tpImp>1</tpImp> <tpEmis>1</tpEmis> <cDV>7</cDV> <tpAmb>2</tpAmb> <finNFe>1</finNFe> <indFinal>0</indFinal> <indPres>1</indPres> <indIntermed>0</indIntermed> <procEmi>0</procEmi> <verProc>210229</verProc> </ide>
  16. @Juliomar Marchetti, tentei também com os schemas do portal da NFe, sem sucesso. @BigWings Eu confirmei, schemas pegando do local correto, tentei um update novamente, e estou com os ultimos schemas comitados Sim Juliomar, por isso que vim aqui recorrer, realmente está bem estranho. Gerei novamente o XML, e tenho ali indPres = 1 e indIntermed = 0 sem sucesso também. Se meu indPres = 0 senão Estou passando desta forma;
  17. Julimar, eu tentei localizar e não encontrei. C:\trunk2\Exemplos\ACBrDFe\Schemas\NFe, tenho ali 144 arquivos, nenhum relacionado a homologação. Tentei localizar também na pasta trunck2 porem sem sucesso. Pode me passar o nome do arquivo, ou confirmar se o caminho que estou procurando está correto? Grato!
  18. Boa tarde pessoal! Estou tentando transmitir uma NFe: Enviando conforme acima, tenho esta mensagem: Element ' indIntermed' is unexpected according to content model of parent element Schemas atualizados Trunk2 Se tentar transmitir com indPres = 0 e IndIntermed = iiSemOperacao, funciona Já pesquisei em outros tópicos aqui e não consegui resolver, podem me dar uma força?
  19. Retornando aqui sobre meu questionamento, o erro estava na minha implementação . Obrigado!
  20. Obrigado pela resposta Italo, eu baixei os fontes semana passada, vou verificar a possibilidade de algum Bug, e retorno aqui.
  21. Olá boa tarde! Gostaria de saber se tem algum forma de o componente não mudar a formatação das palavras, por exemplo: Envio uma descrição de natureza de operação: "VENDA PADRÃO" ao gerar o XML fica "VENDA PADRãO" ou retirando acentos "VENDA PADRaO". gostaria de manter no padrão maiúsculo e ai sim, ter ou não acentos. Grato!
  22. É que hoje temos implementado DANFE e NFE sem uso do ACBR, porém estamos migrando, e os exemplos que encontrei são bem diferentes do DANFE que temos implementado, sabendo que os clientes tendem a ter restrições quanto a mudanças, queremos manter dentro do padrão que já utilizamos, sendo assim iremos redesenhar o da ACBR (Claro que mantendo o que rege o layout). E surgiu a dúvida de como inserir novos campo, vai que tenha necessidade de inserir alguma informação, etc. Apenas para confirmação Juliomar, mas pode me passar o caminho atual dos exemplos destes DANFEs, vai que estou desatualizado (srrs). Agradeço!
  23. No caso ele cria tudo ali no ACBRNFeDANFEFRDM certo? caso precise criar um campo novo, de uma nova TAG, e necessário criá-lo ali e assim, reinstalando componente fica disponível. É este o caminho?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.