Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Impressao Danfe Não Esta Exibindo Volumes


Go to solution Solved by André Ferreira de Moraes,
  • Este tópico foi criado há 3015 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Uso o fast Report ,

 

estou informando os campos de Volume, porém na impressão os mesmos estão saindo vazios, já tentei informar os dados via código fonte como descrito abaixo, porém sem sucesso...

Transp.Vol.Clear;
Transp.Vol.Add.qVol        :=  10;
Transp.Vol.Add.esp         :=  'ESPECIE';
Transp.Vol.Add.marca       :=  'MARCA';
Transp.Vol.Add.nVol        :=  '1';
Transp.Vol.Add.pesoL       :=  StrToCurr('10');
Transp.Vol.Add.pesoB       :=  StrToCurr('10');
Transp.modFrete            :=  mfContaEmitente;

O Único campo que é exibido é o PesoBruto.

 

para resolver eu já tentei Atualizar o Componente, Trocar o Arquivo DANFE.fr3 pelo mais atual , porém todas as tentativas sem sucesso...

 

 

os dados no XML estão corretos...

 

 

Alguém tem alguma ideia de como resolver?

 

Aguardo Respostas...

Edited by WilliamMattos
Link to comment
Share on other sites

  • Moderadores
  • Solution

Vc está adicionando 6 volumes, cada vez que vc chama Transp.Vol.Add um novo volume é criado.
 
Siga o demo e veja como criar corretamente as informações de volume.

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.