Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Nfc-E Autorizado O Uso, Mas Com Mensagem De Rejeição.


  • Este tópico foi criado há 2886 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Ola pessoal, não sei se este é o local correto de postar, caso não for peço ao administrador que mova o post, em meus testes com o monitor de nfe versão 0.9.0b concegui enviar as primeiras NFC-e, mas esta dando um erro na hora do retorno, o estranho é que primeiro aparece que o uso foi autorizado e depois fala que deu erro abaixo a saida do monitor.

 

NFe.CriarEnviarNFe("[infNFe]
versao=3.10
[identificacao]
cUF=51      
Codigo=00000006                        
NaturezaOperacao=VENDA AO CONSUMIDOR
FormaPag=0   
Modelo=65      
Serie=1           
Numero=000000002                           
Emissao=01/07/2014 16:28:37-16:28
indFinal=1
indPres=1
Tipo=1   
CidadeCod=5103379                     
tpAmb=2   
tpImp=4   
tpemis=1   
Finalidade=1   
procEmi=
verProc=2013822149                                                                      
dhCont=
xJust=
[Emitente]
CNPJ=07957206000153                                          
Razao=A C COM DE INFO E TEL LTDA
Fantasia=SOFTCORP INFORAMTICA
IE=133547078                                               
IEST=
IM=508                                                         
CNAE=4751201                     
CRT=1   
Logradouro=AV TAMBURELLO
Numero=70
Complemento=
Bairro=VILA NOVA
CidadeCod=5103379                     
Cidade=COTRIGUACU
UF=MT      
CEP=78330000
PaisCod=1058            
Pais=BRASIL
Fone=(66)3555-1943                                           
[Destinatario]
CNPJ=00919057101                                 
NomeRazao=ANDERSON JUNIOR GADO DA SILVA
IE=
indIEDest=9
Email=
Logradouro=AV TAMBURELLO
Numero=70
Complemento=
Bairro=VILA NOVA
CidadeCod=5103379                     
Cidade=COTRIGUACU
UF=MT      
CEP=78330000                        
PaisCod=1058            
Pais=BRASIL
Fone=
[Produto001]
nItem=1
infAdProd=
Codigo=1
EAN=
Descricao=TESTE
NCM=10011900                        
EXTIPI=
CFOP=5102            
Unidade=UN                      
Quantidade=1
ValorUnitario=10
ValorTotal=10
cEANTrib=
uTrib=UN                      
qTrib=1
vUnTrib=10
vFrete=0
vSeg=0
ValorDesconto=0
vOutro=0
IndTot=1   
xPed=00003                                                       
nItemPed=1                       
vTotTrib=2,01
[iCMS001]
Origem=0   
CST=
CSOSN=102         
Modalidade=
PercentualReducao=
ValorBase=0
Aliquota=0
Valor=0
ModalidadeST=
PercentualMargemST=
PercentualReducaoST=
ValorBaseST=
AliquotaST=
ValorST=
UFST=
pBCOp=
vBCSTRet=
vICMSSTRet=
motDesICMS=
pCredSN=
vCredICMSSN=
vBCSTDest=
vICMSSTDest=
[PIS001]
CST=07      
[COFINS001]
CST=07      
[Total]
BaseICMS=0
ValorICMS=0
BaseICMSSubstituicao=
ValorICMSSubstituicao=
ValorProduto=10
ValorFrete=0
ValorSeguro=0
ValorDesconto=0
ValorII=
ValorIPI=
ValorPIS=0
ValorCOFINS=0
ValorOutrasDespesas=
ValorNota=10
vTotTrib=2,01
ValorServicos=
ValorBaseISS=
ValorISSQN=
ValorPISISS=
ValorCOFINSISS=
[Transportador]
FretePorConta=9
[pag001]
tpag=01      
vpag=10
[DadosAdicionais]
Fisco=
Complemento=

",3,0,1)
OK: Autorizado o uso da NF-e
[ENVIO]
Versao=3.00
TpAmb=2
VerAplic=3.00
CStat=100
XMotivo=Autorizado o uso da NF-e
CUF=51
NRec=
DhRecbto=30/12/1899
TMed=0
Msg=Autorizado o uso da NF-e
Rejeicao: Falha no schema XML
[RETORNO]
Versao=3.00
TpAmb=2
VerAplic=3.00
NRec=0
CStat=215
XMotivo=Rejeicao: Falha no schema XML
CUF=51

ALERTA: Fim da Conexão com: 10.1.1.100 em: 01/07/14 16:25:52

 

atualizei a pasta de schemas pra ver se era isso mas cotinuou a dar a mesma mensagem, oque pode ser?

 

Att.

Anderson Junior
 

Link to comment
Share on other sites

depois de varias tentativas sem encontrar um motivo aparente para o comportamento tentei trocar o valor do parametro bSincrono para 0 no momento de enviar, e para minha surpresa funcionou corretamente, gostaria de um esclarecimento do pessoal porque agora fiquei perdido, segundo esse trecho:

 

NFe.CriarEnviarNFe(cArqINI,nLote,nImprimeDANFE,[bSincrono]) - Caso o parâmetro bSincrono seja igual a 1, a nota será enviada de forma síncrona(novo webservice disponibilizado pelo fisco exclusivamente para NFCe);

 

que esta no anuncio oficial da primeira versão compativel com NFc-e devemos enviar o parametro como sendo 1, mas sempre da o problema mencionado acima, ja quando coloco "0", funciona tanto para nfe quanto para nfc-e, como devo fazer?

 

Att.

Anderson Junior

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.